§ 2.3. Теорема Коши - Пикара

Часть I. Основы теории обыкновенных дифференциальных уравнений
Назад § 2.3. Теорема Коши — Пикара Вперед

В вас этот вопрос не решен, и в этом ваше великое горе, ибо настоятельно требует разрешения...

Ф. М. Достоевский. Братья Карамазовы

В этом параграфе доказывается одна из основных теорем теории обыкновенных дифференциальных уравнений-теорема существования и единственности решения задачи Коши.

2.3.1. Постановка задачи. Рассматривается задача Коши

x ў = f(t, x), (НС)

x(t0) = x0, (НУ)

состоящая из нормальной системы (НС) и начального условия (НУ). Предполагается, что

f: [a, b]×Rn ® Rn; (1)

функция f(t, x) непрерывна по t при любом фиксированном x; (2)

f(t, x) удовлетворяет по x условию
Липшица с некоторой константой L:
||f(t, x) – f(t, y)|| Ј L||x – y|| (t О [a, b]; x, y О Rn). 		(3)

Исследуется вопрос о существовании и единственности решения задачи (НС), (НУ) и изучается метод последовательных приближений для приближенного отыскания решения.

2.3.2. Последовательные приближения. Пусть

j0: [a, b] ® Rn — произвольная непрерывная функция (4)

Последовательные приближения, соответствующие начальному приближению j0, определим с помощью рекуррентной формулы

jk+1(t) = x0 + т t

t0 		f[s, jk(s)] ds.
(5)

Покажем индукцией по k, что функция jk(t) при любом k определена на всем отрезке [a, b] и непрерывна. Для k = 0 это совпадает с (4). Пусть jk(t) обладает указанными свойствами. Тогда в правой части (5) под интегралом стоит непрерывная на [a, b] функция — это следует из свойств jk и условий (1) – (3). Поэтому jk+1 также определена на [a, b] и дифференцируема, а следовательно, и непрерывна.

Итак, все последовательные приближения определены на [a, b] и непрерывны. Отметим еще, что из (5) вытекают два равенства

jўk+1 = f[t, jk(t)] (6)

и

jk+1(t0) = x0. (7)

2.3.3. Формулировка теоремы Коши — Пикара. Пусть выполнены условия (1) – (3). Тогда:

1) задача (НС), (НУ) имеет на [a, b] единственное решение j;

2) последовательные приближения (4), (5) сходятся на [a, b] к j, причем справедлива следующая оценка погрешности k-го приближения:

||jk(t) - j(t)|| Ј L2 ck
k!
 (8)
где

L2 = L1ec, L1 = ||j0 – j1||, c = L·(b – a),
L — константа из условия Липшица (3).

Д о к а з а т е л ь с т в о будет состоять из четырех лемм.

2.3.4. Замечание о единственности. Из сформулированной теоремы вытекает следующее усиленное утверждение о единственности: если j и y — любые два решения задачи (НС), (НУ), определенные не обязательно на всем отрезке [a, b], то они совпадают на D(j) З D(y). Действительно, если это не так, то найдется отрезок [a, b] М D(j) З D(y), на котором эти решения не тождественны. Но теорема Коши — Пикара, примененная на множестве [a, b] × Rn, утверждает, что это невозможно.

Переходим к доказательству теоремы.

2.3.5. Лемма о сближении. Пусть выполнены условия теоремы Коши — Пикара и j0, y0: [a, b] ® Rn — произвольные непрерывные начальные приближения. Утверждается, что для соответствующих последовательных приближений jk, yk (k = 1, 2, ...) справедливы неравенства:

||jk – k|| Ј L0 ck
k!
 (9)
где

L0 = ||j0 – y0||. (10)

Д о к а з а т е л ь с т в о. Индукцией по k покажем, что для любого k

||jk(t) – yk(t)|| Ј L0 Lk|t – t0|k
k!
 (t О [a, b]);
(11)

отсюда будет следовать (9). При k = 0 правая часть в (11) равна L0, и неравенство выполнено ввиду (10). Предположив, что (11) справедливо, докажем аналогичное неравенство с заменой k на k + 1 (в переходе от (12) к (13) мы используем условие Липшица, а от (13) к (14) — предположение индукции):

||jk+1(t) – yk+1(t)|| =

= ||x0 + т t

t0 		f[s, jk(s)] ds – x0 – т t

t0 		f[s, yk(s)] ds||

Ј к
к 		т t

t0 		||f[s, jk(s)] – f[s, yk(s)]|| ds к
к 		=

= м
п
н
п
о
т t

t0 		||f[s, jk(s)] – f[s, yk(s)]|| ds при t і t0
т t0

t 		||f[s, jk(s)] – f[s, yk(s)]|| ds при t < t0
ь
ч
э
ч
ю 		Ј
(12)

Ј м
п
н
п
о
L т t

t0 		||jk(s) - yk(s)|| ds при t і t0
L т t0

t 		||jk(s) - yk(s)|| ds при t < t0
ь
ч
э
ч
ю 		Ј
(13)

Ј м
п
н
п
о
L0Lk+1
k!
 т t

t0 		(s – t0)k ds при t і t0
L0Lk+1
k!
 т t0

t 		(t0 – s)k ds при t < t0
ь
ч
э
ч
ю 		=
(14)

= L0 Lk+1|t – t0|k+1
(k + 1)!
 .

Напомним, что ck/k! ® 0 при k ® Ґ; поэтому из (9) действительно следует, что jk и yk сближаются с ростом k.

2.3.6. Лемма о сходимости. В условиях теоремы Коши — Пикара последовательные приближения равномерно на [a, b] сходятся к некоторой функции j, причем

||jk - j|| Ј L2 ck
k!
 .
(15)

Д о к а з а т е л ь с т в о. Покажем, что последовательность {jk} фундаментальна в C. Сначала оценим ||jk – jk+1||. Для этого применим лемму о сближении к начальным функциям j0 и y0 = j1. Тогда, очевидно, yk = jk+1, L0 = ||j0 – y0|| = ||j0 – j1|| = L1 и, следовательно,

||jk – jk+1|| Ј L1 ck
k!
 .

Отсюда получаем оценку для ||jk - jp|| (p > k):

||jk – jp|| Ј
Ј ||jk – jk+1|| + ||jk+1 – jk+2|| + ... + ||jp – 1 – jp|| Ј
Ј L1 p – 1
е
i = k
 ci
i!
 Ј L1 Ґ
е
i = k
 ci
i!
 Ј L1 = L1Pk
(16)

где Pk ® 0 при k ® Ґ как остаток сходящегося ряда.

Итак, последовательность {jk} фундаментальна, поэтому в силу полноты пространства C она сходится в норме этого пространства к некоторой функции j О C. Для получения неравенства (15) оценим Pk:

Pk = Ґ
е
i = k
 ci
i!
 = ck
k!
 Ґ
е
i = k
 ci–kk!
i!
 Ј ck
k!
 Ґ
е
i = k
 ci–k
(i – k)!
 ,

поскольку при i і k, очевидно, i! і k!(i – k)!. Введем теперь новую переменную суммирования j = i – k:

ck
k!
 Ґ
е
i = k
 ci–k
(i – k)!
 = ck
k!
 Ґ
е
i = k
 cj
j!
 = ck
k!
 ec.

Отсюда и из (16) предельным переходом при p ® Ґ получаем (15).

2.3.7. Лемма о существовании. В рассматриваемых условиях предел последовательных приближений j есть решение задачи (НС), (НУ).

Д о к а з а т е л ь с т в о. Заметим, что jўk(t) равномерно сходится к f[t, j(t)], т. к. при k і 1 (см. (6))

||jўk(t)– f[t, j(t)]|| = ||f[t, jk–1(t)] – f[t, j(t)]|| Ј

Ј L||jk–1(t) – jk(t)||.

Итак, jk(t) ® j(t) при k ® Ґ и jўk(t)Ю j(t) при k ® Ґ (t О [a, b]). По теореме Вейерштрасса о дифференцировании функциональных последовательностей отсюда следует равенство jў(t) = f[t, j(t)]. Кроме того, j(t0) = limk®Ґjk(t0) = x0.

2.3.8. Лемма о единственности. В условиях теоремы Коши — Пикара решение задачи (НС), (НУ) на [a, b] единственно.

Д о к а з а т е л ь с т в о. Если j и y — решения этой задачи на [a, b], то построим последовательные приближения jk, yk, соответствующие начальным приближениям j0 = j, y0 = y. Из (6), (7) в этом случае видно, что jk = j, yk = y при любом k. Но тогда из леммы о сближении следует, что j = y.

Доказательство теоремы Коши — Пикара завершено.

2.3.9. Контрольные вопросы

2.3.9.1. Найдите последовательные приближения, начинающиеся с функции j0(t) є 1 для задачи Коши

x ў = x, x(0) = 1. (17)

2.3.9.2. Удовлетворяет ли задача Коши (17) условиям теоремы Коши — Пикара?

2.3.9.3. Покажите, что

Ґ
е
k = 0
 tk
k!
 = et.

2.3.9.4. Задача Коши

tx ў = x, x(0) = 0

имеет по крайней мере два решения x = 0 и x = t. Почему этот факт не противоречит теореме Коши — Пикара?

2.3.9.5. Может ли уравнение x ў = f(t, x) с удовлетворяющей условиям теоремы Коши — Пикара правой частью f: R×R ® R иметь общее решение вида t(t2 + C)?

2.3.9.6. Найдите решение интегрального уравнения

x(t) = 1+ т t

0 		x(s) ds.

2.3.10. Задачи

2.3.10.1. Докажите, что в условиях теоремы Коши — Пикара последовательные приближения, начатые с произвольной непрерывной функции либо все различны, либо, начиная с некоторого номера, совпадают.

2.3.10.2. Пусть функция f(t, x) непрерывно дифференцируема по совокупности переменных k раз. Докажите, что последовательные приближения, начатые с произвольной непрерывной функции, начиная с (k + 1)-го, непрерывно дифференцируемы k + 1 раз.

2.3.10.3. Для любого натурального K постройте пример задачи Коши, у которой последовательные приближения, начатые с произвольной непрерывной функции, совпадают при k і K, а последовательные приближения, начатые с некоторой непрерывной функции, попарно различны при k < K.

2.3.10.4. Докажите, что задача Коши

x ў1 = min{x1, x2}, x ў2 = max{x1, x2},

x1(0) = 1, x2(0) = 1

имеет единственное решение на любом промежутке, содержащем точку 0.

2.3.10.5. Аналогичный вопрос для задачи Коши

x ў = max{t, x},

x(0) = 0.

2.3.10.6. Методом последовательных приближений найдите решение задачи Коши

x ў1= x1 + x2, x ў2= x2 + 1,

x1(0) = 0, x2(0) = 0.

2.3.10.7. Методом последовательных приближений найдите решение задачи Коши

x ў1= x2, x ў2= –x1,

x1(0) = 0, x2(0) = 1.

2.3.10.8. Методом последовательных приближений найдите решение задачи Коши

x ў = x + 1, x(0) = 0

на отрезке [–1, 1] с точностью 10–1.

2.3.10.9. Покажите, что задача Коши

x ў = (tg t)·sin (t + x), x(0) = 0

имеет на интервале (–p/2, p/2) единственное решение.

File based on translation from TEX by TTH, version 2.32.
Created 4 Jan 2002, 13:43.
Last modified 11 Apr 2002.