§ 3.3. Линейные системы с постоянными коэффициентами

Часть I. Основы теории обыкновенных дифференциальных уравнений
Назад § 3.3. Линейные системы с постоянными коэффициентами Вперед

... и потом я еще такое слыхал: то, что мы называем природой, это, говорят, вроде гончара, который делает сосуды из глины, и коли он слепил один красивый сосуд, стало быть, может слепить их и два, и три, и целую сотню.

Мигель де Сервантес Сааведра. Хитроумный идальго Дон Кихот Ламанчский

Как отмечалось в предыдущем параграфе, общего способа отыскания фундаментальной матрицы для (ЛОС) нет. Для линейной автономной однородной системы

x ў = Ax, (ЛАОС)

в которой матрица A не зависит от t, такой способ существует. Он будет изучен в этом и следующем параграфах.

3.3.1. Метод последовательных приближений. Рассмотрим матричную задачу Коши

X ў = AX, (МУ)

X(0) = I, (МНУ)

которая определяет фундаментальную матрицу (ЛАОС), нормальную в точке t0 = 0. (МУ) есть линейное однородное уравнение с неизвестной функцией, принимающей значения в n2-мерном пространстве Mn квадратных n×n-матриц.

По теореме Коши — Пикара решение этой задачи можно получить методом последовательных приближений. Положим

j0(t) є I.

Тогда

j1(t) = I + т t

0 		AI ds = I + At,

j2(t) = I + т t

0 		A(I + As) ds = I + At + A2t2
2
 ,

j3(t) = I + т t

0 		A ж
и 		I + As + A2s2
2
 ц
ш 		ds = I + At + A2t2
2
 + A3t3
3!
 , ... .

Очевидно,

jN(t) = N
е
k = 0
 Aktk
k!

Таким образом, функции jN(t) являются частичными суммами ряда

Ґ
е
k = 0
 Aktk
k!
 (1)

и известно, что они сходятся (равномерно на любом отрезке [a, b] О R) к решению F0(t) задачи (МУ), (МНУ). Следовательно,

F0(t) = Ґ
е
k = 0
 Aktk
k!
 .
(2)

По аналогии со случаем, когда A есть не матрица, а число, сумму матричного ряда (1) обозначают через eAt и называют экспонентой матрицы At (или матричной экспонентой):

eAt = Ґ
е
k = 0
 Aktk
k!
 ;

из теоремы Коши — Пикара нам известно, что этот ряд сходится равномерно на любом отрезке.

Итак, формула (2), или, что то же,

F0(t) = eAt,

определяет фундаментальную матрицу (ЛАОС), нормальную в точке t0 = 0. Это представление не всегда удобно, так как оно требует вычисления суммы бесконечного матричного ряда. Наши дальнейшие усилия будут направлены на то, чтобы разработать "конечный" алгоритм вычисления фундаментальной матрицы вида eAtP, где P — некоторая постоянная невырожденная матрица.

Отметим еще, что eAt есть матрица оператора сдвига gt (= g0t) в естественном базисе, поскольку

gt(x0) = eAtx0 —

решение (ЛАОС) с начальным условием

x(0) = x0. (НУ)

3.3.2. Пример: разложение el t с комплексным l в ряд. Применим формулу (2) к скалярной комплексной задаче Коши:

z ў = l z (l = a + i b), (3)

z(0) = 1 (4)

и обозначим

y0(t) = Ґ
е
k = 0
 lktk
k!
 .
(5)

Решение задачи (3), (4) для произвольной функции l = l(t) было найдено в п. 3.2.3:

z = y0(t) = exp ж
и 		т t

0 		l(s) ds ц
ш 		=

= exp ж
и 		т t

0 		a(s) ds ц
ш 		й
л 		cos ж
и 		т t

0 		b(s) ds ц
ш 		+ isin ж
и 		т t

0 		b(s) ds ц
ш 		щ
ы 		.

В случае постоянного l

z = el t = ea t(cos b t + isin b t).

Отсюда для решения y0(t) задачи (3), (4) получаем представление в виде экспоненты:

y0(t) = el t = ea t(cos b t + isin b t).

Таким образом, формула (5) означает, что экспонента с комплексным показателем раскладывается в степенной ряд точно так же, как с вещественным:

el t = Ґ
е
k = 0
 lktk
k!
 .

В следующем пункте в очередной раз напоминаются сведения из курса линейной алгебры.

3.3.3. О жордановой нормальной форме матриц. Пусть A — квадратная n×n-матрица с вещественными или комплексными элементами. Утверждается, что ее можно представить в виде

A = PJP–1, (6)

где

P — некоторая невырожденная матрица (приводящая A к жордановой форме),

J = J1 Е J2 Е ... Е Jp — жорданова нормальная форма матрицы A,

M1 Е M2 =
ж
з
и
M1 | 0
0 | M2
 ц
ч
ш
— прямая сумма матриц M1 и M2,

Jk = Jk1 Е Jk2 Е ... Е Jkqk — жорданов блок (k = 1, 2, ..., p),

Jks = lkIr + Ir(1) — жорданова клетка (s = 1, 2, ..., qk),

lk — собственное значение матрицы A, т. е. такое комплексное число, при котором уравнение

Ax = lkx (7)

имеет ненулевые решения (собственные векторы) относительно x,

p — число различных собственных значений, равное числу жордановых блоков,

qk — геометрическая кратность собственного значения lk, равная размерности собственного подпространства, т. е. пространства решений уравнения (7),

Ir — единичная матрица размерности r = r(k, s),

Ir(1) — матрица, полученная из Ir сдвигом единичной диагонали на одну позицию вправо,

rk = еqks=1r(k, s)— алгебраическая кратность собственного значения lk, равная размерности блока Jk.

3.3.4. Выражение eAt через экспоненты жордановых клеток. Пусть A представлена в виде (6). Утверждается, что

eAt = PeJtP–1, (8)

eJt = Е p
е
k = 1
 Е qk
е
s = 1
 eJ ks t,
(9)

где Ее обозначает прямую сумму матриц.

Д о к а з а т е л ь с т в о. По определению,

eAt = Ґ
е
m = 0
 Amtm
m!
 ,
(10)

Из (6) следует, что

Am = PJ

P–1P
I
 JP–1 ... PJP–1 = PJmP1.

Поэтому

N
е
m = 0
 Amtm
m!
 = P ж
з
и 		N
е
m = 0
 Jmtm
m!
 ц
ч
ш 		P–1.

Предельным переходом при N ® Ґ получаем (9). Равенство (8) вытекает из (9) и того известного в алгебре факта, что умножение, сложение и умножение на скаляры матриц одинаковой блочно-диагональной структуры можно производить поблочно:

eJt = Ґ
е
m = 0
 Jmtm
m!
 = Ґ
е
m = 0
 ж
з
и 		Е p
е
k = 1
 Е qk
е
s = 1
 Jks ц
ч
ш 		m

 tm
m! 		=

= Е p
е
k = 1
 Е qk
е
s = 1
 ж
з
и 		Ґ
е
m = 0
 (Jks)mtm
m!
 ц
ч
ш 		.

3.3.5. Вычисление экспоненты жордановой клетки. Экспонента жордановой клетки Jks = lkIr + Ir(1) вычисляется по следующей формуле:

eJ ks t = elk t ж
з
з
з
з
з
з
з
з
з
з
з
з
з
з
з
з
з
з
и
1 | t | t2 2! | ... | tr–3 (r – 3)! | tr–2 (r – 2)! | tr–1 (r – 1)!
0 | 1 | t | ... | tr–4 (r – 4)! | tr–3 (r – 3)! | tr–2 (r – 2)!
0 | 0 | 1 | ... | tr–5 (r – 5)! | tr–4 (r – 4)! | tr–3 (r – 3)!
: | : | : | · · · | : | : | :
0 | 0 | 0 | ... | 1 | t | t2 2!
0 | 0 | 0 | ... | 0 | 1 | t
0 | 0 | 0 | ... | 0 | 0 | 1
 ц
ч
ч
ч
ч
ч
ч
ч
ч
ч
ч
ч
ч
ч
ч
ч
ч
ч
ч
ш
(11)

Д о к а з а т е л ь с т в о. В следующем пункте мы покажем, что если AB = BA, то eA+B = eAeB. Поэтому

eJ ks t = elk I r t · eI r(1)t (12)

так как единичная матрица Ir коммутирует с любой матрицей. Далее,

elk I r t = Ґ
е
m = 0
 (Ir)mlkmtm
m!
 = ж
з
и 		Ґ
е
m = 0
 lkmtm
m!
 ц
ч
ш
Ir = elk tIr.

 (13)

Напомним известный из алгебры факт: (Ir(1))m = Ir(m) — это матрица, полученная из Ir сдвигом единичной диагонали на m позиций вправо, в частности, если m > r – 1, то (Ir(1))m = 0. Следовательно,

eI r(1)t = r – 1
е
m = 0
 Ir(m)tm
m!
 .
(14)

Из (12), (13) и (14) следует (11).

3.3.6. Утверждение об экспоненте суммы. Если матрицы A и B коммутируют, то

eA+B = eAeB. (15)

Д о к а з а т е л ь с т в о. Мы докажем тождество

e(A+B)t = eAteBt, (16)

которое при t = 1 превращается в (15). Левая часть в (16) есть решение матричной задачи

X ў = (A + B)X, X(0) = I, (17)

а сомножители в правой части — соответственно решения матричных задач

X ў = AX, X(0) = I,

X ў = BX, X(0) = I.

Вся правая часть (16) при t = 0, очевидно, равна I. Покажем, что она удовлетворяет матричному уравнению (17):

d
dt
 (eAteBt) = deAt
dt
 eBt + eAt deBt
dt
 = AeAteBt + eAtBeBt.

Поскольку A и B коммутируют и eAt есть сумма ряда из степеней A со скалярными коэффициентами, eAt также коммутирует с B. Поэтому

AeAteBt + eAtBeBt = AeAteBt + BeAteBt = (A + B)eAteBt.

Итак, правая часть в (16), как и левая, есть решение задачи (17), поэтому они тождественны.

3.3.7. Контрольные вопросы

3.3.7.1. Методом последовательных приближений найдите фундаментальную матрицу системы

x ў1= x2, x ў2= 0.

3.3.7.2. Методом последовательных приближений найдите фундаментальную матрицу системы

x ў1 = x2, x ў2 = x1, x ў3 = 0.

3.3.7.3. Как по eAt определить нормальную в точке t0 фундаментальную матрицу (ЛАОС)?

3.3.7.4. Непосредственной постановкой убедитесь, что функция y0(t) = ea t(cos b t + i·sin b t) является решением уравнения z ў = l z.

3.3.7.5. Покажите, что замена переменных x = Py приводит (ЛАОС) к системе y ў = P – 1APy.

3.3.8. Задачи

3.3.8.1. Покажите, что если eAt є eBt, то A = B.

3.3.8.2. Докажите, что P–1eAtP = eP–1 APt для любой невырожденной матрицы P.

3.3.8.3. Докажите, что при всех x0 О Kn

lim
t ® +0
(eAt – I)x0
t
 = Ax0

3.3.8.4. Пусть gt: Kn ® Kn — семейство линейных операторов и gt+s є gtgs при всех t, s О R. Докажите, что если предел

A =
lim
t ® +0
gt – I
t

существует, то gt = eAt.

3.3.8.5. Покажите, что ||eAt|| Ј e||A||·|t|.

3.3.8.6. Зная фундаментальную матрицу F(t) (ЛАОС) и F–1(0), найдите F–1(t).

3.3.8.7. Покажите, что если матрица A блочно-диагональна, т. е.

A = ж
з
з
з
з
з
з
з
з
и
A1
0
A2
A3
· · ·
0
Ak
ц
ч
ч
ч
ч
ч
ч
ч
ч
ш 		,

то

eA = ж
з
з
з
з
з
з
з
з
и
eA 1
0
eA 2
eA 3
· · ·
0
eA k
ц
ч
ч
ч
ч
ч
ч
ч
ч
ш 		.

3.3.8.8. Докажите, что det eAt = et·Tr A, где Tr A = еni=1aii— след матрицы A.

3.3.8.9. Докажите, что

eAt =
lim
k ® Ґ
 ж
и 		I + At
k
 ц
ш 		k

 .

Покажите, основываясь на полученном равенстве, сходимость метода ломаных Эйлера для (ЛАОС).

3.3.8.10. Приведите пример матриц A и B таких, что e(A+B) № eAeB.

3.3.8.11. Коммутантом двух матриц A и B называется матрица [A, B] = AB – BA. Покажите, что если

[A, [A, B]] = [B, [A, B]],

то

eA+B = eA eB e[A, B]/2 = eB eA e[B, A]/2.

3.3.8.12. Докажите формулу Хаусдорфа

eBAe – B = A + [B, A]
1!
 + [B, [B, A]]
2!
 + [B, [B, [B, A]]]
3!
 + ... .

3.3.8.13. Пусть матрица линейной системы

x ў = A(t)x

коммутирует со своим интегралом, т. е.

A(t) т t

t0 		A(s) ds = ж
и 		т t

t0 		A(s) ds ц
ш 		A(t)
(18)

при всех t0, t О R. Покажите, что F(t) = exp(т tt 0A(s) ds) является нормальной в t0 фундаментальной матрицей этой системы. (Случай, выделяемый условием (18), называется случаем Лаппо — Данилевского.)

File based on translation from TEX by TTH, version 2.32.
Created 10 Jan 2002, 14:28.
Last modified 16 Apr 2002.