Электронный учебник

Последний уровень раздела предыдущего изложения Текущий уровень изложения предыдущего раздела Текущий уровень изложения следующего раздела Первый уровень изложения следующего раздела Уровень:

Эквивалентные преобразования моделей ВСВ и канонические представления

Как отмечалось в п. 3.1.1, возможны различные способы выбора переменных состояния динамической системы. Неоднозначность такого выбора определяет неединственность моделей вход-состояние-выход [М4], [М5] (или [М6], [М7]), соответствующих конкретной модели вход-состояние [M1] ([М2] или [М3]), так как выбор иных переменных состояния приводит к получению другой модели ВСВ. С другой стороны первоначальная модель ВСВ может быть специально преобразована, что обычно связывают с изменением базиса (системы координат) пространства состояний [image] . Такого рода преобразование называется эквивалентным, или преобразованием подобия .

3.4.1. Эквивалентное преобразование . Пусть модель вход-выход одноканальной системы (объекта управления) задается операторным уравнением

(3.93) a(p)y(t) = b(p)u(t),

где

.

и [image] - корни характеристического уравнения (полюсы системы), или уравнением [М3] , где

(3.94) [image] ,

а модель ВСВ получена в форме [М6], [М7]. Введем в рассмотрение новый (преобразованный) вектор состояния:

(3.95) [image] ,

где [image] - матрица преобразования (подобия), удовлетворяющая условию [image] . Тогда существует обратное преобразование

(3.96) [image] .

Дифференцируя (3.95) и подставляя (3.96), [М6] находим:

(3.97)

и

(3.98) [image] .

Полученные выражения перепишем в виде

[М6*] [image] ,

[М7*] [image] ,

где

(3.99)

(матрица подобная A),

(3.100) [image] ,

(3.101) [image] .

Подобные матрицы имеют следующие свойства:

а)

б )

Модель [М6* ], [М7* ] называется эквивалентной (подобной) модели [М6], [М7]. Справедливо очевидное свойство:

(3.102) [image] [image] ,

т.е. для подобных систем сохраняются связи выходных и входных переменных, а следовательно и модели ВВ [М1], [М2], [М3].

3.4.2. Канонические представления моделей ВСВ . Наиболее простые модели вход-состояние-выход, соответствующие исходным уравнениям системы [М6], [М7], называются каноническими представлениями ( формами ).

Диагональной формой называется модель, представленная уравнениями состояния

(3.103)

и уравнением выхода

(3.104) [image] .

(рис. 3.24). Модель может быть записана в компактной форме [М6*] [M7*], где

, [image] , [image] .

К диагональной форме приводятся системы с различными полюсами [image] [image] . При этом (см. п. 3.1.3) матрицы основной и преобразованной системы связаны соотношением

(3.105) [image] ,

т.е. матрица преобразования находится как

(3.106) [image] .

Рис. 3.24. Структурная схема канонической (диагональной) формы

Модель полностью управляемой системы [10] может быть приведена к управляемой (фробениусовой)) канонической форме

(3.107)

и

(3.108) [image] ,

(рис. 3.25). Этой форме соответствуют векторно-матричные уравнения [M6*] [M7*], в которых

, [image] ,

C*=[bn bn-1 ... b2 b1],

и [image] - коэффициенты уравнения (3.107),

aT=[-an - an-1 ... -a2 -a1], 0=[0 0...0 0] T,

I - единичная матрица размера ( n-1) [image] (n- 1). Матрица состояния [image] называется сопровождающей матриц ей полинома [image] или Фробениусовой матрицей.

Рис. 3.25. Каноническая управляемая форма

Матрица преобразования к канонической управляемой форме находится как

(3.109) P=U*U -1,

где U и U* - матрицы управляемости исходной [10] и канонической [10] модели соответственно. Для случая n =3 имеет место:

.

Модель полностью наблюдаемой системы (см. [10]) может быть приведена к наблюдаемой (фробениусовой)) канонической форме вида :

(3.110)

и

(3.111) [image] ;

(рис. 3.26). Этой канонической форме соответствуют векторно-матричные уравнения [M6*] [M7*], где [image] - сопровождающая (фробениусова) матрица вида

, [image] , [image] ,

Рис. 3.26. Каноническая наблюдаемая форма

Матрица преобразования находится как

(3.112) P=(Q*)-1Q ,

где Q и Q* - матрицы наблюдаемости исходной и канонической модели [10]. Для случая n =3 имеет место:

.