Небольшая заметка про чтение научных книг - PALMZ

Правила форума
Помощь
Поиск
Пользователи
Календарь
Чат

Искать только в этом форуме?
Дополнительные параметры
[X]
Помощник
Загрузка. Пожалуйста, подождите... Загрузка. Пожалуйста, подождите...
X Сообщение сайта
(Сообщение закроется через 2 секунды)

Здравствуйте, гость ( Вход | Регистрация )

> PALMZ > Общие вопросы > КНИГИ
[X]
Что в чате
· Зайти в чат · Архив
> Небольшая заметка про чтение научных книг, Чтение научных книг на Palm и Pocket PC, конвертация djvu, pdf, latex
Опции V
V Подписка на тему
V Сообщить другу
V Версия для печати
V Скачать тему
V Подписка на этот форум
Режимы отображения
V Переключить на: Древовидный
V Переключить на: Стандартный
V Линейный
anton_nazarov Просмотр профиля | сообщение 14.5.2007, 19:07 Сообщение #1
Группа: Пользователи Сообщений: 7 Регистрация: 5.3.2006 Пользователь №: 20 833 PDA: Sony CLIE SJ20 MOBILE: Motorola T260 Вставить ник Цитата | Я написал небольшую статью про конвертацию и чтение научных книг и статей в Palm на основе собственного опыта. Надеюсь, что информация будет полезна. Статья Английская версия Буду благодарен за любые комментарии и предложения, а так же за рекламу статьи на других сайтах
Вернуться в начало страницы | Ответить с цитированием данного сообщения
2 страниц V 1 2 >
Перейти к странице
 Открыть тему
Ответов (1 - 19)
kiot Просмотр профиля | сообщение 14.5.2007, 19:34 Сообщение #2
[AD-SIZE] Звездочёт Группа: Опытные пользователи Сообщений: 768 Регистрация: 27.2.2005 Из: Великий Устюг Пользователь №: 10 612 PDA: palmOne Tungsten|T5 MOBILE: Sony Ericsson T610 Вставить ник Цитата | Выложите здесь - будут комментарии. -------------------- Было: Palm Vx, Palm m505. Сейчас: palmOne Tungsten|T5 + Kingston SD 1Gb + Palm Wireless Keyboard.
Вернуться в начало страницы | Ответить с цитированием данного сообщения
anton_nazarov Просмотр профиля | сообщение 14.5.2007, 19:38 Сообщение #3
Группа: Пользователи Сообщений: 7 Регистрация: 5.3.2006 Пользователь №: 20 833 PDA: Sony CLIE SJ20 MOBILE: Motorola T260 Вставить ник Цитата | Цитата(kiot @ 14.5.2007, 20:34) [snapback]359361[/snapback] Выложите здесь - будут комментарии. Хорошо, только форматирование сделаю.
Вернуться в начало страницы | Ответить с цитированием данного сообщения
anton_nazarov
Просмотр профиля
сообщение 14.5.2007, 20:05
Сообщение #4

Группа: Пользователи
Сообщений: 7
Регистрация: 5.3.2006
Пользователь №: 20 833
PDA: Sony CLIE SJ20
MOBILE: Motorola T260

Вставить ник
Цитата
Чтение с экрана PDA

Вы наверняка встречали в интернет множество статей на эту тему, но у меня тоже есть чем поделиться

Сейчас появились специальные устройства для чтения, такие, как Sony Read, которые могут быть удобнее, но у PDA (наладонников и смартфонов) есть свои преимущества, например, невысокая цена и небольшие размеры, большой выбор программ для чтения и конвертеров различных форматов файлов.
Многие покупают наладонники специально для чтения.

Есть две основные линии PDA: устройства, использующие Palm OS и устройства на базе Windows CE/Pocket PC/Windows Mobile.

Я, например, использую старый наладонник Sony Clie SJ20 с операционной системой Palm OS 4, который прекрасно подходит для чтения. У него отличный черно-белый экран с высоким разрешением, не требующий подсветки, а кроме того, заряда аккумулятора хватает очень надолго (до 2 недель при ежедневном использовании).

Если вы являетесь владельцем наладонника или современного смартфона, то вы наверняка знаете как читать с вашего устройства.
Тем не менее, я начну с элементарных вещей, а потом перейду к более продвинутым советам.

Простое чтение

Если документ, который вы хотите прочитать, есть у вас на компьютере в каком-нибудь текстовом формате (простой текст, html, MS-Word), то вы можете просто скопировать его на ваш PDA и читать с помощью соответствующих программ, например Documents To Go на Palm или Pocket Word/Pocket IE на Pocket PC.

Однако есть более удобный способ - книгу можно конвертировать в формат, предназначенный для чтения с PDA, и читать при помощи специальных программ.
Я использую iSilo, так как этот формат поддерживает сложное форматирование и картинки, и для него есть удобный графический конвертер iSiloX, который работает под Windows и Linux под wine, а также конвертер под Mac и Linux с интерфейсом командной строки.

Многие пользователи Pocket PC предпочитают HaaliReader.
Кроме того, есть множество других подобных программ.

Теперь рассмотрим чтение более сложных документов.

Чтение книг в формате Chm

Это достаточно распространённый формат для компьютерной литературы. У владельцев Pocket PC не должно быть с ним никаких проблем.

Chm представляет собой скомпилированный html, поэтому его нужно распаковать для конвертации в iSilo.
В Windows это можно сделать используя команду

Код
hh.exe -decompile Destination_Directory filename.chm

Я привык использовать набор небольших утилит KeyTools, для работы с chm. Он работает в Linux под wine
Полученный html можно затем конвертировать в iSilo.

Чтение PDF

С форматом PDF все несколько сложнее.

Существуют разные виды PDF-документов.
С PDF документами, содержащими только текст, все просто - можно выделить весь текст и вставить его в текстовый редактор, а потом конвертировать в iSilo или ваш любимый формат для чтения. Кроме того, некоторые читалки для Palm и Pocket PC поддерживают такие PDF-документы прямо на наладоннике, или в конвертере.
Кроме того, такие PDF документы можно сначала превратить в html используя Adobe Acrobat или pdftohtml, чтобы сохранить форматирование.

Правда даже для текстовых PDF документов это работает далеко не всегда, так как PDF-документы могут использовать нестандартные шрифты, которых нет на PDA. Обычно это становится проблемой для научных текстов, так как формулы безвозвратно портятся при конвертировании.

Другой вид PDF-документов - это документы, состоящие из картинок, например, отсканированные книги.
Такие документы не удаётся сконвертировать в PDA при помощи уже описанных методов, так как картинки не помещаются на экран наладонника или смартфона.

Но у меня есть несколько идей на этот счет.

Чтение сканированных книг

Сканированные книги обычно удаётся распознать, используя программы для автоматического распознавания текста, такие как FineReader, а затем конвертировать текст в подходящий формат для чтения (iSilo, FictionBook и т.д.).
К сожалению, FineReader и подобные программы совершенно беспомощны при работе с книгами, содержащими формулы

Поэтому обсудим чтение научных документов отдельно.

Чтение научных документов

В интернет можно найти огромное количество научных книг и статей

Например большинство новых статей по физике и математике выкладываются в свободный доступ в arxiv. Кроме того, у вас может быть доступ к электронным версиям научных журналов через системы вроде Metapress, ScienceDirect или |Scopus.

Статьи обычно выкладываются в формате PDF или PostScript, но в arxiv-e можно также скачать исходный код статей, обычно в формате LaTeX.
Это очень удобно, так как LaTeX легко конвертировать в html с помощью TeX4ht.

Конвертация LaTeX в html с TeX4ht

Чтобы воспользоваться TeX4ht, вам придётся установить:
  • LaTeX, вы можете использовать дистрибутив miktex для Windows, или установить LaTeX из пакета в вашем дистрибутиве Linux
  • сам TeX4ht, он входит в состав новых версий miktex, а также в дистрибутивы и репозитории Linux
  • ImageMagick для конвертации формул в картинки, эта библиотека также входит в большинство дистрибутивов Linux
Если вы работаете под Windows, у вас могут быть некоторые проблемы с TeX4ht, тогда вам поможет этот документ.

После того, как вы установили все необходимое, вы можете сконвертировать документ LaTeX (например, статью из [[http://arxiv.org|arxiv-а]]) с помощью команды:
Код
htlatex your_tex_file_name "html,pic-m"

Ключ "html,pic-m" указывает TeX4ht, что нужно конвертировать файл в html, а формулы представить в виде картинок. Дополнительную информацию о использовании TeX4ht можно почерпнуть из руководства.

Полученные html-файлы можно конвертировать в iSilo или читать в Pocket IE.

К сожалению исходный код статей и книг в формате LaTeX доступен не часто.
Но есть и другие методы.

Распознавание научных текстов с помощью InftyReader

Если ваш документ имеет хорошее качество, то его можно попробовать распознать программой InftyReader.
Эта программа распознает формулы и английский текст.
Вы можете скачать пробную версию, и использовать её для перевода документов в TeX. Затем их можно конвертировать с помощью TeX4ht.

Проблема состоит в том, что документ должен быть действительно хорошего качества. Кроме того, не поддерживаются другие языки, кроме английского.

Чтение сканированных научных книг

Многие научные книги и старые статьи доступны только в сканированном виде, в виде картинок, обычно упакованных в PDF или DJVU.
Например, большое количество русских и англоязычных книг доступно в библиотеке Колхоза или в библиотеке мехмата МГУ (правда доступ к этим библиотекам ограничен).
Отсканированные старые статьи есть на сайтах издательств, таких как Springer.
Обычно качество этих книг и статей не слишком хорошее в целях уменьшения объёма, поэтому их не удаётся распознать InftyReader-ом.

Читаем DJVU

Есть несколько читалок DJVU для PocketPC/Windows Mobile, например ExpressView от Lizerdtech - создателей формата DJVU.
Я могу порекомендовать две программы:
  • PocketDJVU - эта свободная программа достаточно стабильная и быстрая, но если у вас смартфон или наладонник с экраном qVGA (240х320), то читать будет не слишком удобно, так как будет слишком мелко или придётся скролить страницу из стороны в сторону.
  • SmartDJVU - коммерческая программа, созданная фирмой Inscenic. У этой программы есть отличная возможность - она может переносить строки текста, используя информацию из текстового слоя документа DJVU. Текстовый слой достаточно просто создать в DocumentExpress от Lizardtech. Однако SmartDJVU достаточно нестабильна (судя по отзывам в форумах), а кроме того, разработчики заявляют, что новых версий не будет, так как программа не приносит им дохода. Тем не менее, эта идея очень удачная.
Итак, для Pocket PC есть неплохие просмотрщики DJVU, поэтому чтение книг в формате djvu не должно вызывать проблем, если у вас есть Pocket PC с VGA (640x480) экраном.

Но если у вас Palm или смартфон с другой OS, или вам не удаётся добавить текстовый слой в djvu документ, то вам нужен другой способ.
Кроме того, не существует способа распознать рукописный текст, а значит и добавить текстовый слой в djvu документы с рукописным текстом, например в конспекты.

Преобразование сканированных документов с Fit2PDA

Вы можете воспользоваться моей программой Fit2PDA для преобразования книг или других сканированных документов.
Принцип её работы очень прост: Fit2PDA разделяет страницы сканированной книги на строчки и делит строки на части, помещающиеся на экран PDA. Пример работы можно посмотреть здесь.
Fit2PDA сгенерирует html с картинками с шириной равной ширине экрана вашего наладонника или смартфона.

Скачайте Fit2PDA со страницы проекта, запустите fit2pda.exe или fit2pda.
Затем добавьте книги в программу и выберите параметры конвертации: ширину экрана вашего устройства, желаемое разрешение (dpi - точек на дюйм, 170-190 dpi для новых Palm-ов или Pocket-ов, 70-90 dpi для старых Palm-ов и Pocket-ов, 96 или 130 dpi для смартфонов).
Кроме того, вам может понадобиться разбиение получающегося html-документа с картинками на части, так как некоторые программы на некоторых устройствах не могут отображать документы с большим числом больших картинок.
После этого нажмите на кнопку convert и выпейте чашечку кофе [image] , так как конвертация займёт довольно много времени.
Полученный html документ можно конвертировать в iSilo (не забудьте снять галочку с пункта "Resize large images") или читать в Pocket IE.

Fit2PDA может использоваться для преобразования рукописных конспектов, как можно видеть здесь на нижней картинке, но для этого нужно предварительно улучшить качество изображения, в особенности контраст, и избавиться от клеточек.

Вы можете написать мне письмо, а также почитать мой блог для получения дополнительной информации о Fit2PDA.

Заключение

Я использовал все описанные методы конвертирования докумнтов и прочел много научных статей и книг на моем наладоннике.
PDA могут быть не самыми лучшими устройствами для чтения, но они очень удобны.

Оригинал

Английская версия

Сообщение отредактировал anton_nazarov - 14.5.2007, 21:34
Вернуться в начало страницы
Ответить с цитированием данного сообщения
ViSoR Просмотр профиля | сообщение 14.5.2007, 20:18 Сообщение #5
Группа: TEAM Сообщений: 1 018 Регистрация: 7.6.2005 Из: Минск Пользователь №: 12 502 PDA: palmOne Tungsten|E2 + Palm T|X MOBILE: Nokia 6233 Вставить ник Цитата | anton_nazarov, поменяйте тег [cоdebox] на [соde] -------------------- Sony Clie SL10 + MS Apacer 64Mb (увели) -> palmOne Tungsten|E2 + Palm T|X + SD Transcend 80x 1Gb + MMC 32Mb (типа раритет) iPod Nano 4Gb black, Canon PowerShot S3 IS, Dell Inspiron 9400.
Вернуться в начало страницы | Ответить с цитированием данного сообщения
anton_nazarov Просмотр профиля | сообщение 14.5.2007, 21:35 Сообщение #6
Группа: Пользователи Сообщений: 7 Регистрация: 5.3.2006 Пользователь №: 20 833 PDA: Sony CLIE SJ20 MOBILE: Motorola T260 Вставить ник Цитата | Цитата(ViSoR @ 14.5.2007, 21:18) [snapback]359372[/snapback] anton_nazarov, поменяйте тег [cоdebox] на [соde] Спасибо за подсказку, я что-то сразу не нашёл.
Вернуться в начало страницы | Ответить с цитированием данного сообщения
andrufka Просмотр профиля | сообщение 15.5.2007, 10:24 Сообщение #7
Группа: Разработчик PALMZ Сообщений: 99 Регистрация: 10.10.2005 Пользователь №: 17 030 PDA: Tungsten E MOBILE: Motorola Вставить ник Цитата | Выглядит очень заманчиво. Однако мне не удалось запустить конвертацию. Какая-то проблема с GS. Ругается: AFPL Ghostscript 8.00: Can't find initialization file gs_init.ps. Запускал под XP SP2. -------------------- Tungsten E + 1Gb SD
Вернуться в начало страницы | Ответить с цитированием данного сообщения
Mar00k
Просмотр профиля
сообщение 15.5.2007, 10:34
Сообщение #8

askr [drífu Háars]

Группа: TEAM
Сообщений: 1 774
Регистрация: 2.2.2005
Из: Минск, Беларусь; Орёл, Россия
Пользователь №: 9 929
PDA: TE -> T5
MOBILE: Treo 650

Вставить ник
Цитата
На palmos 5 для чтения сложных статей на мой взгляд лучшее - repligo. В статье почему-то не упомянут.
Сам же для чтения регулярно использую isilo, repligo, doctogo8.

--------------------
мы не должны смотреть вверх, на то что неизмеримо выше нас.
мы не должны смотреть вниз, на то, что нас недостойно.
мы должны всегда смотреть вперёд на Путь, что ждёт нас впереди
Вернуться в начало страницы
Ответить с цитированием данного сообщения
borka Просмотр профиля | сообщение 15.5.2007, 10:43 Сообщение #9
Группа: Опытные пользователи Сообщений: 239 Регистрация: 9.3.2006 Пользователь №: 20 906 PDA: T615C + m505 + TT3 MOBILE: SE t68i Вставить ник Цитата | Repligo на PalmOS5 действительно хорош, _но_ 1) Для машинок на ОС4 он не подходит. 2) Если у нас отсканированная и не распознанная книга, то читать им неудобно - в постраничном виде он не умеет перелистывать на следующую страницу джойстиком) - если оригинал был широкий и ландскейп не помогает, то приходится делать скролл влево-вправо, что, в общем, ещё тот кошмар P.S. Пошёл смотреть FIT2PDA.... P.P.S. Комплект для скачки не полный - если не поставить дополнительно AFL ghostscript, то работать вообще не будет. Скачал какую-то версию 8.0, поставил на c:\gs\... Теперь что-то делает. Посмотрим. Сообщение отредактировал borka - 15.5.2007, 10:59
Вернуться в начало страницы | Ответить с цитированием данного сообщения
Mar00k Просмотр профиля | сообщение 15.5.2007, 10:55 Сообщение #10
askr [drífu Háars] Группа: TEAM Сообщений: 1 774 Регистрация: 2.2.2005 Из: Минск, Беларусь; Орёл, Россия Пользователь №: 9 929 PDA: TE -> T5 MOBILE: Treo 650 Вставить ник Цитата | А чем не устраивает flowed text в repligo? Вытягивает текст в 1 колонку по ширине, всё ок. -------------------- мы не должны смотреть вверх, на то что неизмеримо выше нас. мы не должны смотреть вниз, на то, что нас недостойно. мы должны всегда смотреть вперёд на Путь, что ждёт нас впереди
Вернуться в начало страницы | Ответить с цитированием данного сообщения
borka Просмотр профиля | сообщение 15.5.2007, 11:18 Сообщение #11
Группа: Опытные пользователи Сообщений: 239 Регистрация: 9.3.2006 Пользователь №: 20 906 PDA: T615C + m505 + TT3 MOBILE: SE t68i Вставить ник Цитата | Если текст распознан, то, конечно устраивает (или почти устраивает). Я же говорил про случай, когда текст не распознан. Т.е. исходник - просто упакованный набор абстрактных картинок. Да, а flowed текст иногда глючит. В смысле, конечно, не он сам, а глючат не совсем корректно сделаные PDF-rи. Вот сейчас читал PDF, там от страницы к страницы прыгает размер шрифта. Причем заметно, примерно как при переключении размера в "text size". Очень неудобно anton_nazarov Да, ошибок тут есть. Попробовал запустить с десяток PDFов, реакция была от падения с треском до ничегонеделанья. Вот примерно на одиннадцатом делает что-то осмысленное. Вопрос - где удобнее вести обсуждение софта? Могу описать падение и дать примеры
Вернуться в начало страницы | Ответить с цитированием данного сообщения
andrufka Просмотр профиля | сообщение 15.5.2007, 11:33 Сообщение #12
Группа: Разработчик PALMZ Сообщений: 99 Регистрация: 10.10.2005 Пользователь №: 17 030 PDA: Tungsten E MOBILE: Motorola Вставить ник Цитата | RepliGo нераспознанный текст тоже отображает в flowed режиме. Однако формулы при этом разваливаются на части. И читать их в таком виде невозможно. Тем и интересна предлагаемая программа, что строчки не распадаются на отдельные символы, как в RepliG. Правда у меня нифига не работает. А так супер конечно -------------------- Tungsten E + 1Gb SD
Вернуться в начало страницы | Ответить с цитированием данного сообщения
borka Просмотр профиля | сообщение 15.5.2007, 11:43 Сообщение #13
Группа: Опытные пользователи Сообщений: 239 Регистрация: 9.3.2006 Пользователь №: 20 906 PDA: T615C + m505 + TT3 MOBILE: SE t68i Вставить ник Цитата | Цитата(andrufka @ 15.5.2007, 12:33) [snapback]359433[/snapback] RepliGo нераспознанный текст тоже отображает в flowed режиме. Ой? А как, интересно, он может умудряться это делать, если нераспознанный текст - это всего лишь картника По крайней мере у меня он пишет "There is no flowed text to show" или как-то так.
Вернуться в начало страницы | Ответить с цитированием данного сообщения
andrufka Просмотр профиля | сообщение 15.5.2007, 12:03 Сообщение #14
Группа: Разработчик PALMZ Сообщений: 99 Регистрация: 10.10.2005 Пользователь №: 17 030 PDA: Tungsten E MOBILE: Motorola Вставить ник Цитата | Примерно также, как и предлагаемая программа. Если RepliGo считает, что на странице один текст без картинок, даже не распознанный, то прекрасно отображает страницу в flowed. Если у вас "грязные" сканы в PDF или в DJVU, то вы можете сами сконвертировать документ в набор TIFF-картинок. Затем почистить их в каком-либо графическом редакторе. И распечатать эти картинки на RepliGo-принтер. И читать в flowed-режиме. -------------------- Tungsten E + 1Gb SD
Вернуться в начало страницы | Ответить с цитированием данного сообщения
piloclip
Просмотр профиля
сообщение 15.5.2007, 12:17
Сообщение #15

Группа: Пользователи
Сообщений: 45
Регистрация: 20.2.2004
Пользователь №: 5 177
PDA: Palm TE, Sony SL10, Palm T5
MOBILE: Nokia 3310

Вставить ник
Цитата
Не знаю, упоминалась ли эта программа на форуме, но я пользуюсь для "нераспознаваемых сканов" только ей!
http://files.ebook.googlepages.com/Setup.exe
топик по ней
http://www.the-ebook.org/forum/viewtopic.p...p;postorder=asc
если коротко - программа преобразует djvu или pdf (и кое что другое) в серию картинок.
В отличие от RepliGo это можно сделать "по умному" - нарисовать на страничке рамочек и каждая рамка породит свою картинку (также можно делать и спецформаты для ебуков, собсно для этого программа и рождена, картинки - приятное дополнение).
Очень мне понравилось, как программа "размыливает" шрифт - ясное дело, читается хуже, чем в исиле, но это - лучший вариант для сканов, который я видел. Рамочки придется настраивать отдельно для четных и нечетных страниц, даже если скан разворотами.
Я выбираю куски с наложением на 1-2 строки и (если листы не А4 в одну колонку), сохраняю сразу в jpeg 320*480, 8 градаций серого. Получается в несколько раз больше djvu размером, зато листается мгновенно.
Иногда встречал глюк - при конвертации рамки съезжали и картинки выходили кривые. Я тогда еще сразу проверял результат и стал фиксить - расставив рамки выбираю команду "Все страницы инд.", теперь даже не проверяю - сразу на флешку.
Если еще не сказал - программа десктопная - картинки на пальме можно смотреть любой Image-программой (картинки размером с экран в масштабе 1:1 любая осилит).

Попутно вопрос - какая гляделка умеет запоминать текущую позицию чтения - сейчас пользуюсь ... TCMP, но это, понятно, не совсем решение. А другие запоминать последнюю картинку научить не смог.

Возможно, программа стоит отдельного топика - для HiRes+ это, единственное приемлимое для меня решение по сканам, даже при наличии альтернатив (RepliGo, GrxView, DjvuDecode, различных Pdf-ридеров)

ЗЫ - осознаю, что ссылка на другой форум - дурной тон, но это - единственная замена Help'a
Вернуться в начало страницы
Ответить с цитированием данного сообщения
borka Просмотр профиля | сообщение 15.5.2007, 12:29 Сообщение #16
Группа: Опытные пользователи Сообщений: 239 Регистрация: 9.3.2006 Пользователь №: 20 906 PDA: T615C + m505 + TT3 MOBILE: SE t68i Вставить ник Цитата | andrufka, если честно, то за всё время, сколько я пользуюсь RepliGo у меня она ни разу не "смогла" сделать flow на нераспознанный текст. Если вам не сложно, выложите куда-нибудь такой нераспозанный документ (можно буквально одну страничку pdf/tiff) и соответствующий RGO? Очень интересно, серьёзно....
Вернуться в начало страницы | Ответить с цитированием данного сообщения
andrufka Просмотр профиля | сообщение 15.5.2007, 12:39 Сообщение #17
Группа: Разработчик PALMZ Сообщений: 99 Регистрация: 10.10.2005 Пользователь №: 17 030 PDA: Tungsten E MOBILE: Motorola Вставить ник Цитата | Для сомневающихся в способности RepliGo показывать нераспознанный текст в flowed-режиме прилагаю пример. В архиве исходная страничка в виде картинки TIFF и файл RGO, полученный из этой картинки. Прикрепленный файл 62.zip ( 73,85 килобайт ) Кол-во скачиваний: 5 -------------------- Tungsten E + 1Gb SD
Вернуться в начало страницы | Ответить с цитированием данного сообщения
borka
Просмотр профиля
сообщение 15.5.2007, 13:00
Сообщение #18

Группа: Опытные пользователи
Сообщений: 239
Регистрация: 9.3.2006
Пользователь №: 20 906
PDA: T615C + m505 + TT3
MOBILE: SE t68i

Вставить ник
Цитата
andrufka, большое спасибо, а то бы я себе голову сломал

В общем, ситуация такая. Если пользоваться RepliGoMobilizer, то потом flow сделать нельзя. Я попробовал присланную картинку -> PDF -> RGO. Получился файл 70К, никакого flow.

Если напечатать напрямую на принтер, то RGO уже всего 15К. И flow!!

Я никогда этого не замечал, потому что бросил пользоваться принтером почти сразу (только иногда презентации, если надо их вычитать), т.к. он на большинстве djvu/pdf просто виснет на какой-нибудь странице. Видимо (я так теперь это думаю) он как раз пытается вставить разметку для flow, и обламывается....

Теперь ищется средство, как такой "виснущий" PDF образумить и заставить нормально печататься. Как "почистить" скан?

piloclip

А этот JaP умеет широкий текст резать ? (который as-is на палме мелковат, если всё впихивать по ширине, чтобы "без скролла"). Т.е. что-то типа flow, как RepliGO и вот Fit2PDA? А то сделал он мне 4 картинки из страницы, но как теперь это читать, если полстрочки в одной картинке, полстрочки - в другой?

Или программа просто не для этого предназначена?
Вернуться в начало страницы
Ответить с цитированием данного сообщения
andrufka Просмотр профиля | сообщение 15.5.2007, 13:39 Сообщение #19
Группа: Разработчик PALMZ Сообщений: 99 Регистрация: 10.10.2005 Пользователь №: 17 030 PDA: Tungsten E MOBILE: Motorola Вставить ник Цитата | Проблему с вылетанием RepliGo при печати зачастую можно решить разбиением большого файла на части. Т.е. печатать страниц по 50-100. -------------------- Tungsten E + 1Gb SD
Вернуться в начало страницы | Ответить с цитированием данного сообщения
borka Просмотр профиля | сообщение 15.5.2007, 14:02 Сообщение #20
Группа: Опытные пользователи Сообщений: 239 Регистрация: 9.3.2006 Пользователь №: 20 906 PDA: T615C + m505 + TT3 MOBILE: SE t68i Вставить ник Цитата | Так, нашёл проблему. В действительности, я немного неправильно её сформулировал. Иногда реплиго виснет на одной странице мёртво, вне зависимости от того, сотая это страница документа, или одна единственная. Я поэкспериментировал, и до меня дошло. Реплиго не переваривает отсканированные "тексты" на которых есть мусор - вертикальные или горизонтальные полосы вдоль текста. Обычно они получаются от границ книги при сканировании. Соответственно, алгоритм. 1) gs-ом разбиваем pdf на картинки. (Наверное, можно и Acrobat'ом, не суть) 2) Прогоняем их через Skan Kromsator и кропом убиваем все такие полоски. Заодно despekle / deskew 3) Собираю обратно multi-page tiff через irfanview 4) Печатаю из того же irfanview все страницы на Реплиго в один документ. Вопрос, для пунктов 3-4 есть что-то более быстрое, т.е., например, выбрать много-много файлов и печатать их батчем? Пытался через Microsoft Photo Printing Wizard - после него не делает flow почему-то
Вернуться в начало страницы | Ответить с цитированием данного сообщения
« Предыдущая тема · КНИГИ · Следующая тема »

2 страниц V 1 2 >
Перейти к странице
 Добавить ответ в эту тему
1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0

Режим отображения: Переключить на: Стандартный · Линейный · Переключить на: Древовидный

Подписка на тему · Сообщить другу · Версия для печати · Подписка на этот форум

PALMZ - все сообщения
PALMZ - раздел PalmOS
PALMZ - раздел PocketPC
PALMZ - раздел КАРТЫ И GPS НАВИГАЦИЯ
PALMZ - раздел GSM / CDMA устройства
PALMZ - Русский софт
PALMZ - раздел ОБШИЕ ВОПРОСЫ
PALMZ - Барахолка
PALMZ - раздел PDA на LINUX
Текстовая версия Сейчас: 26.5.2007, 16:31
Русская версия IP.Board © 2007 IPS, Inc.
Лицензия зарегистрирована на: PALMZ Team
Персональная благодарность за поддержку dedline, EvGor и ViSoR

Рейтинг GPS Клуба [AD-IMG]

  • Москва: Не выбрасывайте книги!
    Кто-то ищет Вашу книгу! Частные бесплатные объявления. Без регистрации
    s.agava.ru - Москва
  • У тебя есть свой КПК (PDA)?
    Скачай наш терминал и зарабатывай, торгуй мобильно на рынке форекс!
    systemforex.org - Москва
  • Видеокурс для руководителей!
    Эффективное управление персоналом. Интенсив. Видеокурсы MBS.
    mbs-multimedia.ru
    • >>