CREDO NEW теоретический журнал № 4 2004 г.

CREDO NEW теоретический журнал
главная подшивка текущий номер

Т.В.Жданова

Рассуждение. Когнитивно-информационый подход

Cтатья выполнена при финансовой поддержке гранта Федерального агентства по образованию

Изучение вопроса, касающегося природы и структуры человеческих рассуждений, побудило нас обратиться к исследованиям в области когнитивной психологии и тесно связанным с ними разработкам по искусственному интеллекту.

Вообще вопросы о том, что такое "рассуждение"?, как его формализовать и представить в ЭВМ? с конца 70-х годов двадцатого столетия становятся центральными в проблеме ИИ. За это время специалистами предложены десятки различных толкований термина "рассуждение".

Чаще всего рассуждение определяется как "операция доказательства общезначимости или выполнимости логического утверждения" [6, с.210]. Я. Хинтикка предлагает рассматривать всякое рассуждение как интеррогативный (вопросно-ответный) процесс. Его позицию разделяет П.И. Соснин. Д.А. Поспелов в ряде случаев употребляет термин "рассуждение" как синоним термина "умозаключение", например, в высказывании о том, что "индуктивное умозаключение всегда является правдоподобным рассуждением" [8, с. 88]. В то же время он описывает такие схемы выводов, лежащие в основе рассуждений, которые существенно отличаются от стандартных схем умозаключений. В отличие от Д.А. Поспелова один из видных специалистов по искусственному интеллекту В.К. Финн предлагает определять рассуждение как "построение последовательности аргументов …, вынуждающих принятие некоторого утверждения - цели рассуждения" [12, с. 159]. При этом он выделяет особенности рассуждения, отличающие его от логического вывода [там же, с. 158]:

1) открытость множества возможных аргументов;

2) использование метатеоретических, и в частности металогических, средств, посредством которых осуществляется управление логическими выводами, применяемыми в процессе рассуждения;

3) использование не только правил достоверного вывода, но и правил правдоподобного вывода, аппроксимирующих применяемые эвристики (например правила структурной эмпирической индукции, аналогии и т.д.).

Существенным для нашего исследования является тот факт, что В.К. Финн проводит отличие между понятием "рассуждение" и понятием "логический вывод", указывая при этом, что последний входит в состав рассуждения наряду с металогическими средствами, посредством которых осуществляется управление выводами. Эти металогические средства - необходимый элемент процесса рассуждения. Действительно, знание лишь отдельных правил вывода еще не позволяет с полным основанием утверждать, что мы обладаем способностью корректно (правильно) рассуждать. Для подобного умения необходима информация не только об отдельных шагах (этапах, звеньях) рассуждения, но и о процессе в целом: важно знать, например, какая цель достигается посредством определенного вида рассуждения (доказывания, объяснения, прогнозирования и т.п.), какие типы задач решает тот или иной вид рассуждения, какова стратегия осуществления каждого из обозначенных выше познавательных процессов.

Основные характеристики информационно-когнитивного подхода к пониманию и моделированию человеческих рассуждений состоят в следующем:

· Моделирование рассуждений в исследованиях по искусственному интеллекту не должно ограничиваться формализацией дедуктивных аспектов интеллекта. Ведь в повседневной жизни, чаще всего, наш интеллект способен вырабатывать разумные решения в условиях неопределенности. Имея дело с неполной, неточной или изменчивой информацией, наши рассуждения часто приблизительны, правдоподобны, неопределенны. Такие рассуждения, именуемые модифицируемыми [6], должны иметь возможность подвергаться пересмотру, а выведенные из них заключения должны допускать возможность отказа от них.

· Построение рассуждений зависит от текущего состояния знаний субъекта, которое может изменяться (рассуждения, модифицируемые по интроспективной природе). Аналогом человеческих знаний в компьютерных системах выступают "база знаний" и "база данных". "База знаний" содержит необходимые для решения задач знания о законах проблемной (предметной) области и способах решения возникающих в этой области задач [2, с.8]. "База данных" составляет совокупность дескриптивных описаний фактуального знания на машинных носителях информации. Значительное внимание разработчиков экспертных систем уделяется изучению особенностей знаний и их структурированию.[1,2,5,7]: чем лучше организованы знания в базе знаний, тем успешнее будет осуществляться в ней поиск нужной информации.

· Необходимым элементом любой рассуждающей системы является "логический блок", задача которого "состоит в поиске вывода ответа на входное сообщение, поступившее в систему" [8, с. 127].

· Рассуждение всегда связано с определенной целью. Этот тезис находит свое выражение в разработках схем рассуждений, основанных на применении целевой функции (метод прямой и обратной волны [8]), а также в попытках моделирования вопросно-ответных отношений.

· Предпринимаются попытки учета мотивов принятия утверждений. Убежденность в истинности какого-либо высказывания может иметь мифологические основания, может определяться совокупностью морально-этических норм [8, с. 28].

Мы предлагаем понимать под рассуждением определенную разновидность речемыслительной деятельности, языкового мышления. Всякое рассуждение строится с целью найти ответ на какой-нибудь вопрос, причем к рассуждению прибегают, как правило, в ситуации, когда искомый ответ по каким-либо причинам не может быть найден посредством наблюдения, опытным путем: этот ответ находится посредством вывода (умозаключения). Такая позиция побуждает нас выделить среди многообразия теорий и методов различных областей знаний, объединенных термином "когнитивная наука", прежде всего, те, которые связаны с изучением мыслительных процедур, операций и стратегий, осуществляемых и используемых человеком при решении задач.

В рамках когнитологического направления процесс решения задач составляет собственно деятельность мышления. Общепринятой в когнитивной психологии считается модель обработки информации, предполагающая, что "процесс познания можно разложить на ряд этапов, каждый из которых представляет собой некую гипотетическую единицу, включающую набор уникальных операций, выполняемых над входной информацией" [10, c.31]. В качестве этапов могут выступать восприятие, кодирование информации, извлечение из памяти, формирование понятий, суждение и формирование высказывания. На каждый последующий этап поступает информация с предыдущего и подвергается определенной обработке, специфичной для этого этапа.

Наиболее известную модель решения задач - Универсальный решатель задач (УРЗ) - разработали Ньюэлл, Саймон и Шоу (Newell, Simon, and Shaw, 1958; Newell, Simon, and Shaw, 1960; Newell and Simon, 1963; Newell and Simon, 1973). В ней предусмотрены большой объем хранения, а также стратегии поиска необходимой информации и концепции, имитирующие процессы решения задач человеком. В УРЗ был заложен важный принцип, согласно которому задача есть различие (рассогласование) между наличным (исходным) состоянием (обозначим его А) и желаемым состоянием (обозначим его В), определяемым как цель. "Решить задачу - это значит проделать определенные преобразования над состоянием А так, чтобы оно стало идентичным состоянию В" [10, c.464]. Таким образом, решение задачи представляет собой сопоставление признаков состояния А с признаками состояния В, и если имеет место отличие между ними, то состояние А подвергается ряду преобразований. Процесс сравнения признаков двух состояний А и В, а также процедура преобразования состояния А (случае отсутствия полного сходства) проводятся до тех пор, пока признаки состояния А полностью не совпадут с признаками состояния В.

Однако решение далеко не всех задач предполагает преобразование или создание состояний, объектов или скоплений объектов, в которых четко определены начальные и конечные состояния. Согласно классификации задач Райтмана [10, c.469] помимо задач рассмотренного нами типа (Райтман называет их задачами первого типа), существуют еще три класса задач. В задачах второго типа требуется изобрести конечный объект. Задачи третьего типа предполагают, что в начальный момент имеется один или более компонентов (каждый из которых есть нечто конкретное), а на конечной стадии таких задач один или более компонентов теряют свою самостоятельную сущность. В задачах четвертого типа имеется хорошо определенный объект и известно конечное состояние, достигаемое путем некоторого (определенного) преобразования начального объекта. Последние задачи, на наш взгляд, являются разновидностью задач первого типа с той лишь разницей, что в задачах первого типа не известен заранее тот ряд операций, который потребуется для преобразования начального объекта.

Когнитивные психологи связывают процесс решения задач со структурой памяти. Согласно позиции Грино [10, с. 470-472] при решении задач к делу привлекается информация, методы и идеи, которые мы знаем и помним из предшествующего опыта. Этот предшествующий опыт составляет содержание памяти. В структуре памяти Грино выделяет три компонента: 1) кратковременная память, которая имеет очень ограниченный объем и из которой информация легко воспроизводится; 2) долговременная память - постоянное, хорошо организованное хранилище информации о понятиях и отношениях между ними (аналог базы знаний в компьютерных системах) и 3) рабочая память, имеющая достаточный объем, чтобы удерживать и воспроизводить умеренное количество информации. Решение задач согласно такой модели представляет собой уникальную форму обработки воспоминаний, но не через простое воспроизведение последних, а посредством образования новых связей. Процесс решения включает два основных этапа: построение когнитивной сети (или дерева), репрезентирующей задачу и затем построение набора отношений, соединяющих сеть задачи с желаемой сетью, или сетью решения. Построение дерева осуществляется в рабочей памяти путем выделения условий задачи. Если в качестве примера рассматривать математическую задачу, то результатом первого этапа процесса решения, согласно Грино, будет некоторая структура в рабочей памяти, представляющая собой определенный список переменных. На втором этапе строятся связи между закодированными в структуре рабочей памяти переменными и желаемыми свойствами, составляющими решение задачи с целью соответственного преобразования информации, содержащейся в рабочей памяти. Предложенная Грино модель решения задачи во многом сходна с УРЗ.

Сетевая модель, которую разработали Эйзенштадт и Карив, согласуется с моделью Грино. Однако существенным в их исследовании нам представляется вывод о том, что решение задачи зависит от субъективной репрезентации [10, c. 474], мотивов и интенций конкретного человека, решающего задачу.

О.К. Тихомиров весь процесс решения задачи представлял следующим образом: формирование поисковой потребности, нахождение действия, могущего удовлетворить эту потребность, и окончательное решение [11, с. 54]. Такая структура процесса решения задачи, на наш взгляд, предельно упрощена: наибольшего уточнения требует второй этап - нахождение действия, могущего удовлетворить проблему. В случае если задача разбита на ряд элементарных подзадач и при этом определены типы этих подзадач (например, задача на объяснение некоторого явления или события, на доказательство какого-либо утверждения и т.п.), отпадает необходимость поиска действий, поскольку эти действия представляются ясными и отчетливыми, когда человек обладает знаниями относительно этапов рассуждения (решения задачи), которые мы рассмотрим далее.

Мы полагаем, что среди основных компонентов и стадий рассуждения, понимаемого как процесс решения задачи или поиска ответа на вопрос посредством умозаключения, можно выделить следующие:

1. Постановка вопроса субъектом мыслительной деятельности относительно ненаблюдаемых непосредственно свойств или параметров некоторой ситуации (причины ее возникновения, связи с другими ситуациями и т.п.), описываемой уже имеющимся у него высказыванием (исходным знанием), либо относительно семантического или прагматического статуса этого высказывания (значения его истинности, степени правдоподобия и т.п.).

2. Выделение предметной области (универсума) рассуждения: акцентуация внимания рассуждающего на определенном и сравнительно нешироком круге предметов и явлений, к которому непосредственно относится исходное знание.

3. Актуализация знаний о предметной области рассуждения: припоминание рассуждающим сведений о ней, в частности, о существующих в ней устойчивых и необходимых зависимостях (законах), их наблюдаемых проявлениях (эмпирических индикаторах).

4. Подбор высказываний из доступного субъекту мыслительной деятельности знаний о предметной области рассуждения, которые он предполагает включить в состав умозаключения в статусе его посылок или заключения, причем выбор схемы умозаключения детерминируется исходным знанием и целью рассуждения.

5. Эпистемологическая оценка высказываний-посылок: признание их в качестве истинных (или весьма правдоподобных); в случае, если эти высказывания не могут быть признаны рассуждающим, происходит подбор других высказываний в качестве посылок предполагаемого умозаключения (может измениться и схема умозаключения).

6. Умозаключение, т.е. признание субъектом рассуждения высказывания-заключения на основе уже признанных им высказываний-посылок.

7. Формулировка ответа на поставленный в начале рассуждения вопрос.

Данная последовательность отображает лишь общую структуру, основной "маршрут" рассуждений. Чаще всего в реальной мыслительной практике рассуждение представлено в "свернутом" виде: многие его компоненты не артикулируются, а большинство мыслительных операций совершается автоматически. "Если опытному археологу показать обработанный камень или черепок глиняного сосуда, он довольно уверенно скажет, к какой эпохе или даже к какой культуре относится показанный предмет. Но если его спросить, каким образом он пришел к этому выводу, какова цепочка рассуждений, приведших его к ответу, то этот вопрос окажется для него более сложным, чем первый, поскольку подобные заключения, как правило, основаны на опыте и интуиции исследователя…" [4, с. 9].

Представленная нами структура рассуждений отражает так называемые простейшие рассуждения. В более сложных своих проявлениях они могут содержать не одно, а несколько умозаключений. Из простых рассуждений могут складываться сложные рассуждения. Эта ситуация имеет место, если решаемая задача разбивается на ряд подзадач, процесс решения каждой из которых представляет собой простое рассуждение. Схематически это можно представить так:

задача k - задача i - ... - задача 2 - задача 1,

причем первоначальное движение мысли (процедура разбиения задачи на подзадачи) идет от задачи1 к задаче k, в то время как непосредственная процедура решения осуществляется в обратном порядке: строится рассуждение, результатом которого будет решение задачи k; полученное решение задачи k выступает исходными данными задачи i; строится рассуждение, результатом которого будет решение задачи i и т.д. Решение задачи1 будет составлять решение исходной задачи.

В процессе рассуждения может возникнуть потребность в получении дополнительной информации (в том числе и посредством наблюдения, измерения и т.п.), которая затем включается в состав знаний субъекта рассуждения, и т.д. Однако эмпирические процедуры не относятся к деятельности рассуждения.

Выделенные компоненты и стадии рассуждения взаимосвязаны, при этом каждый из "строительных блоков" простого рассуждения сам по себе не обладает свойствами целого (собственно рассуждения).

Предложенная нами структура рассуждения учитывает многие субъективные аспекты рассматриваемого мыслительного процесса. И это, на наш взгляд, оправдано. Научное мышление, а соответственно и научное рассуждение, призвано быть объективным, адекватно отражать реальную действительность, однако нужно признать, что "мыслительные построения всегда в известном смысле субъективны, даже тогда, когда они прекрасно отражают объективное положение вещей" [9, с.8].

В заключение хотелось бы отметить, что исследования по искусственному интеллекту способствовали возрождению интереса к тематике рассуждений, актуализировали ряд вопросов относительно их специфики и структуры, роли в мыслительной деятельности в целом. Стало ясно, что категориальный аппарат и методы формальной логики (связанной с изучением таких форм мыслительной деятельности как образование, обобщение и ограничение понятий, деление их объема, операция эквивалентного преобразования суждений, процедура умозаключения и т.д.) не приспособлены к тому, чтобы адекватным образом описывать реальные процессы рассуждения. Это, в свою очередь, указывает на необходимость выделения особой методологической области, интегрирующей в себе исследования, связанные с оперированием научными понятиями, суждениями, принципами научного мышления, умозаключениями и т.п., которую мы предлагаем именовать логико-прагматической теорией рассуждений.

Литература.

1. Алексеева И.Ю. Человеческое знание и его компьютерный образ. 1992

2. Гаврилова Т.А., Червинская К.Р. Извлечение и структурирование знаний для экспертных систем. М., "Радио и связь", 1992.

3. Гаврилова Т.А. Представление знаний в экспертной диагностической системе АВТАНТЕСТ//Изв. АН СССР. Техн. Кибернетика. - 1984. - №5.

4. Гарден Ж.-К. Теоретическая археология. - М.: Прогресс, 1983. - 295 с.

5. Коов М.И., Мацкин В.В. Диалектика социального познания. - М.: Политиздат, 1988

6. Логический подход к искусственному интеллекту. От классической логики к логическому программированию. М., 1990

7. Поспелов Д.А. Ситуационное управление: теория и практика. - М.: Наука, 1986.

8. Поспелов Д.А. Моделирование рассуждений. Опыт анализа мыслительных актов. - М.: Радио и связь, 1989. - 184 с.

9. Радовель М.Р. Категориальная структура исследовательского мышления. - Ростов-на-Дону, 1993.

10. Солсо Р. Когнитивная психология.

11. Тихомиров О.К. Психология мышления. Учебное пособие - М.: Изд-во МГУ, 1984. - 272с.

12. Финн В.К. Интеллектуальные системы: проблемы из развития и социальные последствия. // Будущее искусственного интеллекта. - М.: Наука, 1991. - 302 с.
Содержание

Summary

С.А.Чернов
Кантианцы против Якоби

И.В.Шевченко
Ф.-Г.Якоби против И.Канта: критика трансцендентальной философии

А.А.Кобченко
"Закон" и "Благодать" в концепции Вышеславцева В.П. как принципы общей регуляции жизни человека и общества

Д.А.Ольшанский
Глобализация и Мир в философии Жака Деррида

Л.Н.Латыпов
Об экзистенциональной основе учения Иисуса Христа

И.Е.Барыкина
Проблема предмета и метода в исторической науке и философии истории

Т.В.Жданова
Рассуждение. Когнитивно-информационый подход

В.Е.Семенков
Петербург философствующий. Социологические заметки о положении философов в кругу интеллектуальных сообществ города

И.В.Вехов, С.Г.Кошкина
Современные дискуссии по проблеме организационного развития в отечественной социологии организаций

В.Г.Качалова
Меценатство и частное коллекционирование как форма сохранения культурных ценностей в ХIХ - начале ХХ вв

В.Н.Лукин, Т.В.Мусиенко
Теоретическое моделирование в компаративных исследованиях

Т.В.Мусиенко
Микрополитика как раздел современной политологии: тенденции и перспективы развития

В.П.Гриценко, Б.С.Есенькин, С.П.Иваненков, А.Ю.Соломеин
Критика и библиография

Хроника научной жизни

Наши авторы

Свидетельство о регистрации ПИ № 2 - 5501 от 19 октября 2001 г. Выдано Северо-Западным окружным межрегиональным территориальным управлением.