РАДИАЛЬНО-БАЗИСНЫЕ НЕЙРОННЫЕ СЕТИ В ЗАДАЧАХ ТЕХНИЧЕСКОЙ ДИАГНОСТИКИ

В.И. Дубровин, С.А. Субботин, А.А. Согорин

Запорожский государственный технический университет, Запорожье, Украина

E-mail: vdubrov@zstu.zaporizhzhe.ua , vdubrov@zstu.edu.ua

Abstract

In connection with continuous growth of the requirements to a reliability of gas turbine engines (GTE) the researches directed on forecasting to lift capability of details, working for want of cyclic loads, are rather urgent.

One from most hardly of negative factors, subject to operation, of details GTE is the blade. For definition of sub-standard blades the data - spectra of free fading oscillations of blades after shock energization are going or differences of halfcycles of fading oscillations of blades after shock energization - in experiments they contained 10240 spectral lines in frequency band up to 25000 Hz, with allowing on frequency of 2.441406 Hz. On the basis of these data it was necessary to execute a classification of blades (suitable / defective). The main difficulty was, that each parameter of a blade is characterized not by one value, and whole set of values and use of traditionally used statistical methods in this case is inconvenient.

For solution of the task of a classification we offer to use radial - basic neural networks (NN). The application нейросетей in this case is expedient, as they are capable to be trained to approximate many-dimensional functions, that is can extract, truth, in implicit for the user sort, knowledges from researched data domain.

For solution of the task of a classification of blades was used radial - basic NN, on which inputs the values of spectra of blades previously compressed with the help median filtering moved. On an output of a NN number of the class of a blade moved.

The experiments have shown, that a NN successfully decide the task of a classification of blades GTE on spectra of fading oscillations of blades and differences of halfcycles of fading oscillations of blades, providing for want of it a rather high reliability of a classification for want of rather small time of learning.

The application of the offered approach opens new possibilities in development of methods early diagnostics of difficultly recognized defective parts of air engines with use of computer systems of collection and data processing

Введение

В связи с непрерывным ростом требований к надежности газотурбинных двигателей (ГТД), ужесточением условий работы и режимов их эксплуатационной нагруженности, исследования, направленные на прогнозирование несущей способности деталей, работающих при циклических нагрузках, весьма актуальны.

Одной из наиболее сильно подверженных действию негативных факторов деталей ГТД является лопатка. Для определения некондиционных лопаток собираются данные - спектры свободных затухающих колебаний лопаток после ударного возбуждения (рис. 1) или разности полупериодов затухающих колебаний лопаток после ударного возбуждения (рис. 2) - в экспериментах они содержали
Основная трудность состояла в том, что каждый параметр лопатки характеризуется не одним значением, а целым набором значений и использование традиционно применяемых статистических методов в этом случае затруднительно.

Для решения задачи классификации мы предлагаем использовать радиально-базисные нейронные сети (НС). Применение нейросетей в данном случае целесообразно, так как они способны обучаться аппроксимировать многомерные функции, то есть могут извлекать, правда, в неявном для пользователя виде, знания из исследуемой предметной области [1,2].

Радиально-базисные сети

Радиально-базисные НС состоят из трех слоев. Первый слой - входной. Каждому входу хi соответствует один нейрон первого слоя, связанный своим выходом со входами всех нейронов второго слоя, i=1,...,n, n - размерность пространства, в котором формулируется задача (количество входов НС). Второй слой составляют нейроны, функция состояния которых вычисляет расстояние dj между вектором весов входов Wj = {wji,..., wjn} нейрона j и вектором входов Х = {х1..., xn} [3]. В зависимости от постановки задачи расстояние может вычисляться на основе заданных метрик [4]:

, либо [image] ,

где n(j) – количество входов j-го нейрона второго слоя.

Нейроны второго слоя могут использовать различные функции активации: пороговую и экспоненциальную [5].

Нейроны третьего (выходного) слоя выполняют сбор выходов нейронов второго слоя.

Для решения задачи классификации мы предлагаем использовать радиально-базисные нейронные сети (НС). Применение нейросетей в данном случае целесообразно, так как они способны обучаться

Сети с пороговой функцией активации нейронов второго слоя

В этих сетях нейроны второго слоя используют пороговую функцию активации с порогом Rj, в общем случае разным для разных нейронов. Обозначая выход j-го нейрона через pj, имеем:

pj = 1, если dj < Rj,

pj = 0, если dj [image] Rj.

Нейроны третьего слоя выполняют сбор выходов нейронов второго слоя, образующих покрытие одной области. Если есть сигнал «1» только от одного нейрона второго слоя, то он признается как результат принадлежности входного вектора к рассматриваемой области. Если есть сигнал «1» от нескольких нейронов, входящих в покрытие разных областей, то функционирование сети признается противоречивым.

Сети с экспоненциальной функцией активации нейронов второго слоя

В этих сетях нейроны второго слоя используют функцию активации

,

где aj - множитель, управляющий скоростью изменения значения вероятности отнесения входного вектора к j-ой области от расстояния dj.

Каждый выходной нейрон (нейрон третьего слоя) затем вычисляет взвешенную сумму значений функций активации соединенных с ним нейронов второго слоя. В качестве весов используются счетчики представительности нейронов второго слоя Ki:

,

где Mk - множество нейронов второго слоя, образующих область k. Условная вероятность Р(Ck/X) принадлежности входного вектора Х области Ck вычисляется путем нормировки:

,

где N - количество областей.

Обучение радиально-базисных сетей

Процедура обучения радиально-базисных сетей включает три механизма:

· формирование нейронов второго и третьего слоев, задание их функций активации и настройки весов;

· модификация значений порогов нейронов;

· модификация счетчиков представительности нейронов.

Ниже рассмотрим схематическое описание процедуры обучения нейросети на множестве входных векторов Z = {X1, Х2,...,Хm}, принадлежащих различным областям Ck, k = l,...,g, где g – количество областей. При поступлении на входы сети вектора Xj, j=l,...,m, принадлежащего ранее не встречавшейся при обучении области С, формируется выходной нейрон этой области и связанный с ним j-ый нейрон второго уровня. Формирование j-го нейрона второго уровня заключается в следующем:

· порождение j-го нейрона с весами входов, равными компонентам входного вектора Xj : Wji = Xji, i = l,...,n, n - размерность пространства, в котором формулируется задача;

· задание значения порога Rj j-го нейрона, равного некоторому наперед выбранному значению Rmax, Rj = Rmax;

· задание значения счетчика представительности Kj j-го нейрона, Kj = l.

Будем в дальнейшем называть полем влияния j-го нейрона все точки многомерного пространства, входящие в гипершар с центром Wj и радиусом Rj. При поступлении на входы сети входного вектора Xj, принадлежащего уже встречавшейся области С, но не попадающего в поле влияния других нейронов, формируется соответствующий этому вектору нейрон второго слоя.

Если очередной поступивший входной вектор принадлежит уже ранее встречавшейся области С и попадает в поле влияния другого нейрона, то возможны два варианта, в зависимости от типа строящейся нейросети.

При построении полной вероятностной нейронной сети выполняется формирование соответствующего нейрона второго слоя.

При построении сокращенной вероятностной нейронной сети новый нейрон не формируется, а увеличивается на единицу значение счетчика представительности Kj j-го нейрона, в поле влияния которого попал входной вектор. Заметим, что при подсчете условных вероятностей вместо учета вклада двух нейронов будет учтен двойной вклад одного нейрона.

Полные вероятностные нейронные сети точнее сохраняют свойства обучающего множества Z, но требуют больших ресурсов. Если очередной поступивший входной вектор Х попадает в поле влияния нейрона иной области, нежели область которой принадлежит вектор X, то формируется нейрон, соответствующий поступившему вектору.

При пересечении полей влияния нейронов разных областей предпринимается попытка уменьшения значений порогов этих нейронов вплоть до некоторого наперед заданного значения Rmin, с целью исключения пересечения областей влияния. Возможно, что даже при достижении порогов Rmin, поля влияния будут пересекаться. В этом случае решение о принадлежности входного вектора, попадающего в пересечение полей влияния будет делаться на основе условных вероятностей. Корректировка покрытия областей полями влияния нейронов позволяет за несколько проходов, использующих множество Z обучающих векторов, произвести формирование нейронной сети, решающей задачу.

Эксперименты и результаты

Для решения задачи классификации лопаток использовалась радиально-базисная НС, на входы которой подавались значения спектров лопаток, предварительно сжатые с помощью медианной фильтрации. На выход НС подавался номер класса лопатки.

Фрагмент результатов экспериментов приведен в таблице.

Таблица Фрагмент результатов экспериментов

Фактический класс лопатки | Распознанный класс лопатки | Фактический класс лопатки | Распознанный класс лопатки
0 | 0 | 1 | 1
0 | 0 | 0 | 0
1 | 1 | 1 | 1
1 | 1 | 0 | 0
1 | 1 | 1 | 1
0 | 0 | 1 | 1
0 | 0 | 0 | 0
0 | 0 | 0 | 0
1 | 1 | 1 | 1
1 | 1 | 0 | 0
0 | 0 | 1 | 1
0 | 0 | 0 | 0
0 | 0 | 1 | 1
0 | 0 | 0 | 0

Эксперименты показали, что НС успешно решают задачу классификации лопаток ГТД по спектрам затухающих колебаний лопаток и разностям полупериодов затухающих колебаний лопаток, обеспечивая при этом достаточно высокую надежность классификации при сравнительно небольшом времени обучения.

Применение предлагаемого подхода открывает новые возможности в разработке методов ранней безразборной диагностики трудно распознаваемых дефектов деталей авиационных двигателей с использованием компьютерных систем сбора и обработки данных.

Литература:

1. Субботiн С.О. Нейроннi мережi керують якicтю // Пульсар, 1999, № 12, С. 8-10

2. Дубровин В.И., Субботин С.А. Нейросетевое моделирование и оценка параметров нелинейных регрессий / 6-я Всероссийская конференция "Нейрокомпьютеры и их применение", Москва 16-18 февраля 2000: Cборник докладов.-М.:Издательское предприятие журнала “Радиотехника”, 2000.- С. 118-120

3. Neural Network Toolbox User’s Guide / Demuth H., Beale M.- Natick: MathWorks Inc, 1997.- 700 p.

4. Дубровин В.И., Субботин С.А. Построение адаптивных систем диагностики на основе нейронных сетей с латеральным торможением // Радіоелектроніка. Інформатика. Управління, 1999, № 2, С. 110 –114

5. Dubrovin V.I., Subbotin S.A. Choice of neuron transfer functions and research their influence for learning quality of neural networks / Proceedings of International Conference on Modern Problems of Telecommunications, Computer Science and Engineers Training TCSET’2000.- Lviv-Slavsko, 2000.-pp. 114-115