Олимпиада студентов по информатике (1990-91 учебный год)

Олимпиада студентов по информатике
1991-92 учебный год

1. Цепная дробь. Пусть m и n — целые натуральные числа, m < n. Представить простую дробь m/n в виде цепной дроби:

Пример

2. Простые двоичные числа. Дано натуральное число N. Среди простых чисел, не больших N, найти такое, в двоичной записи которого максимальное число единиц.

3."Угадай число". Составить программу, по которой компьютер предлагает Вам задумать число в интервале от 1 до 100. Затем пытается угадать его наиболее быстрым способом. В ответ на сообщаемое компьютером число Вы отвечаете оно "равно", "больше" или "меньше" задуманного. В итоге сообщается задуманное число и количество сделанных попыток.

4. Спортлото. Составить программу, разыгрывающую тираж спортлото 6 из 36.

5. Стрельба по цели. На расстоянии L от пушки и на высоте H находится мишень. d — высота мишени, V0 — скорость вылета снаряда. Дано: V0 = 1000 м/с; d = 5 м; L и H задаются случайным образом и стреляющему не известны (т.е. не могут быть использованы для предварительного расчета выстрела). Управляемым параметром является угол a. После каждого выстрела стрелок получает одно из сообщений: "попал", "недолет", "выше", "ниже". Требуется за наименьшее количество попыток попасть в мишень. Если достичь мишени невозможно, то выдать об этом сообщение. На экран выводить протокол стрельбы в следующей форме:

Номер выстрела Угол прицела Результат

6. Календарь. Дан год (любой — прошлый или будущий) и порядковый номер дня в году. Получить сообщение с указанием соответствующей календарной даты.

Пример. Дано: год — 1992, день — 40-й. Вывести на экран: 9 февраля 1992 года.

7. Двоичная арифметика. Целое неотрицательное число M задано массивом двоичных чисел (0 и 1). Получить и вывести массив двоичных цифр числа M + 1.

8. Игра Баше. Дано N предметов. Играют двое. Берут предметы по очереди. За один ход можно взять не более M предметов (N – M >= 2). Проигрывает тот, кто берет последний предмет. Составить программу, по которой машина, играя второй, всегда выигрывает. Если для данных N и M такая тактика невозможна, то сообщить об этом.

9. Часы. Получить на экране изображение циферблата часов и движущихся по нему часовой и минутной стрелок. Соотношение угловых скоростей вращения стрелок должны быть реальными (1 к 12-ти). Часы должны запускаться и останавливаться нажатием клавиши.

10. Падающая карта. Запрограммировать игру: вверху, в средней части экрана висит карта. Внизу по горизонтали равномерно движется цель. После нажатия клавиши карта опускается и ускоренно падает. Игрок стремится попасть в цель. После падения карты все повторяется.

11. Шарик в ящике. На экране изображен квадрат. В центре — шарик. После нажатия клавиши шарик начинает двигаться в случайном направлении. Отражение от стенок зеркальное, абсолютно упругое. Получить на экране картину движения шарика.