Научно-технический прогресс и криптографическая деятельность в России в XIX веке

На главную страницу Сайт Agentura.ru - о спецслужбах России и мира: информация о тех, кто традиционно стремится остаться в тени...
Поиск в Агентуре
Сотрудничество с журналом "Защита информации. Инсайд"
[01.03.2005]
webmaster@agentura.ru
© Агентура, 2000-2004 гг.
Пишите нам Пишите нам

[AD-SIZE]

Научно-технический прогресс и криптографическая деятельность в России в XIX веке

Ю. И. Гольев, Д. А. Ларин, к. т. н., А. Е. Тришин, к. ф. м. н., профессор, Г. П. Шанкин, д. т. н. / в рамках совместного проекта с журналом «Защита информации. Инсайд» /

Во второй половине XIX века произошли революционные изменения средств передачи информации: стал использоваться телеграф, а с начала XX века – радио. Криптографическая деятельность неразрывно связана с историей развития средств связи, поэтому в статье этому вопросу уделяется большое внимание.

После победы над Наполеоном роль России в мире существенно возросла. Открылись многочисленные дипломатические представительства Российской империи (посольства, консульства, миссии) в различных странах Европы, Азии (Турция, Персия, Египет, Китай), Америки (США, Бразилия). При этом все возрастающие объемы дипломатической переписки нужно было тщательно засекречивать.

В 1828 году должность российского представителя в Персии занимал известный русский писатель, общественный деятель и дипломат Александр Сергеевич Грибоедов. Он использовал в своих письмах шифр, известный как «решетка Кардано». Предложенный Кардано «шифр-решетка» лежал в основе знаменитого «шифра Ришелье», в котором шифрованный текст внешне имел вид «невинного» послания.

Напомним, в чем заключалась эта система шифрования. Из плотного материала вырезался прямоугольник произвольных размеров, например, 7 на 10 клеток. В прямоугольнике проделывались окна. Секретный текст вписывался в эти окна, затем решетка снималась и оставшиеся клетки заполнялись так, чтобы получалось сообщение, не вызывающее подозрений. Суровую команду на английском языке «YOU KILL AT ONCE» с помощью решетки можно спрятать в текст любовного содержания, например такой: «I LOVE YOU. I HAVE YOU DEEP UNDER MY SKIN. MY LOVE LASTS FOREVER IN HYPERSPACE». Этот шифр являлся классическим примером объединения криптографии и стеганографии.

Грибоедов писал своей жене «невинные» послания, с которыми знакомились сотрудники МИД. Они расшифровывали сообщения и затем доставляли письма адресату. Жена Грибоедова, видимо, не догадывалась о двойном назначении этих посланий.

Уже в советское время некоторых биографов Грибоедова смутил тот факт, что в отдельных письмах из Персии нарушался характерный стиль знаменитого писателя. При исследовании оказалось, что эти письма содержали дипломатические послания Александра Сергеевича. Раскрыли эту систему очень просто. Сложили все листочки в стопку и просветили мощной лампой. Буквы, стоявшие на местах окон решетки, давали темные пятна, так как лежали строго друг под другом. По этим пятнам легко восстанавливалась решетка, то есть ключ.
В России шифровалась переписка и по внутриполитическим вопросам. Например, по линии азиатского комитета МИД велась конфиденциальная переписка с восточными окраинами России. Здесь затрагивались вопросы управления подвластными России «киргизскими ордами», и проблемы отношений с Бухарой и Хивой. Связь осуществлялась при помощи дипломатических курьеров и Фельдъегерского корпуса.

В XIX веке по мере укрепления российской государственности курьерская связь уже не могла полностью удовлетворить потребности управления страной и вооруженными силами. Сообщения требовалось передавать быстро, а курьерская связь была относительно медлительной. Военные конфликты приобретали все большие и большие масштабы, расширялись пространства, на которых одновременно действовали крупные массы войск, и ими нужно было эффективно управлять. Длительное время, требовавшееся для передачи конфиденциальных сообщений, приводило к несогласованности действий соединений и даже к их гибели.

Русские ученые, инженеры работали над созданием принципиально новых средств передачи информации на дальние расстояния. Это направление исследований было настолько важным, что изобретения делались порой независимо в России и за рубежом примерно в одно и то же время.

Еще в 1794 году гениальный русский изобретатель И. П. Кулибин сконструировал семафорный (оптический) телеграф и разработал код к нему. Записанный в виде одной таблицы код упрощал работу по передаче сообщений. Это позволяло быстрее передавать нужную информацию.

В 1808 году офицер русского военно-морского флота А. Бутаков разработал свою систему семафорного телеграфа. Она успешно была применена в 1810 году на русской эскадре, действовавшей на Средиземном море под флагом вице-адмирала Д. Н. Сенявина.

В 1824 году между Петербургом и Шлиссельбургом была проложена опытная линия семафорной связи по проекту генерал-майора П. А. Козена, проработавшая до 1836 года.

Первая правительственная линия оптического телеграфа между Петербургом и Кронштадтом протяженностью 30 км была оборудована французским инженером Ж. Шато в 1833 году.

Зимний дворец в 1835 году получил прямую оптическую телеграфную связь с Царским Селом и Гатчиной. Тогда же международные события побудили русское правительство выделить средства для строительства линии оптического телеграфа от Петербурга до Варшавы. Линия протяженностью 1200 км, построенная в конце 1838 году, имела 149 промежуточных станций, через которые сигнал проходил за 15 минут. Правительственная шифрованная депеша, состоявшая из 45 сигналов, передавалась из Петербурга в Варшаву за 22 минуты.

Оптический телеграф просуществовал в России около полувека, примерно до середины 1850-х годов. Он сыграл значительную роль в развитии внутренних коммуникаций как средство оперативного управления исполнительными органами государства в мирное и военное время.

Однако более значительные перспективы давало использование электрического телеграфа. 21 октября 1832 года в Петербурге состоялась публичная демонстрация электромагнитного телеграфного аппарата П. Л. Шиллинга фон Канштадта. В 1836 году под его руководством была проложена экспериментальная подземная кабельная телеграфная линия между крайними помещениями здания Адмиралтейства в Петербурге, которая действовала более года. В том же году Шиллинг предложил подвешивать линейные провода между телеграфными станциями на деревянные опоры. В следующем году Шиллинг начал работу над проектом первой подводной телеграфной линии связи между Петергофом и Кронштадтом. Она не была прервана из-за смерти русского изобретателя 25 июля 1837 года. Исследования Шиллинга как один из этапов работ по созданию и распространению проволочного телеграфа оказали большое влияние на развитие этой области науки и техники в других странах.

Преемником и продолжателем работ П. Л. Шиллинга по развитию и внедрению телеграфа в России стал академик Петербургской академии наук Б. С. Якоби. В 1841 году он построил телеграфную линию между Зимним дворцом и Главным штабом в Петербурге, оборудованную оригинальными пишущими аппаратами его конструкции. В 1842 году подобная линия была проложена от Зимнего дворца до Главного управления путей сообщения и публичных зданий в Петербурге. В следующем году была проложена новая линия до дворца в Царском Селе. Построенные Якоби телеграфные линии представляли собой зарытые в землю изолированные медные провода. В 1850 году Якоби придумал буквопечатающий телеграфный аппарат собственной конструкции. Как говорил об этом устройстве сам ученый, в нем «регистрация знаков осуществлялась с помощью типографского шрифта».

Интенсивная работа по созданию телеграфа в России и связанные с этим теоретические и экспериментальные исследования дают право считать П. Л. Шиллинга и Б. С. Якоби основоположниками телеграфной связи в России.

Строительство и ввод в эксплуатацию первых линий связи положили начало бурному развитию сети государственного телеграфа. К концу 1855 года протяженность телеграфных линий в России составила более 5 тыс. км. Первая большая телеграфная линия протяженностью 655 км соединила в 1852 году Петербург и Москву.

Телеграфный аппарат Юза. Такой аппарат стоял на Николаевской телеграфной станции. / Источник /.

Смотри также на «Агентуре»:

  • Криптографические идеи XIX века. Русская криптография
  • Криптография в XIX веке
  • Раздел «Шифр» в Технике спецслужб

Увеличение количества линий связи приводило к необходимости разрабатывать новые шифры и коды, удобные для закрытия секретной информации, передаваемой с помощью телеграфа.

Основными шифрами, используемыми в России в XIX веке, были биграммные шифры П. Л. Шиллинга и биклавные – барона Дризена. [6]. К усовершенствованию этих шифров, применявшихся, в основном, в МИД, и к построению ключей для них привлекались специалисты шифровальной службы. Также широко использовались коды. Кодовые таблицы объемом до 1000–1200 словарных величин было принято называть словарными ключами и в зависимости от словаря конкретного кода называть французскими, русскими, немецкими. Их применяли в Военном министерстве, МВД, МИД и некоторых других гражданских ведомствах. Так, с помощью кодов, введенных в действие во второй половине 1860-х годов, вели секретную переписку Министерство финансов, Министерство путей сообщения, Министерство государственных имуществ, Государственный контроль, Государственная таможенная служба. Ведущими специалистами по кодам того времени были начальник цифирного отделения МИД барон Дризен и сотрудник отделения М. Сухотин.

Иногда шифры употреблялись для совершенно особых миссий. Так сенатор, тайный советник Тапильский, посланный Александром II из Петербурга в Москву к митрополиту Филарету с просьбой составить царский манифест 1861 года об освобождении крестьян, имел личный шифр для почтовых отправлений. Деликатность миссии сенатора заключалась в том, что царь считал нежелательным разглашение факта поручения духовному лицу светского дела.

Для шифрования на разных языках использовались разные ключи. Французские и немецкие ключи применялись для сношений со странами Европы, а русские – для шифрования внутренней переписки и для связи с российскими представителями в странах Востока (в частности, в Турции) и некоторых европейских странах.

До второй половины XIX века шифры для всех ведомств России разрабатывались в МИД. Но уже в конце 1840-х годов в Главном штабе Военного министерства была организована и начала свою работу собственная цифирная экспедиция. Создававшиеся здесь шифры утверждались военным министром. Экземплярами военных шифров снабжались военачальники, а также император и члены императорской фамилии, военный министр. Шифрованная переписка по линии Военного министерства велась не только в периоды ведения боевых действий, но и в мирное время. Зашифровывались сообщения, касавшиеся мобилизационной и военной подготовки, а также готовности армий и крепостей к боевым действиям и некоторые другие сведения. В военное время из цифирной экспедиции МИД в Военное министерство поступали экземпляры тех шифров, которые действовали в сетях общей связи, куда в силу политических, военных или иных причин могли входить дипломатические представители России за границей, командующие действующими армиями, военно-морскими силами и иные лица. Во второй половине XIX века большинство шифров Военного министерства представляли собой коды малого (до 1000 словарных величин) объема. Кодовыми обозначениями здесь являлись трех- и четырехзначные числа. Военные шифры этого типа обычно использовались в течение длительного времени, перерабатывался лишь относительно быстро устаревавший словарь, что объяснялось, например, изменением географии военных действий и т. п. Словарные ключи были наиболее распространенным типом шифров, используемых в конце XIX века в военном ведомстве. Их называли «военными ключами».

Следует отметить, что сроки действия ключей были очень длительными. Некоторые ключи, введенные в середине XIX века, действовали и в начале ХХ века. Такой продолжительный срок использования ключей, разумеется, снижал стойкость шифров. К тому же биклавные шифры не подходили для шифрования информации, передаваемой по телеграфу. Начальник 1-й экспедиции шифровального департамента отдела МИД К. Таубе писал в начале XX века: «Система биклавная не применима в настоящее время ввиду смешанной передачи буквами и цифрами, не допускаемой телеграфными конвенциями». Однако некоторое количество шифров биклавного типа применялось для шифрования секретной почтовой корреспонденции и в начале XX века.

После того, как электрический телеграф начал использоваться в системе управления государством, большое влияние на его дальнейшее развитие стали оказывать требования военно-стратегического характера. Начавшаяся Крымская война (1853–1856 гг.) ускорила постройку телеграфных линий, так как нужна была оперативная связь между крупными городами. В 1854 году была введена в эксплуатацию телеграфная линия Петербург-Варшава протяженностью более 1000 км. В мае 1855 года закончилось строительство линии Киев-Кременьчуг-Николаев-Одесса, а в сентябре того же года была открыта телеграфная связь на новой линии Николаев-Перекоп-Симферополь. С этого времени Петербург получил телеграфную связь с Симферополем, используя для данной цели ранее построенные линии Петербург-Москва и Москва-Киев.

Примером шифра, используемого во время Крымской войны, может служить русский словарный ключ № 299 на 600 величин, который был введен в действие в апреле 1854 года. Предназначался он для связи командиров частей Дунайской армии. После войны этот шифр продолжал использоваться. В 1891 году им были снабжены Бухара, Кашгар, Кульджа, Сеул, Пекин, Токио, Иркутск, Омск, Ташкент, Хабаровск, Урга, Чугучак и Владивосток, а выведен из употребления он был только в 1901 году.

Расширение системы телеграфной связи обусловливалось и экономическим развитием России. В государственную телеграфную сеть включалось все большее количество городов. Телеграфные сообщения были установлены между Москвой, Орлом и Харьковом; Житомиром и Варшавой; Новочеркасском и Херсоном; Тифлисом и Владикавказом и многими другими городами. Строящиеся телеграфные станции подразделялись на правительственные и частные железнодорожные.

В 1857 году был построен городской телеграф в Петербурге, объединивший в единую правительственную сеть важнейшие пункты государственного и военного управления. Городские телеграфы были введены в Москве в 1861 году и в Киеве в 1881 году.

В 1871 году была закончена постройка длиннейшей по тому времени линии правительственного телеграфа Москва-Владивосток.

Электрический телеграф приобретал все большее значение в политической и экономической жизни страны. Освоение Забайкальского края и Дальнего Востока, начавшееся в 1850-х годах, повлекло за собой строительство новых телеграфных линий, в частности, Сибирской телеграфной магистрали Казань-Владивосток протяженностью 8330 верст. Были проложены подводные телеграфные кабели, соединившие Баку с Красноводском, а также международные линии в Данию, Швецию и Японию.

К концу 1905 года протяженность телеграфных линий в России составила 169200 верст.

Несмотря на бурное развитие телеграфной связи в России, Фельдъегерский корпус, отметивший в 1896 году свой столетний юбилей, продолжал обеспечивать обмен наиболее важной и срочной информацией императорского дома с руководителями министерств и ведомств страны. Документальная шифрованная связь, осуществляемая Фельдъегерским корпусом, к началу XX века оставалась важным способом организации управления и взаимодействия в высшем звене государственного руководства.

В 1860–1870-е годы военным министром России графом Д. А. Милютиным были проведены реформы, коснувшиеся всех сторон устройства армии. Появление нового средства управления войсками – телеграфа – поставило вопрос перед Генеральным штабом русской армии о необходимости регламентирования его применения и создания органов, которые бы повседневно решали вопросы боевого применения этого мощного средства управления войсками.

В 1876 году было издано Положение о полевом управлении войск в военное время. В соответствии с Положением во главе армии стоял главнокомандующий, имевший при себе полевое управление армии, в составе которого было полевое управление военных сообщений с подчиненным ему отделом почт и телеграфов. В обязанностях заведующего отделом указывалось, что он отвечает за организацию и деятельность почт и телеграфа на военных дорогах, что означало ответственность за почтовую и телеграфную связь внутри армии и связь Главной квартиры армии с центром.

Положением предусматривалось наличие при полевом штабе армии станции правительственного телеграфа, располагавшей 4 – 6 телеграфными аппаратами Морзе. Предусматривалось и активное использование фельдъегерской службы.

Линейное обеспечение телеграфной правительственной связи было возложено на военно-походные телеграфные парки. Они предназначались для организации связи между штабами действующей армии и для связи отдельных частей армии как между собой, так и с государственными телеграфными линиями. В 1867 году был сформирован первый образцовый военно-походный телеграфный парк, а осенью 1870 года начато формирование шести таких парков. Каждый парк имел 8 телеграфных аппаратов Морзе, 35 верст телеграфного провода и необходимое количество шестов и изоляторов для подвески.

Приказом военного министра в 1870 году было утверждено Положение о военно-телеграфных командах, которые в военное время предназначались для усиления личным составом существующих линий правительственных и частных железнодорожных телеграфов. В их функции входила постройка и эксплуатация новых военных телеграфных линий, ремонт линий, разрушенных противником при его отступлении, а также повреждение и уничтожение линий, переходящих к неприятелю.

Военно-походные телеграфные парки и военно-телеграфные команды, в отличие от подразделений правительственного телеграфа, находились в подчинении полевого инженерного управления, что значительно затрудняло координацию действий по использованию системы телеграфной связи для управления вооруженными силами в военное время.

Сложившаяся система телеграфной связи была небезуспешно применена уже в ходе русско-турецкой войны 1877–1878 гг. Для шифрования во время этой кампании в русской армии применялись русский биграммный ключ № 361, составленый в 1876 году, французский биклавный ключ № 348, введенный в действие в 1870 году, и некоторые другие шифры. В русском биграммном ключе № 361 было 992 шифрвеличин – 28 букв упрощенного русского алфавита, 3 знака препинания, а также всевозможные их биграммные сочетания. Им отвечали трехзначные кодовые обозначения. Этот шифр был вначале разослан в консульства на Востоке, направлен в Тифлис и Одессу. Французский ключ № 348 использовался на европейских линиях связи. В русско-турецкую войну оба шифра были направлены в действующую армию. Их экземпляры находились у генерала Н. П. Игнатьева и генерала В. Б. Фредерикса. Использовались эти шифры и после войны: русский ключ – до 1903 года, а французский – до 1891 года.

В Турции в 1877 году во время войны с Россией применяли четырехзначный цифровой код, составленный в Германии специально для Турции. Но опыт русско-турецкой войны, как и франко-прусской, показал недостаточную эффективность существовавших в то время военно-полевых шифровальных кодов. Они давали большое количество ошибок, были громоздкими, непрактичными и не очень стойкими.

Телеграф, широко используемый во время русско-турецкой войны (1877–1878 гг.), стал новым возможным источником информации о планах и замыслах противника. Для ее получения можно было перехватывать сообщения, передаваемые по телеграфным линиям связи, либо непосредственно захватывать телеграфные станции. Известны примеры таких захватов русскими войсками. Так, много неприятностей доставлял туркам кавалерийский отряд генерала Струкова, осуществлявший стремительные рейды по турецким тылам. Отряд захватывал стратегически важные населенные пункты, мосты и телеграфные станции. На последних русские получали доступ к передаваемой корреспонденции и документации, в частности, к турецким кодовым книгам. Добываемая информация о противнике оперативно использовалась для действий самого отряда и других частей русской армии. При захватах линии связи выводили из строя, а телеграфные аппараты снимали и увозили. Иногда, правда, этого не происходило, так как действовать приходилось очень быстро. Так, один из небольших отрядов, входивших в состав отряда генерала Скобелева, развивавшего успехи генерала Струкова, напал «на телеграфную станцию Магалесси, где наткнулся на большие партии черкесов и потому не мог произвести правильной порчи железной дороги и телеграфа, а ограничился лишь тем, что прапорщик Живов, ворвавшись в телеграфную комнату, сжег находившиеся там бумаги».

В результате уничтожения турецких линий телеграфной связи оставались большие связки проволоки. Они находили применение во время оборонительных действий наших войск. Телеграфную проволоку разбрасывали перед траншеей. При внезапном наступлении противника в темную ночь шум от путавшихся в проволоке наступающих предупреждал часовых об опасности. Генерал Скобелев отмечал: «В франко-прусскую войну германские войска делали то же самое, и результаты были удовлетворительные».

Следующий важнейший этап развития электрических средств связи начался с момента изобретения телефона. Его придумал американец А. Г. Белл в 1876 году. В России интерес к телефонной связи возник сразу после того, как стало известно об изобретении. Это было новое и эффективное средство управления. Первый телефонный разговор в России состоялся в ноябре 1879 года между Петербургом и Малой Вишерой. В 1881 году развернулось строительство телефонных станций в Петербурге, Москве, Варшаве, Риге, Одессе. Годом позже эти станции были введены в действие. Одновременно с устройством городских телефонных станций возникла необходимость в установлении междугородных телефонных связей, и в 1882–1883 годах первые такие станции были построены, связав Санкт-Петербург и Москву с близлежащими городами.

Телефонная связь стала широко применяться военными и морскими ведомствами. Телефонное сообщение было установлено между отдельными помещениями Главного штаба в Петербурге. С появлением телефонов военные инженеры русской армии, оценив важность этого изобретения для военной связи, сочли возможным испытать телефон в полевых условиях. Выполнением этой задачи занялся сын Б. С. Якоби подполковник В. Б. Якоби. Первые испытания телефонов в армии, давшие положительные результаты, были произведены летом 1878 году в Выборге между островами Транзундского пролива на расстоянии 6–12 км по телеграфному кабелю и между Выборгом и Уран-Саарской правительственной станцией по линии военного телеграфа на расстоянии 30 км.

Работая над совершенствованием телефона, В. Б. Якоби в июне 1881 года изготовил миниатюрный телефон, названный «Телекаль», который являлся первым образцом военно-полевого телефонного аппарата. Трудность использования телефона заключалась в необходимости иметь для телефонной связи отдельные от телеграфа провода. Разработкой принципа одновременного телеграфирования и телефонирования по одним и тем же проводам занялись военный инженер Г. Г. Игнатьев и русский изобретатель Е. И. Гвоздев. Практическое использование системы одновременного телефонирования и телеграфирования Е. И. Гвоздева было осуществлено впервые на линиях железных дорог, а с 1893 года эта система стала применяться и на дальних правительственных междугородных телефонных линиях. В 1887 году инженер К. А. Мосицкий разработал первую автоматическую телефонную станцию, а в 1895 году русский изобретатель М. С. Бердичевский (Апостолов) совместно с М. Ф. Фрейденбергом сконструировал автоматическую телефонную станцию с шаговым искателем.

В 1896 году в Петербурге был построен и начал выпускать продукцию телефонный завод акционерной компании «Эриксон-Гейслер», который стал производить настольные и настенные аппараты специально для государственных телефонных линий и сетей, а также полевые телефоны для русской армии. Кроме того, в армии в период с 1895 по 1896 годов впервые появились полевые телефоны фирм «Белл» и «Сименс».

С внедрением в войска телефонной связи в штат каждой телеграфной роты было введено 24 полевых телефонных аппарата, которые предназначались для организации телефонной связи между штабами армии, корпуса и дивизии.

Последняя четверть XIX века характеризуется бурной телефонизацией России, строительством дальних правительственных междугородных линий и городских телефонных станций, а также использованием телефонной связи в оперативном звене действующей армии.

К началу XX века существовавшие электрические средства связи уже не в полной мере удовлетворяли потребности управления страной и вооруженными силами. Основная проблема заключалась в том, что для использования телеграфа и телефона необходимо протягивать кабель, по которому проходит сигнал. Впервые проблема передачи электрического сигнала без проводов была решена в России, где был создан беспроволочный телеграф – радио.

7 мая 1895 года А. С. Попов выступил с публичным докладом на заседании физического отделения русского физико-химического общества, в ходе которого продемонстрировал первый в мире радиоприемник. Уже первые испытания беспроволочного телеграфа на флоте доказали превосходство радио над другими средствами связи. Одновременно с опытами по радиосвязи на флоте подобные работы стали проводиться и в армии. Их началом следует считать 1898 год. Именно с этого времени в них участвовал целый ряд армейских телеграфных специалистов.

После испытания в 1900 году сконструированных А. С. Поповым переносных полевых радиостанций на маневрах 148-го Каспийского походного полка был сделан вывод, что при помощи радио можно установить связь между высшими штабами на расстоянии 50 верст и более. Дальнейшие работы по созданию полевых радиостанций в русской армии были продолжены специалистами Офицерской электротехнической школы.

Таким образом, беспроволочный телеграф, несмотря на свою историческую молодость, еще до начала ХХ века обратил на себя внимание государственных и военных специалистов как наиболее перспективное средство связи с очень широкой предполагаемой областью применения.

Возможность быстрой передачи шифрованных сообщений на большие расстояния, а также возможность перехвата сообщений в пунктах передачи, приема и по пути следования депеш обусловливали рост криптографических отделов и отделений с привлечением на эту службу большого количества телеграфистов, радиотехников, лингвистов, математиков.

Обратимся к дешифровальной деятельности российских спецслужб. Как и в XVIII веке, в течение XIX столетия велась активная перлюстрация практически всей переписки иностранных представителей в России. При необходимости осуществлялось ее дешифрование. Перлюстрировалась как дипломатическая, так и военная переписка, то есть сообщения от иностранных военных агентов (сейчас эти представители называются военными атташе). Методы безуликового ознакомления с содержанием писем постоянно совершенствовались и были развиты настолько, что российским специалистам удавалось производить все необходимые операции за несколько минут. При этом использовалось фотографирование. Адресаты не замечали никаких следов вскрытия. Такая спешка была вызвана тем, что курьеры иностранных представительств привозили пакеты на почтамт незадолго до отхода заграничных поездов, а забирать старались сразу же после получения почты с вокзала.

Как утверждал бывший царский сотрудник «черного кабинета» (цензор) России С. Майский, «иностранная дипломатическая переписка попадала в руки российских «специалистов» практически полностью. В российском «черном кабинете» имелся полный набор безукоризненно скопированных печатей для зарубежной переписки всех находившихся в Петербурге посольств и консульств… У российского «черного кабинета» имелись копии многих шифров иностранных государств».

Успехи российского «черного кабинета» признавали даже весьма высокопоставленные деятели зарубежных государств. Так, в конце XIX века объединитель Германии «железный канцлер» О. Бисмарк проявлял особое беспокойство о сохранности секретных посланий, отправляемых из Петербурга. Он писал: «…немецкий шифр не остается неизвестным российскому императорскому двору; ведь я знал по опыту, что даже в здании нашей миссии в Петербурге сохранить наши тайны мог не искусно сделанный замок, а только частая смена шифра. Я был уверен, что не мог телеграфировать в Ливадию ничего, что не дойдет до сведения императора». В Ливадии (Крым) в это время происходили русско-германские переговоры. Бисмарк с сожалением констатировал: «Сохранить тайну шифра в Петербурге особенно трудно».

Аналогичная мысль о русских дешифровальщиках была высказана немцами уже в конце 30-х годов ХХ века. В справке Главного управления полиции безопасности отмечалось: «…русские испокон веков являются мастерами шифрования и дешифрования. Уже во время Петра Первого им удавалось не только доставать шифры всех находящихся в России дипломатических представительств, но и разгадывать их».

Сам император России Александр II не стеснялся в использовании сведений, полученных в результате дешифрования. Он жаловался Бисмарку, что его, императора, резко критикуют немецкие государи в своих шифрованных посланиях в Россию. Чтение шифрпереписки он считал естественным правом самодержца. Здесь надо отметить, что при использовании сведений, добытых путем дешифрования, следует проявлять особую осторожность, так как противник, узнав, что его шифры раскрыты, может поменять ключ и даже всю шифрсистему.

К сожалению, информацию об успехах российских дешифровальщиков иностранцам «поставляли» и другие высокопоставленные чиновники. Так, министр иностранных дел Российской Империи Лобанов-Ростовский в разговоре с одним иностранным дипломатом упомянул о своей осведомленности о некоторых фактах, сведения о которых не могли быть получены из официальных источников. Эта информация стала известна немецкому послу. Посол тут же отправил в Берлин телеграмму, в которой были такие слова: «Использую этот шифр из осторожности, так как предыдущий употреблялся слишком часто, и у меня появились основания для недоверия. Меня предупредили, прошу о новом шифре». Несмотря на проявленную немецким дипломатом «осторожность», эта телеграмма была также дешифрована русским «черным кабинетом», и российский министр был проинформирован о крайней нежелательности разглашения сведений, полученных путем дешифрования.

Российские дипломаты имели некоторые сведения о возможностях «черных кабинетов» по перлюстрации дипломатической переписки и пускались на различные ухищрения, чтобы противодействовать этой деятельности. Так, например, посол России в Турции граф Н. П. Игнатьев (о нем упоминалось при описании примеров шифров, используемых во время русско-турецкой войны 1877–1878 гг.) знал о том, что посольская переписка перехватывается. Это было видно по внешним признакам получаемых пакетов. Кроме того, по внешним признакам письма, его объему, качеству пакета (конверта), почерку, запаху, можно было судить о важности корреспонденции. «Тонкий запах», высококачественный конверт, почерк посла вызывали настороженность специальных почтовых чиновников Турции. Поэтому посол прибегнул к следующему приему. Конверт использовал «простейшего» качества (очень дешевый), адресацию писал его лакей (якобы отправляя письмо своему знакомому или родственнику), само письмо несколько дней выдерживали рядом с открытой бочкой, в которой находилась соленая сельдь. Запах у письма появлялся специфический, свойственный людям «низшего» сословия. Этот прием себя оправдал. Послания Игнатьева по внешним признакам не перехватывались.

Будучи послом России в Англии, граф Игнатьев получил письмо из Петербурга с явными следами вскрытия. На встрече с английским министром иностранных дел он указал на противоправные действия английского «черного кабинета». Поначалу министр ответил, что такого кабинета в Англии нет. Но под давлением улик признался: «А что же я, по-вашему, должен был вам сказать? Неужели вы думаете, что нам не интересно знать, что пишет вам ваш министр, и что вы ему доносите про нас?..»

В конце XIX века дешифровальная работа, в основном, была сосредоточена во второй экспедиции шифровального департамента МИД. Здесь дешифровывались копии, снятые с шифртелеграмм, перлюстрированных «черным кабинетом» главного телеграфа в Петербурге. Через главный телеграф проходила корреспонденция из других городов Российской империи (Москвы, Варшавы, Киева, Одессы и др.), где имелись иностранные дипломатические представительства. Штат этого подразделения шифровального департамента состоял из 10–12 человек. Во второй экспедиции специалистов-криптоаналитиков было всего 2–3 человека. Весь остальной штат имел лишь весьма отдаленные сведения об искусстве дешифрования.

Одним из ведущих дешифровальщиков в России до революции 1917 года был Эрнест Феттерлейн. Среди его заслуг было дешифрование британской дипломатической почты. По иронии судьбы после революции он сбежал в Англию и возглавил там русскую секцию британской дешифровальной службы. За первые десять лет после революции его главным достижением стало дешифрование русской дипломатической почты, на этот раз для англичан. Благодаря Феттерлейну англичане дешифровали значительную часть нашей дипломатической переписки во время англо-советских торговых переговоров. Это была чрезвычайно важная информация. В самом начале переговоров (июнь 1920 года) В. И. Ленин писал главе русской делегации Л. Б. Красину: «Эта свинья Ллойд Джорж (премьер-министр Великобритании – авт.) пойдет на обман без тени сомнения или стыда. Не верьте ни единому его слову и в три раза больше дурачьте его». Понятно, как к этим словам отнеслись англичане. Однако истинный источник информации они, естественно, не могли назвать. Лишь позднее (в августе) кабинет министров дал разрешение на публикацию части дешифрованных документов (8 телеграмм). Однако и здесь они прибегли к уловке. Англичане сообщили, что документы получены агентурным путем. Но этому даже в Англии не поверили. Тем не менее, советские дипломатические шифры были заменены лишь в начале 1921 года. Но уже в апреле англичане совместно с Феттерлейном дешифровали и их. Летом 1923 года были введены новые шифры, но уже через год англичане снова читали советскую переписку.

Специального учебного заведения, где преподавалась криптография, в России не было, и поэтому чиновниками в шифровальный департамент назначались лица, окончившие обычные учебные заведения (университеты или лицеи). Крупным недостатком являлось и то обстоятельство, что работники дешифровального отделения в основном владели лишь французским и немецким языками, и некоторые – английским. Между тем, министерство постоянно испытывало потребность в специалистах, владеющих и другими, более редкими языками. Поэтому департамент постоянно обращался за квалифицированной языковедческой помощью к ученым, преподавателям, иным лицам, владеющим теми или иными языками. Так, для помощи в дешифровании иностранной дипломатической переписки привлекались профессор Попов, преподававший в Петербургском университете китайскую словесность, его однофамилец, окончивший факультет восточных языков и хорошо знавший японский язык. Последний за счет министерства даже был направлен в командировку в Японию с целью совершенствования знания языка. Для переводов с венгерского или, как тогда говорили, мадьярского языка, обращались за помощью к В. И. Кривошу-Неманичу, работавшему в Генеральном штабе и знавшему 14 языков. Цензоры Комитета иностранной цензуры Смирнов и Жуковский переводили соответственно с турецкого и персидского языков.

Дешифровальщики всегда работали в тесном контакте с разведкой, одна из важнейших задач которой была выкрасть ключи к шифрам, кодовые таблицы, сфотографировать документацию. Ставилась и более трудная задача – внедрить агента в службы противника, связанные с шифрами и кодами.

Часто раскрытию шифров и кодов способствовали полученные агентурным путем открытые тексты, которые можно было привязать к соответствующим шифрованным сообщениям. Для кодов, например, это сразу давало некоторое число раскрытых кодовых групп, после чего значительно облегчалась работа по дешифрованию. Нередко коды просто-напросто покупались и продавались. Европейским центром подобной деятельности в то время была Вена. Там производились всевозможные сделки по покупке и продаже копий секретных документов, писем, карт, кодов, планов, чертежей и т. п. Упомянутый ранее С. Майский писал, что Россия покупала коды и шифры в Вене, Париже и Брюсселе. Торговцам кодами можно было даже делать «предварительные заказы». Этими методами активно пользовались разведки Германии, Австро-Венгрии и других стран. Коды, представляющие меньший интерес, греческий, болгарский или испанский, можно было легче достать. Они стоили дешевле – полторы – две тысячи рублей, в то время как германский, японский или американский – десятки тысяч. Цены шифрдокументов других стран колебались между 5 и 15 тысячами. В Брюсселе шифры и коды приобретались у известного авантюриста де Вернина. Его основным занятием было похищение шифров и кодов из посольств с помощью работавших там и подкупленных им лакеев, швейцаров, денщиков и т. д. Де Вернин делал фотографии украденных документов и продавал их. Таким образом, в шифровальном департаменте имелось большое количество иностранных кодов. В порядке взаимопомощи МИД даже делился информацией с морским и сухопутным генеральными штабами. Некоторые коды вскрывались аналитическим путем. Однажды, когда долго не удавалось купить один германский код, двум сотрудникам было дано поручение его восстановить по ежедневно получаемым многочисленным копиям шифртелеграмм. Над этим заданием больше года работали два человека. Когда работа приближалась к концу, и код был уже в значительной степени раскрыт, немцы вывели его из действия.

В конце XIX – начале XX века Россия активно использовала возможности подкупа иностранцев, имевших доступ к шифрам, кодам, шифрованной переписке. Особо важная корреспонденция иностранных дипломатов не отправлялась по почте, а обычно упаковывалась в специальные портфели с секретными замками и доставлялась к месту назначения особыми курьерами. В результате она не попадала в «черный кабинет» и не могла быть перлюстрирована. В этих случаях приходилось прибегать к подкупу. Как вспоминает Майский, не было случая, чтобы золото не открывало замок портфеля и не давало возможность всего за несколько минут сфотографировать документы. Весь вопрос был в размере суммы. Многие курьеры, фельдъегеря и служащие иностранных посольств были подкуплены. За небольшую плату они добывали практически любые документы, даже целые коды и шифровальные ключи. Для достижения этого им приходилось брать у спящего хозяина ключи от письменного стола или от несгораемого шкафа, снимать с них отпечаток из воска и заказывать дубликаты ключей или пускать ночью в посольство специалистов, которые могли бы квалифицированно добыть нужную информацию. «Поражаться надо было доверию некоторых послов к своим лакеям, которые продавали их за гроши. Однажды произошел такой случай, вместо одного посла великой державы был назначен другой, который должен был с собой привезти весь новый штат служащих, так как прежний посол старым своим слугам не доверял, но в письме к новому послу он очень ходатайствовал за одного, по его выражению, «незаменимого» человека, своего выездного лакея, то есть именно за то лицо, которое за незначительное месячное вознаграждение доставало из посольства все, что было угодно», – писал Майский.

К сожалению, российские шифры также становились объектами кражи. Особенно крупная утрата шифров произошла в русском посольстве в Пекине 19 августа 1888 года. Причем несмотря на компрометацию, ключи продолжали использоваться, что совершенно недопустимо! Например, ключ № 356, украденный в Пекине, был выведен из употребления лишь на некоторое время. В начале 1890-х годов его вновь ввели в действие, но уже в Европе. В 1898 году произошла еще одна компрометация этого шифра: один экземпляр его был утрачен начальником Адриатической эскадры. Только после этого действие ключа было прекращено окончательно. В Пекине также был украден русский ключ № 361. Его окончательно вывели из действия лишь в 1903 году, но и после этого барон Таубе писал: «Ключ № 361 может применяться как временный в специальных случаях, кроме Дальнего Востока».

Руководителям российской криптографической службы того времени представлялось возможным использовать скомпрометированные шифры. Если шифр был скомпрометирован в одном регионе, допускалось его использование в другом. Решающим обстоятельством здесь являлось отсутствие предполагаемых контактов между нашими потенциальными противниками из-за дальности расстояний. Другим фактором было время. Скомпрометированный шифр мог вновь вводиться в действие через значительный промежуток времени. Предполагалось, что за давностью он оказывался забыт противником. Справедливости ради надо отметить, что некоторые меры все же предпринимались. Например, в 1866 году цифирная экспедиция МИД занималась «проверкой всех находящихся в некоторых странах шифров, а равно контролем всех книг, которые ведутся о состоянии заготовленных и разосланных экспедицией шифров». При этом оказалось, что некоторые миссии имеют у себя шифры в огромном количестве, многие из которых вовсе не употребляются. Вместе с тем проверка обнаружила, что некоторые уже закрытые миссии не возвратили находившихся у них шифров. В результате были даны необходимые распоряжения и приняты соответствующие меры к исправлению существующего положения.

Подводя итог данной статье, отметим, что развитие криптографии и связи в России в XIX веке отвечало мировому уровню. Однако в организации шифровального дела имелись существенные недостатки, основными из которых были длительные сроки действия ключей и использование ключей после их компрометации.

Литература

  • Астрахан В. И., Гусев В. В., Павлов В. В., Чернявский Б. Г. Становление и развитие правительственной связи в России, Орел: ВИПС, 1996.
  • Бабаш А. В., Шанкин Г. П. История криптографии. Часть I. М.: Гелиос, 2002.
  • Бабаш А. В., Гольев Ю. И., Ларин Д. А., Шанкин Г. П. О развитии криптографии в XIX веке // Защита информации. Конфидент. № 5, 2003, с. 90-96.
  • Бабаш А. В., Гольев Ю. И., Ларин Д. А., Шанкин Г. П. Криптографические идеи XIX века. Русская криптография // Защита информации. Конфидент. № 3, 2004, с. 90-96.
  • Вальдман Э. К. Занимательная телеграфия и телефония. М., «Связь», 1964.
  • Востоков К. У истоков радиовойны // Независимое военное обозрение 14-20 июля, 2000, с. 7
  • Дамасскин И. А. Сто великих разведчиков. М., 2002.
  • Крестовский В. Двадцать месяцевъ въ действующей армiи. (1877-1878) письма въ редакцiю газеты «Правительственный вестникъ» отъ ея офицiальнаго корреспондента, лейбъ-гвардiи уланскаго Его Величества полка штабсъ-ротмистра Всеволода Крестовскаго, Т.2, С.-Пб.: типографiя министерства внутренних делъ, 1879.
  • Кудрявцев Н. А. Государево Око. Тайная дипломатия и разведка на службе России. М., ОЛМА-ПРЕСС, 2002.
  • Кукридж Е. Х. Тайны английской секретной службы. М., 1959.
  • Немирович-Данченко В. И. «Скобелев». М., Воениздат, 1993.
  • Очерки истории внешней разведки, т. 1, ред. Е. М. Примакова, М., 1997.
  • Очерки истории внешней разведки, т. 2, ред. Е. М. Примакова, М., 1997.
  • Полмар Н., Аллен Т. Б. Энциклопедия шпионажа. М., 1999.
  • Соболева Т. А. Тайнопись в истории России. М., 1994.
  • Соболева Т. А. История шифровального дела в России. М.: ОЛМА-ПРЕСС-Образование, 2002.
  • Тайные операции российских спецслужб. М., 2000.
  • Тайные страницы истории. М., 2000.
  • Черняк Е. Пять столетий тайной войны. М., 1991.
  • Kahn D. The codebreakers. N.-Y., 1967.

Смотри также на «Агентуре»:

  • Криптографические идеи XIX века. Русская криптография
  • Криптография в XIX веке

[AD-IMG]


SJ8: NEWSRU.com

[AD-IMG]