lecture11

Лекция 11.

Качество САУ

11.1. Теоретическое обоснование метода D-разбиений

Изменение параметров САУ, например, с целью оптимизации, приведет к изменению коэффициентов уравнения динамики. Останется ли при этом САУ устойчивой - неизвестно. Критерии устойчивости об этом ничего не говорят. Рассмотрим метод определения границ допустимых изменений параметров, при которых САУ не теряет устойчивости.

Приведем характеристическое уравнение замкнутой САУ к виду:

D(p) = pn + c1 pn -1 + c2 pn-2 + ... + cn = 0,

где c0 = a0 /a0 = 1, c1 = a1 /a0 и т.д. При некоторых конкретных значениях c1 ,c2 ,...,cn уравнение имеет единственное решение, то есть единственный набор корней (p1 , p2 ,...,pn ). По их расположению на комплексной плоскости можно судить об устойчивости САУ при заданных параметрах. Если изменить какой-либо параметр САУ, например коэффициента передачи, то изменятся и коэффициенты характеристического уравнения D(p) = 0 и станут равными cн1 ,cн2 ,...,cнn . Уравнение примет вид:

Dн(p) = pn + cн1 pn -1 + cн2 pn -2 + ... + cнn = 0.

Это уже другое уравнение и оно также имеет единственное решение (pн1 ,pн2 ,...,pнn ), отличающееся от (p1 ,p2 ,...,pn ). Если плавно менять значение параметра САУ, то коэффициенты уравнения тоже будут плавно изменяться, а его корни будут перемещаться по комплексной плоскости (рис.81).

Каждый уникальный набору коэффициентов c1 ,c2 ,...,cn можно изобразить точкой в пространстве коэффициентов, по осям которого откладываются значения коэффициентов c1 ,c2 ,...,cn . Так уравнению третьей степени соответствует трехмерное пространство коэффициентов (рис.82). Пусть точка N с координатами (cN1 ,cN2,cN3) соответствует уравнению, имеющему решение (pN1,pN2,pN3), точка M с координатами (cM1 ,cM2 ,cM3) соответствует уравнению, имеющему решение (pM1 ,pM2 ,pM3). При изменении какого-либо параметра САУ коэффициенты характеристического уравнения будут изменяться, при этом точка в пространстве коэффициентов, соответствующая данному уравнению будет перемещаться по некоторой траектории, например из положения N в положение M. Этому перемещению будет соответствовать и перемещение корней (pN1,pN2,pN3) на комплексной плоскости в положение (pM1 ,pM2 ,pM3) (аналогично рис.81).

При этом движении некоторые корни будут переходить через мнимую ось комплексной плоскости из левой полуплоскости в правую и наоборот. В момент перехода такой k-й корень примет значение pK = j [image] K, а коэффициенты уравнения будут иметь определенные значения cK1,cK2,cK3, определяющие в пространстве коэффициентов точку K. Подставим корень pK в характеристическое уравнение, получим тождество:

D(pK ) = (j [image] K)3 + cK1(j [image] K)2 + cK2 (jK ) + cK3 = 0

Меняя w от - [image] до + [image], и находя при каждой частоте все возможные сочетания коэффициентов c1 ,c2 ,...,cn , удовлетворяющих уравнению

D(j [image] ) = (j [image])n + c1 (j [image])n-1 + c2 (j [image] )n-2 + ... + cn = 0,

можно построить в n-мерном пространстве коэффициентов сложную поверхность S, разделяющую его на области, называемое D-областями. Полученное уравнение называется уравнением границы D-разбиения.

Переход из одной D-области в другую через поверхность S соответствует переходу одного или нескольких корней через мнимую ось в плоскости корней. То есть каждая точка внутри определенной D-области соответствует уравнению с определенным количеством левых и правых корней. Поэтому области обозначают D(m) по числу m правых корней.

Достаточно взять любую точку в пространстве коэффициентов и найти для нее число правых корней. Затем, двигаясь по пространству коэффициентов через границу S, можно выявить обозначения всех других областей. Особый интерес представляет область D(0), которой соответствуют уравнения с полным отсутствием правых корней, называемая областью устойчивости. Описанный метод определения областей устойчивости называется методом D-разбиений.

Не обязательно строить сложную n-мерную картину D-разбиения, можно изменять значения, например, только двух коэффициентов, оставляя другие коэффициенты постоянными. Границу D-разбиения S можно строить не только также и в пространстве конкретных параметров системы, от которых зависят данные коэффициенты.

11.2. D-разбиение по одному параметру

Пусть необходимо выявить влияние на устойчивоять САУ, например, коэффициента усиления K. Приведем характеристическое уравнение к виду D(p) = S(p) + K [image] N(p), выделив члены, не зависящие от K в полином S(p), а в остальных членах, линейно зависящих от K, вынесем его за скобки. Граница D-разбиения задается уравнением

D(j [image] ) = S(j [image] ) + K [image] N(j [image] ) = 0, => K = -S(j [image] )/N(j [image]) = X( [image]) + jY( [image]).

Изменяя w от - [image] до + [image], будем вычислять X( [image]) и Y( [image]) и по ним строить точки границы D-разбиения. Пространство коэффициентов представляется системой координат X-Y (рис.83а). Обычно строят только половину кривой ( [image] = [0, + [image]), другую половину достраивают симметрично относительно вещественной оси.

Если в плоскости корней двигаться вдоль мнимой оси от - [image] до + [image] и штриховать ее слева (рис.83б), то это будет соответствовать движению вдоль линии D-разбиения при изменении w от - [image] до + [image] и штриховке ее также слева. Переходу корня в плоскости корней из штрихованной полуплоскости в нештрихованную вдоль стрелки 1 соответствует аналогичный переход через границу D-разбиения вдоль стрелки 1, и наоборот. Если пересекается область с двойной штриховкой (точки A, В, C), то в плоскости корней мнимую ось пересекает пара комплексно сопряженных корней.

Если известно количество правых корней, соответствующее хотя бы одной D-области, то двигаясь от нее через границы с учетом штриховок, можно обозначить все остальные области. Область с наибольшим количеством штриховок является претендентом на область устойчивости. Нужно взять любую точку из этой области и при соответствующем значении K проверить систему на устойчивость любым методом.

Есть одна особенность. Так как K - вещественное число, то Y( [image]) = 0, поэтому нас интересует не вся область устойчивости, а лишь отрезок вещественной оси в этой области, то есть K = X( [image]).

11.3. Прямые методы оценки качества управления

Устойчивость САУ является необходимым, но не достаточным условием для ее эффективного функционирования. Важное значение имеет качество управления, то есть степень удовлетворения совокупности требований к форме кривой переходного процесса, которая определяет пригодность системы для конкретных условий работы.

Для сравнения качества различных САУ исследуется их реакция на типовые воздействия. Обычно это ступенчатая (толчковая) функция, как один из наиболее неблагоприятных видов возмущений. Для систем, работающих с периодическими возмущениями, целесообразно оценивать качество управления при гармоническом воздействии. Все остальные возмущения можно разложить на ступенчатые воздействия с использованием интеграла Дюамеля, либо в ряд Фурье.

Все современные методы анализа качества управления можно разделить на прямые методы анализа по кривой переходного процесса или по частотным характеристикам, и косвенные методы, позволяющие, не решая дифференциального уравнения, определить некоторые показатели качества процесса управления; к ним, в частности, относятся корневые, интегральные и частотные методы.

11.3.1. Оценка переходного процесса при ступенчатом воздействии.

Пусть САР (рис.84) при t = 0 воздействует возмущающий фактор f в виде единичной ступенчатой функции. При нулевых начальных условиях динамический режим описывается переходной характеристикой h(t) = [image] y(t) = y(t) - y0 = -e(t) (рис.85). По ней можно определить все наиболее важные показатели качества управления.

1. Статическая ошибка eуст = y0 - yуст = -hуст - это разность между предписанным и действительным значением управляемой величины в установившемся режиме. Для статических систем статическая ошибка отлична от нуля (рис.85а) и пропорциональна величине возмущающего фактора f (в линейных САУ) и коэффициенту передачи системы по данному возмущению, а для астатических - равна нулю (рис.85б).

2. Время переходного процесса tпп - это время от момента воздействия, начиная с которого колебания управляемой величины не превышают некоторого наперед заданного значения, то есть |h(t)-hуст| [image] [image] . Обычно принимают [image] = 0.05hуст.

3. Перерегулирование s - это максимальное отклонение управляемой величины от установившегося значения, выраженное в относительных единицах: s = [image]. Здесь hmax1 - значение первого максимума переходной характеристики. При больших перерегулированиях могут возникнуть значительные динамические усилия в механической части системы, электрические перенапряжения и т.п. Допустимое значение s определяется из опыта эксплуатации. обычно оно составляет 0.1...0.3, иногда допускается до 0.7.

4. Частота колебаний [image] = 2 [image] /T, где T - период колебаний.

5. Число колебаний n за время tпп.

6. Декремент затухания k, равный отношению двух смежных перерегулирований: .

При создании САУ допустимые значения показателей качества оговариваются техническими условиями, что можно представить в виде диаграммы показателей качества. Это область, за границы которой не должна выходить переходная характеристика (рис.86).

11.3.2. Оценка качества управления при периодических возмущениях

Периодические возмущения можно разложить в ряд Фурье, поэтому их воздействие удобно анализировать по частотным характеристикам, показывающим, как звено преобразует гармонический сигнал.

Обычно используют АЧХ замкнутой САУ (рис.87), которую легко построить по АФЧХ разомкнутой САУ Wp(j [image] ), по формуле

Aз = [image] .

По этой кривой можно получить ряд показателей качества.

1. Показатель колебательности M - это отношение максимального значения АЧХ замкнутой САУ к ее значению при [image] = 0, то есть M = Aзmax( [image])/Aз(0). Так как

Aз(0) = [image] [image] 1,

при Kp >> 1, то M [image] Aзmax( [image]). Он характеризует склонность системы к колебаниям и не должен превышать 1.5.

2. Резонансная частота системы [image] p - это частота, при которой колебания проходят через систему с наибольшим усилением, а АЧХ достигает максимума.

3. Полоса пропускания системы - это интервал частот от [image] = 0 до = [image] 0, на котором выполняется условие Aз( [image] 0) [image] [image] [image] 0.707. Если она высокая, то система будет воспроизводить высокочастотные помехи.

4. Частота среза [image] ср - при которой АЧХ замкнутой САУ принимает значение, равное единице. По ней можно судить о длительности переходного процесса tпп [image] (1..2)2 [image] / [image] ср.

5. Склонность САУ к колебаниям характеризуют также ее запасы устойчивости по модулю (допускается от 6 до 20дб) и по фазе (допускается от 30 до 60 градусов).

Вопросы

  1. Как параметры САУ влияют на вид уравнения динамики?
  2. Что происходит с корнями характеристического полинома САУ при изменении ее параметров?
  3. Что такое пространство коэффициентов и плоскость корней?
  4. Что такое граница D-разбиений? Как найти ее уравнение? Как ее построить?
  5. Что такое D-области и как они нумеруются?
  6. Что такое область устойчивости?
  7. Как формулируется правило штриховки в случае D-разбиения по одному параметру?
  8. Как пронумеровать D-области в случае D-разбиения по одному параметру?
  9. Что называется качеством управления и зачем его оценивать?
  10. Что относится к прямым оценкам качества управления?
  11. Что называется косвенными методами оценки качества управления?
  12. Когда используются оценки качества управления при ступенчатом воздействии, и когда при периодическом?
  13. Перечислите прямые оценки качества управления при ступенчатом воздействии?
  14. Перечислите прямые оценки качества управления при периодическом воздействии?
  15. Что называется диаграммой показателей качества?