Карты Карно 5 и 6 переменных

Главная > Минимизация булевых функций > Карты Карно 5 и 6 переменных Обновлена -

Карты Карно 5 и 6 переменных

Особенностью изображения карт Карно для числа переменных более 4-х является то, что "математически" соседние столбцы карты Карно пространственно оказываются разнесенными. Таким образом, карта Карно для 5 переменных представляет собой две карты 4-х переменных, зеркально отображенные относительно центральнеой вертикальной линии (выделенной жирным тоном). При этом столбцы одного цвета в правой и левой частях карты фактически оказываются соседними по переменной x3 (соседние столбцы также указываются стрелками в нижней части карты). При выполнении склеиваний следует учитывать "соседство" указанных столбцов, особенно розовых и зеленых, которые пространственно разделены.

На рисунке слева приведен пример изображенной на плоскости карты Карно для 5 переменных. Внутри клеток карты Карно указаны десятичные эквиваленты номеров наборов, соответствующих данной клетке карты Карно. Значения переменных x3 x4 x5 в столбцах карты образуют зеркальный код Грея.

По такому точно принципу может быть изображена карта Карно для 6 переменных (три переменных в столбцах и три в строках), но с практической точки зрения работать с такой картой достаточно затруднительно.

Другим способ изображения карты Карно для 5 и более пернеменных является ее пространственная интерпретация (трехмерное изображение). Ниже приведена карта Карно для функции 6 переменных. При наведении курсора на 6-мерный куб справа от карты, на ней подсвечиваются соответствующие "пространственные" группы нулей или единиц.

Закрыть окно