Генератор

Генератор - нелинейное устройство, преобразующее энергию источника постоянного тока в энергию гармонических или релаксационных колебаний различной формы.

В цифровой и импульсной технике в качестве генераторов используются генераторы импульсов прямоугольной формы: мультивибраторы, блокинг-генераторы, работающие в автоколебательном, ждущем режиме и режиме деления частоты и синхронизации. В качестве формирователей импульсов прямоугольной формы используются также триггеры как устройства, имеющие два устойчивых состояния.

Для формирования линейно изменяющегося напряжения или тока используются генераторы фантастронного типа, генераторы линейно изменяющегося напряжения (ГЛИН), генераторы линейно изменяющегося тока (ГЛИТ).

Для генерирования кодовой последовательности применяются специальные формирователи, представляющие собой многокаскадные устройства функционального назначения.

Генерация

Генерация - нелинейный процесс преобразования энергии постоянного тока в энергию колебаний.

“Генератор единиц”

Генератор единиц - условное название генератора периодической последовательности прямоугольных импульсов.

По ГОСТ 2.743-82 генератор единиц обозначается прямо-угольником с одним выходом, в поле условного обозначения которого стоит единица, как показано на рис. Г1.

Рис. Г1

Генератор псевдослучайной последовательности

Генератор псевдослучайной последовательности (ГПСП) - функциональный генератор, предназначенный для формирования импульсов, т.е. комбинаций нулей и единиц с максимально возможной длиной.

Двоичная система счисления ( см. рубрику “Системы счисления”)

Двоичные переменные ( см. рубрику “Булева алгебра”)

Двунаправленные ключи

Двунаправленные ключи - устройства, имеющиеся только в сериях ИМС, построенных на КМОП-структурах (например, серии 176, 564, 1561,1564) .

Поскольку канал полевого транзистора размыкается и замыкается при изменении управляющего потенциала и затвор тока управления не потребляет, то цепь управления и коммутируемая цепь гальванически не связаны. На этом принципе основаны построение одиночного ключа и многопозиционных переключателей ( коммутаторов).

Эти устройства позволяют коммутировать как аналоговые, так и цифровые сигналы. В последнем случае одна и та же микросхема может работать как цифровой мультиплексор и демультиплексор. Коммутаторы КМОП являются двунаправленными. Таким образом сигнал можно подать на выход (это теперь одиночный вход) и, выбрав адрес, направить ток на один из многих выходов (номинально - входы).

Делители частоты с переменным коэффициентом деления

Делители частоты, построенные на основе цепи последовательно соединенных триггеров, имеют коэффициенты деления Кд= 2n, где n - число триггеров в цепи. В практике проектирования устройств необходимо иметь делители частоты с Кд [image] 2n. Такие задачи появляются при проектировании устройств цифрового отображения информации, устройств измерения времени и т.п. Алгоритм проектирования устройств недвоичных счетчиков и делителей частоты можно найти в

[ 10 ].

Демультиплексор

Демультиплексор - устройство функционального назначения, предназначенное для распределения цифровой информации с общей шины данных по соответствующим каналам.

Таким образом демультиплексор реализует операцию, обратную мультиплексированию, и под воздействием управляющих сигналов распределяет информацию по соответствующим адресам. Условное обозначение демультиплексора приведено на рисунке.

Для выходных сигналов демультиплексора можно записать булевы соотношения, описывающие функционирование устройства:

по которым можно просто построить логическую схему демультиплексора.

Детектор событий

Событием в цифровой технике называется переход от уровня логической единицы U1 к уровню логического нуля U0 и обратный переход.

Устройство, обнаруживающее эти переходы, называется детектором событий.

Детекторы событий строятся с применением сумматоров по модулю два.

Дешифратор

Дешифратор - цифровое устройство функционального назначения для распознавания кодовых комбинаций.

Дешифратор имеет число входов, равное значности принимаемого кода, и число выходов, равное возможному числу кодовых комбинаций.

Например, дешифратор для распознавания трехразрядного двоичного кода, при трех входных переменных имеет 23 выходов для распознавания всех входных комбинаций (рис. Д1).

Рис. Д1

Дешифратор, изображенной на рис. Д1, называется полным, т.к. опознает все комбинации входных переменных. В случае, когда число выходных переменных N < 2m, где m - число двоичных переменных, дешифратор называется неполным. В цифровой технике дешифраторы применяются в качестве устройств, преобразующих двоичные коды в коды для управления устройствами индикации.

Приведем таблицу истинности для дешифратора, изображенного на рис. Д1, - табл. Д1.

Табл. Д1

№п.п | Входы |  |  | Выходы F
 | X1 | X2 | X3 | 0 | 1 | 2 | 3 | 4 | 5 | 6 | 7
0 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0
1 | 0 | 0 | 1 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 0
2 | 0 | 1 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0 | 0
3 | 0 | 1 | 1 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0
4 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | 0
5 | 1 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0
6 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1 | 0
7 | 1 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0 | 1

Из таблицы истиности просто получить булевы выражения в дизъюнктивно нормальной форме (ДНФ).

С целью упрощения схемотехнического решения при построении DC многоразрядных кодов существуют ступенчатые и пирамидальные дешифраторы.

Диаграмма Вейча ( см. рубрику “Вейча карты”)

Дизъюнкция (дизъюнктор)

Дизъюнкция (логическое сложение) обозначается с помощью знака плюс, например, А+В ( читается “А” плюс “В”). Логическое сложение иногда называется также “соединением” или “включением” или “включающим ИЛИ” и может читаться “А или В”. Таблица истинности для операции дизъюнкциии приведена ниже.

F= А+B.

Таким образом, логической суммой входных переменных XN называется двоичная переменная Y, принимающая нулевое значение тогда и только тогда, когда все слагаемые одновременно равны нулю.

Цифровое устройство, реализующее операцию логического суммирования, называют дизъюнктором или элементом ИЛИ. По ГОСТ 2.743-82 дизъюнктор обозначается прямоугольником, в основном поле еоторогосхемах, обозначаемых в виде прямоугольника, в основном поле которого ставится символ “1” - условное обозначение реализуемой функции, число входов n равно числу входных переменных (рис. Д2).

Рис. Д2

Длительность импульса

В импульсной и цифровой технике применяются импульсы различной формы. Для единообразного определения его временных параметров независимо от его формы приняты следующие определения.

Линейная модель прямоугольного импульса первого приближения изображена на рис. Д3.

Рис. Д3

На рис. Д3 изображен идеальный импульс трапецеидальной формы, на котором можно выделить эти временные параметры импульса. Различают длительность импульса : на уровне 0,9 от Um, 0,1 от Um и 0,5 от Um, где Um - амплитуда импульса.

Под активной длительностью импульса ta понимается длительность импульса на уровне 0,5 от амплитудного значения.

Под длительностью фронта импульса tфр понимается интервал времени, в течение которого напряжение изменяется от уровня 0,1 до уровня 0,9 его амплитудного значения.

Под длительностью среза импульса tср понимается интервал времени, в течение которого напряжение уменьшается от уровня 0,9 до уровня 0,1 его амплитудного значения.

Динамический триггер

Динамическим триггером называется последовательностная схема, состоящая из комбинационной части и элемента памяти, имеющая два состояния. В одном из них под воздействием синхроимпульсов на выходе появляются импульсные сигналы ( а не перепады потенциала, как это имеет место в потенциальных триггерах), а второе состояние характеризуется отсутствием импульсов.

Диодно-транзисторный элемент (ДТЛ)

Диодно-транзисторный элемент (ДТЛ) представляет собой совокупность входной диодно-резистивной сборки, реализующей операцию И, и выходного инвертора.

Таким образом, элемент ДТЛ реализует операцию И-НЕ и, являясь функционально полным, может явиться основой построения серий цифровых ИМС. Отличительной особенностью элемента ДТЛ является то, что при подаче уровня логической единицы (при потенциальном способе представления информации) или импульсного сигнала при импульсном способе представления информации все входные диоды смещены в обратном направлении и потребления мощности от источника входного сигнала не происходит.

Дискретный сигнал (дискретная информация)

Дискретным называется сигнал, принимающий ограниченное число значений.

В цифровой технике , как правило, приходится иметь дело с сигналами, принимающими только два значения: есть импульс - нет импульса, высокий уровень потенциала - низкий уровень. Эти значения сигнала приписывают два символа “1” и “0”. Поэтому дискретные сигналы называют цифровыми.

Если высокому уровню потенциала приписывают значение 1, а низкому уровню потенциала - значение 0, то имеем дело с так называемой позитивной логикой.. При обратном сочетании речь идет о негативной логике.

Информация, отображаемая с помощью дискретных (цифровых) сигналов, получила название дискретной (цифровой) информации.

Дифференцирование сигналов

Операция дифференцирования - линейная операция, выполняемая линейными устройствами - дифференцирующими цепями, постоянная времени которых значительно меньше длительности сигнала. Выходное напряжение дифференцирующей цепи U2(t) связано со входным U1(t) следующим соотношением:

.

В цифровой и импульсной технике дифференцирующие цепи применяются, например, при формировании кратковременных импульсов из серии прямоугольных.

При практическом применении дифференцирующих цепей сложно выполнить условие дифференцирования:

t дц << t и ,

в случае смягчения этого требования цепи называются укорачивающими.

Запоминающее устройство

В цифровой технике под запоминающими устройствами (ЗУ) понимают технические средства, предназначенные для ввода (записи), хранения и выдачи (считывания) цифровой информации, представленной двоичными кодами. По виду носителя информации ЗУ могут быть: ферромагнитные, электромагнитные, сегнетоэлектрические, оптические, ультразвуковые, на основе сверхпроводимости и электронные. Среди последних значительное место занимают полупроводниковые ЗУ, выполненные в виде больших интегральных микросхем (БИС) и представляющие основной тип элементной базы внутренних ЗУ современных ЭВМ, как универсальных, так и специализированных.

В настоящее время основной объем выпуска микросхем памяти составляют БИС оперативных ЗУ (ОЗУ) и БИС постоянных ЗУ (ПЗУ).

Основными характеристиками ЗУ являются:

информационная емкость, определяемая максимальным объемом хранимой информации в битах или байтах;

быстродействие, характеризуемое временем выборки информации из ЗУ и временем цикла обращения к ЗУ с произвольным доступом или временем поиска и количеством переданной в единицу времени информации в ЗУ (или из ЗУ) с последовательным доступом; энергопотребление, опреляемое электрической мощностью, потребляемой ЗУ от источников питания в каждом из режимов работы;

надежность, стоимость, массо-габаритные показатели и др.

Микросхемы ОЗУ отличаются наиболее широкой номенклатурой среди БИС памяти. Они выпускаются во всевозможных конструктивно-технологических вариантах емкостью от 16 бит до 16 Мбит. ОЗУ относятся к энергозависимым устройствам, поскольку информация, записанная в них, при снятии напряжения питания безвозвратно теряется и восстановлению не подлежит.

Разновидностью ОЗУ являются энергонезависимые БИС ОЗУ (ЭН ОЗУ), имеющие ограниченное пока применение в связи со сложностью элементов памяти и значительной стоимостью.

Интегральные ПЗУ выпускаются трех видов:

масочные ПЗУ, программируемые в процессе изготовления с помощью индивидуальных фотошаблонов (масок) по заказам потребителей;

однократно программируемые ПЗУ (ППЗУ), в которых запись информации призводится потребителем путем разрушения плавких перемычек матрицы элементов памяти импульсами электрического тока;

репрограммируемы ПЗУ (РПЗУ), в которых информация может неоднократно изменяться электрическим способом.

Запоминающий элемент (см. рубрику “Элементы памяти”).

Импульс

Под импульсом в цифровой и импульсной технике понимается сигнал, отличающийся от нулевого или постоянного уровня U0 в течение времени, сравнимого с постоянной времени устройства, проводящего его обработку.

В цифровой и импульсной технике обычно оперируют с видеоимпульсами, т.е. импульсами без высокочастотного заполнения. Импульсы могут иметь самую разнообразную форму: прямоугольную, трапецеидальную, треугольную, колоколообразную и т.д. Диапазон длительностей импульсов, с которыми имеют дело в современной технике, весьма широк и лежит в пределах от единиц наносекунд (1 нс=10-9 с) до миллисекунд ( 1мс= 10-3 с ) и более.

Импульсно-потенциальная система

Перепадами напряжения (тока) называются быстрые, практически мгновенные скачкообразные изменения напряжения (тока) между двумя уровнями. Таким образом, перепадами напряжения (или потенциала) можно кодировать цифровую информацию. В системах обработки информации, где по части входов (выходов) информация представлена в импульсной форме (т.е. наличие импульса в тактовые моменты времени означает символ “1”, а отсутствие его в этот момент времени - символ “0”), а по другой части входов (выходов) - представлена в потенциальной форме, называют импульсно-потенциальными системами.

Инверсия

Инверсия ( логическое отрицание, операция НЕ) - одна из основных логических операций булевой алгебры.

Инверсия обозначается чертой, ставящейся над переменной. Например, отрицание переменной А, читаемое “не А”, записывается [image] . Таблица истинности для операции НЕ представлена ниже.

.

Инвертор

Инвертором называют логическое устройство, реализующее операцию логического отрицания.

В простейшем случае в качестве инвертора может быть использован транзисторный ключ с общим эмиттером.

Условное графическое обозначение инвертора приведено ниже.

Интегрирование сигналов

Интегрирование сигналов - линейная операция, производимая линейными устройствами - интегрирующими цепями, постоянная времени которых значительно больше длительности сигнала. Сигнал U2 (t) на выходе интегрирующей цепи описывается выражением

.

Интегрирующие цепи (интеграторы) применяются в цифровой и импульсной технике для реализации операции интегрирования в аналоговых ЭВМ и для построения генераторов линейно изменяющегося напряжения или тока.

Интерфейс

Термин “интерфейс” обычно используют для обозначения совокупности правил взаимодействия некоторой группы компонентов вычислительной системы и правил построения технических средств, обеспечивающих это взаимодействие.

Основной задачей интерфейса (или, другими словами, сопряжения) является на основе унификации осуществить совместимость программных, аппаратных и конструктивных средств, обеспечивающих заданное качество взаимодействия различных функциональных элементов в едином процессе обработки информации в ЭВМ на этапах сбора, преобразования и обработки, хранения и выдачи результатов и управляющих воздействий.

Различают системный, межмашинный и малый интерфейсы. В соответствии с типом реализуемой системы ввода-вывода системные интерфейсы подразделяются на следующие классы:

сосредоточенные (например, интерфейсы персональных ЭВМ, Microbus, Multibus 11),

локально-сосредоточенные (Q-bus),

локальные (Unibus,ОБЩАЯ ШИНА СМ ЭВМ, И-41 СМ ЭВМ),

локально-распределенные (bitbus, последовательная магистраль micro NOVA).

Межмашинный интерфейс обеспечивает построение мультипроцессорных систем (Multibus 11, VMEbus, Eurobus и т.п.), локальных и распределенных сетей.

Малые интерфейсы учитывают различие физических принципов работы групп периферийных устройств, а следовательно, различие информационных потоков. Контроллеры малых интерфейсов обеспечивают выход на системный интерфейс, при этом контроллеры периферийных устройств должны выходить на соответсвующий малый интерфейс. Таким образом осуществляется унификация подключения периферийных устройств к различным вычислительным комплексам.

Иными словами, главной задачей интерфейса является обеспечение информационной связи ЭВМ с “внешним миром”.

Карты Карно

Минимизация булевых функций может быть проведена одним из известных методов, к числу которых относится метод карт Карно. Карта Карно для n двоичных переменных представляет собой прямоугольную таблицу с чилом клеток в ней, равной N=2n. Таким образом, для трех переменных карта Карно включает восемь клеток, для четырех - шестнадцать и т.д.

На карту Карно в так называемом циклическом коде Грея (см. рубрику “Циклический код Грея”) заносятся минтермы. Для четырех переменных карта Карно имеет следующий вид:

На карте Карно в коде Грея по горизонтали перечисляются переменные X1, X2, а по вертикали - переменные Y1, Y2.

Метод карт Карно использует одну из известных аксиом алгебры Буля:

.

Можно сформулировать несколько правил, основанных на этой аксиоме (аксиома склеивания переменных).

Если минтермы расположены в соседних или крайних клетках строки или столбца, то ранг минтерма снижается на один порядок, а склеиванию подлежит переменная, входящая с разными показателями инверсии.

В приведенной карте Карно исходное выражение содержит четыре минтерма четвертого ранга (16 букв), а минимизированное (тупиковое) выражение состоит из двух минтермов третьего ранга (6 букв).

.

Если минтермы образуют строку, столбец, квадрат или большой квадрат, то ранг минтерма снижается на два порядка, а склеиванию подлежат переменные, входящие с разными показателями инверсии.

Например, пусть задана карта Карно, в которую занесены семь минтермов четвертого ранга, образующие строку и столбец, т.е. исходное булево выражение состоит из 28 букв, тупиковая форма содержит два минтерма второго ранга (4 буквы).

.

Квантование по уровню

При дискретном представлении непрерывного сигнала наряду с задачей дискретизации во времени в соответствии с теоремой Котельникова возникает задача квантования входного сигнала по уровню. В простейшем случае , когда сигнал представлен двумя уровнями квантования, говорят о бинарном квантовании. Для уменьшения ошибки квантования и более точного восстановления исходного сигнала по его дискретным выборкам необходимо число уровней квантования увеличивать. Для АЦП увеличение разрядности определяет разрешающую способность, выражаемую в процентах, децибеллах или разрядах и определяет потенциальные возможности АЦП с точки зрения достижимой точности. Например, 12-разрядный АЦП имеет разрешающую способность 1/4096, или 0, 245% от полной шкалы, или -72,2 дБ [ 11 ].

В табл. К1 приведены основные данные по разрешающей способности как функции числа двоичных разрядов АЦП.

Таблица К1

Раз-ряды (n) | Разреше-ние | дБ | % |  | Значение младшего значащего разряда (МЗР)
 |  |  |  | 20В |  | 10В |  | 5В |  | 2,5В |  | 1В
2 | 1/4 | -12 | 25 |  | 5В |  | 2,5 В |  | 1,2В |  | 625мВ |  | 250мВ
4 | 1/16 | -24,1 | 6,2 |  | 1,25В |  | 625мВ |  | 312мВ |  | 156мВ |  | 62,5мВ
6 | 1/64 | -36,1 | 1,6 |  | 312мВ |  | 156мВ |  | 78,1мВ |  | 39,1 мВ |  | 15,6мВ
8 | 1/256 | -48,2 | 0,4 |  | 78,1 мВ |  | 39,1 мВ |  | 19,5 мВ |  | 9,77мВ |  | 3,91 мВ
10 | 1/1024 | -60/2 | 0,024 |  | 19,5мВ |  | 9,77мВ |  | 4,88мВ |  | 2,44мВ |  | 977 мкВ
12 | 1/4096 | -72,2 |  |  | 4,88мВ |  | 2,44мВ |  | 1,22мВ |  | 610 мкВ |  | 244 мкВ
14 | 1/16384 | -84,3 | 0,006 |  | 1,22мВ |  | 610 мкВ |  | 305 мкВ |  | 153 мкВ |  | 61 мкВ
16 | 1/65536 | -96,3 | 0,0015 |  | 305 мкВ |  | 153 мкВ |  | 76,3 мкВ |  | 38,1 мкВ |  | 15,3 мкВ
18 | 1/262144 | -108,4 | 0,0004 |  | 76,3 мкВ |  | 38,1 мкВ |  | 19,1 мкВ |  | 9,54 мкВ |  | 3,81 мкВ
19 | 1/524288 | -114,4 | 0,0002 |  | 38,1 мкВ |  | 19,1 мкВ |  | 9,54 мкВ |  | 4,77 мкВ |  | 1,91 мкВ
20 | 1/1048576 | -120,4 | 0,0001 |  | 19,1 мкВ |  | 9,54 мкВ |  | 4,77 мкВ |  | 2,38 мкВ |  | 0,954 мкВ
21 | 1/2097152 | -126,4 | 5*10-5 |  | 9,54 мкВ |  | 4,77 мкВ |  | 2,38 мкВ |  | 1,19 мкВ |  | 0,477 мкВ
22 | 1/4194304 | -132,4 | 24*10-6 |  | 4,77 мкВ |  | 2,38 мкВ |  | 1,19 мкВ |  | 596нВ |  | 238 нВ
23 | 1/8388608 | -138,5 | 12*10-6 |  | 2,38 мкВ |  | 1,19 мкВ |  | 596нВ |  | 298 нВ |  | 119 нВ
24 | 1/16777216 | -144,5 | 6*10-6 |  | 1,19 мкВ |  | 596нВ |  | 298 нВ |  | 149 нВ |  | 59,6 нВ

Ключ электронный

Электронный ключ (ЭК) является первоосновой, элементарным кирпичом, из которого строится здание цифровой техники.

Электронным ключом называется устройство, обладающее двумя состояниями: “включено” и “выключено”, которые отличаются друг от друга значением выходного параметра: Rвых, Uвых, Iвых.

Элементарным ключом является нелинейное устройство, два рабочих состояния которого отличаются выходным сопротивлением. В качестве активного элемента в электронном ключе используются диоды, транзисторы и другие элементы с выраженной нелинейностью вольт-амперной характеристики. Кроме активных элементов в состав ключа входят источники питающих напряжений, пассивные элементы и т.д.

В микроэлектронном исполнении в качестве активного элемента используются интегральные диоды и транзисторы. Наибольшее применение нашли транзисторные ЭК.

Разновидности транзисторных ключей (ТК):

ключ с общей базой;

ключ с общим коллектором;

ключ с общим эмиттером;

ключ-звезда.

Наибольшее применение нашли транзисторные ключи с общим эмиттером. Особенности статического и переходного режима работы ТК изложены в [ 5 ].

Коды арифметические

Для отображения информации в цифровых устройствах используют различные арифметические коды, составленные по определенным правилам. Различные варианты арифметических кодов используются в цифровых системах для упрощения структур и облегчения их взаимодействия с устройствами ввода-вывода и для повышения надежности аппаратуры за счет автоматического обнаружения и исправления ошибок.

Самым простым кодом является код прямого замещения или бинарный код (БК), являющийся двоичным эквивалентом десятичного числа (см. рубрику “Системы счисления”). Для обозначения знака числа отводится знаковый разряд (ЗН), причем “0” в этом разряде обозначает положительное число, “1” - число отрицательное.

Тогда формат представления чисел будет выглядеть следующим образом:

ЗН D0 D1 D2 D3 D4 D5 D6

При выполнении арифметических операций над операндами может возникнуть переполнение разрядной сетки, например, при сложении двух положительных чисел со знаком; в результате мы можем получить неверный результат, когда в знаковом разряде появляется единица, т.е. получено отрицательное число. Для устранения ошибок при операциях с операндами со знаком применяют модифицированный двоичный код, в котором для обозначения чисел со знаком отводится два знаковых разряда: двумя нулями обозначается положительное число, а двумя единицами - отрицательное. В этом случае факт переполнения разрядной сетки можно обнаружить достаточно просто, проверяя значения знаковых разрядов после выполнения операции на четность с помощью сумматора по модулю два. При результате проверки, равным нулю, переполнения разрядной сетки не произошло, при обратном результате - произошло ее переполнение.

Дополнительные коды используются для реализации операции вычитания на основе типовых схем сумматоров, применяемых в арифметических устройствах. Существуют две разновидности дополнительных кодов: код с дополнением до единицы (обратный код) и с дополнением до двух. Первый характеризуется тем, что результат сложения преобразованного числа с исходным дает единицы во всех разрядах. Код с дополнением до двух характерен тем, что суммирование преобразованного и исходного чисел дает нули во всех разрядах с переносом единицы из старшего бита результрующего числа. Для получения дополнения до двух необходимо во всех разрядах заменить единицы и нули на противоположные символы, а к полученному результату в младший бит добавить единицу.

Особое место занимают коды, предназначенные для отображения десятичных чисел (табл. К2).

Таблица К2.

Десятичные числа | Код с избытком 3 |  |  |  | Код Айкена |  |  |  | 2 из 5 |  |  |  |  | Код Джонсона
 |  |  |  |  | 2 4 2 1 |  |  |  |  |  |  |  |  |
 | x1 | x2 | x3 | x4 | x1 | x2 | x3 | x4 | x1 | x2 | x3 | x4 | x5 | x1 | x2 | x3 | x4 | x5
0 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 0 | 0 | 0 | 0
1 | 0 | 1 | 0 | 0 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 0 | 0 | 1 | 0 | 0 | 0 | 0
2 | 0 | 1 | 0 | 1 | 0 | 0 | 1 | 0 | 1 | 0 | 1 | 0 | 0 | 1 | 1 | 0 | 0 | 0
3 | 0 | 1 | 1 | 0 | 0 | 0 | 1 | 1 | 1 | 0 | 0 | 1 | 0 | 1 | 1 | 1 | 0 | 0
4 | 0 | 1 | 1 | 1 | 0 | 1 | 0 | 0 | 0 | 1 | 0 | 1 | 0 | 1 | 1 | 1 | 1 | 0
5 | 1 | 0 | 0 | 0 | 1 | 0 | 1 | 1 | 0 | 0 | 1 | 1 | 0 | 1 | 1 | 1 | 1 | 1
6 | 1 | 0 | 0 | 1 | 1 | 1 | 0 | 0 | 1 | 0 | 0 | 0 | 1 | 0 | 1 | 1 | 1 | 1
7 | 1 | 0 | 1 | 0 | 1 | 1 | 0 | 1 | 0 | 1 | 0 | 0 | 1 | 0 | 0 | 1 | 1 | 1
8 | 1 | 0 | 1 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 1 | 0 | 1 | 0 | 0 | 0 | 1 | 1
9 | 1 | 1 | 0 | 0 | 1 | 1 | 1 | 1 | 0 | 0 | 0 | 1 | 1 | 0 | 0 | 0 | 0 | 1
Избыточные | 0 | 0 | 0 | 0 | 0 | 1 | 0 | 0 | Все 5-разряд- |  |  |  |  | Все 5-разряд-
слова | 0 | 0 | 0 | 1 | 0 | 1 | 1 | 1 | ные числа, где |  |  |  |  | ные числа, где
(комбина- | 0 | 0 | 1 | 0 | 0 | 1 | 1 | 0 | единицы зани- |  |  |  |  | между едини-
ции) | 1 | 1 | 0 | 1 | 1 | 0 | 0 | 1 | мают не два |  |  |  |  | цами располо-
 | 1 | 1 | 1 | 0 | 1 | 0 | 0 | 0 | разряда |  |  |  |  | жены нули и
 | 1 | 1 | 1 | 1 | 1 | 0 | 1 | 1 |  |  |  |  |  | наоборот

Остановимся на некоторых особенностях кодов, представленных в таблице.

Код с избытком 3. Этот код применяется для кодирования декад (вместоБК) при двоично-десятичном представлении чисел. Особенность кода состоит в том, что он самодополняющий, т.е. дополнительное до 9 число в каждой декаде получается заменой нулей на единицы и наоборот в каждом двоичном разряде. Конструкция этого кода заключается в перечислении двоичных эквивалентов десятичных чисел от 0+3=3 до 9+3=12.

Код Айкена (код 2-2-1). Этот код тоже самодополняющийся; цифры 2, 4, 2, 1 означают веса разрядов.

Код 2 из 5. Преимущество этого кода состоит в простоте обнаружения ошибок в аппаратуре, поскольку единичное искажение любого символа может быть легко опознано.

Код Джонсона представляет собой чередующиеся “волны” нулей и единиц. Формирование последовательности чисел в таком виде может быть реализовано использованием сдвигающих регистров.

Кроме кодов, перечисленных в таблице К1, для отображения десятичной информации используется двоично-десятичный код. ДДК применяется для устройств, использующих декадную форму отображения информации (цифровые измерительные приборы, калькуляторы, аппаратура цифропечати и т.д.) Этот код для отображения каждого десятичного разряда требует четыре двоичных разряда, комбинации двоичных чисел от 10 до 15 включительно считаются избыточными или нештатными и используются для упрощения структурных схем преобразователей кодов или для обнаружения ошибок.

Комбинационные схемы

Комбинационные схемы (КС) - логические устройства, состояния выходов которых зависят только от состояния входов в данный момент времени и от предшествующего состояния не зависят.

Отличительной особенностью КС является независимость их состояния от предыстории, что в схемотехническом решении отличает их от последовательностных схем отсутствием элементов памяти.

К числу комбинационных схем функционального назначения относятся: сумматоры, преобразователи кодов, шифраторы, дешифраторы, мультиплексоры, демультиплексоры и т.п.

Компаратор ( см. рубрику “Схемы сравнения кодов”)

Конъюнктор (см. рубрику “Булева алгебра”)

Конъюнкция (см. рубрику “Булева алгебра”)