Линии задержки

Линией задержки (ЛЗ) называется пассивный четырехполюсник, сигнал на выходе которого появляется через некоторый интервал времени (задержку) по отношению к входному сигналу.

В импульсной технике в качестве ЛЗ может применяться недиспергирующая (неискажающая) линия передачи с распределенными параметрами, либо искусственная длинная линия с сосредоточенными параметрами. В цифровой технике в качестве устройств задержки сигналов могут использоваться элементы: повторители, базисные элементы И-НЕ, ИЛИ-НЕ, “исключающее ИЛИ”, обладающие конечным временем задержки, а на их основе возможно построение ЛЗ с дискретным временем задержки.

Логика позитивная

Логика называется позитивной, если в потенциальной системе высокому уровню потециала U1 приписывается значение логической единицы, а низкому уровню потенциала U0 - логический нуль.

Логика негативная

Логика называется негативной, если в потенциальной системе высокому уровню потенциала U1 приписывается значение логического нуля, а низкому уровню потенциала U0 - значение логической единицы.

Логические элементы

Логическим элементом называется устройство, выполняющее элементарные логические операции И, ИЛИ, НЕ, И-НЕ, ИЛИ-НЕ, относящиеся к функциональным элементам одноступенчатой логики и элементы двухступенчатой логики: И-ИЛИ-НЕ, И-ИЛИ ИЛИ-И и др.

ДТЛ (см. рубрику “Диодно-тразисторный элемент”).

ДТЛ-2 (см. рубрику “Диодно-тразисторный элемент”).

РТЛ (см. рубрику “Резистивно-транзисторная логика”).

ТТЛ

Логический элемент транзисторно-транзисторной логики (ТТЛ) реализует логическую операцию И-НЕ. Операция И реализуется на многоэмиттерном транзисторе, а операция инверсии (логического отрицания), в простейшем случае, - на ключе с общим эмиттером. С целью повышения нагрузочной способности выходной каскад выполняется по сложной схеме, как это принято в т.н. стандартных сериях ТТЛ [ 7 ].

ЭСЛ

Логический элемент ЭСЛ является элементом с парафазным выходом и реализует логические функции ИЛИ, ИЛИ-НЕ. Благодаря появлению второго выхода расширяются функциональные возможности элемента, а вследствие того, что ни одна транзисторная структура, образующая схему ЭСЛ, не работает в режиме насыщения, эти устройства имеют наибольшее быстродействие и применяются для построения скрий ИМС повышенного быстродействия [ 6 ].

Логическое отрицание ( см. рубрику “Инверсия”).

Логическое сложение (см. рубрику “Дизъюнкция”).

Логическое умножение (см. рубрику “Конъюнкция”).

Мажоритарный элемент (функция)

1. Мажоритарный элемент - логическое устройство функционального назначения, сигнал на выходе которого всегда соответствует большинству значений входных переменных.

2. Мажоритарной функцией называют функцию, равную единице, если большинство переменных истинно:

F=A#D#C

Поясним определение на примере мажоритарного элемента “2 из 3”,

приведя условное графическое обозначение и таблицу истинности .

Как видно из таблицы истиности, сигнал на выходе элемента действительно соответствует значению числа входных переменных, равных или больших двух. Иными словами, сигнал на выходе мажоритарного элемента “два из трех” появляется тогда и только тогда, когда возбуждены два и более входа.

Синтез мажоритарных элементов можно произвести известными методами, например методом карт Карно.

Макстермы

Допустим, что имеется булева функция

. ( 1)

Соотношение (1) является булевой суммой двух переменных, причем каждая из них входит в выражение только один раз в прямой и инверсной форме.

Сумма, образованная таким образом, называется макстермом

У двух переменных X, Y имеется четыре макстерма:

, [image], [image], [image]. ( 2)

У булевых функций многих переменных число макстермов определяется сооношением NM=2n , где n - число переменных, а индекс соответствующего макстерма представляет собой десятичное число двоичного представления переменных, если переменная в прямой форме будет задана единицей, а в инверсной - нулем.

Пример. Для функций трех переменных определим макстермы M4, M7, M5 :

Основные свойства макстермов

1. Булево произведение всех макстермов n переменных равно нулю

.

2. Булева сумма неодинаковых макстермов равна единице, т.е. при

.

Меандр

Меандр - периодическая последовательность импульсов прямоугольной формы со скважностью, равной двум, т.е. длительность импульса равна половине периода повторения.

Методы анализа импульсных процессов и устройств

Отличительной особенностью процессов, протекающих в импульсных устройствах, является то обстоятельство, что длительность сигналов, действующих в них, соизмерима с постоянной времени устройств, проводящих их обработку. Таким образом, основным режимом работы импульсных устройств является переходной процесс. Для анализа процессов в линейных электрических цепях с сосредоточенными параметрами применимы законы Кирхгофа, теорема суперпозиции, теоремы об эквивалентных генераторах напряжения и тока.

Математический аппарат, используемый в импульсной технике, предназначенный для расчета статического и переходного режимов, основан на классическом методе составления и решения конечных или дифференциальных уравнений ( уравнений состояния схемы). При этом удобным математическим аппаратом решения дифференциальных уравнений состояния является метод преобразования Лапласа.

Учет нелинейности вольт-амперных характеристик активных элементов ИУ приводит к составлению нелинейных уравнений, решаемых численными методами с применением современных ЭВМ и пакетов прикладных программ.

Метод карт Карно (см. рубрику “Карты Карно”).

Минимизация логических функций

Под минимизацией логических функций понимается наиболее простое ее представление в виде суперпозиции операций, составляющих какую-либо фиксированнную, функционально полную систему.

В настоящее время в наиболее развитом состоянии оказались методы, применимые в случае, когда набор операций состоит из дизъюнкции, конъюнкции и инверсии. При решении канонической задачи минимизации искомым является представление заданной булевой функции в дизъюнктивно нормальной форме (ДНФ). При проектировании микроэлектронной аппаратуры удобен метод минтермов, среди которых можно назвать уже упоминавшийся метод карт Вейча и метод карт Карно (см. рубрику “Карты Карно”). Метод карт Карно удобен не только при проектировании комбинационных схем, но и схем последовательностного типа, содержащих в своем составе элементы памяти.

Для решения задачи минимизации необходимо произвести последовательный перебор всех функций системы, их парных, тройных и т.п суперопозиций до тех пор пока не получим так называемую тупиковую форму. Для этого необходимо вспомнить одну из аксиом алгебры Буля:

и основные законы булевой алгебры.

Пример. Минимизируем выражение

.

Задача минимизации выполнена, получена тупиковая форма, содержащая три буквы против шести в исходном выражении (структурной формуле).

Минтермы

Пусть мы имеем следующее булево соотношение:

. ( 3)

Уравнение состоит из булевой суммы слагаемых, которые, в свою очередь, отличаются между собой только наличием или отсутствием инверсий.

Сумма, образованная таким образом, называется минтермом (конституентом единицы).

У двух переменных имеются четыре минтерма:

, [image], [image], [image].

Продолжив это для функций многих переменных, получим, что число минтермов для n переменных равно Nm=2n, а индекс соответствующего минтерма является десятичным эквивалентом двоичного числа, полученного заменой инверсии на нуль, а переменных без инверсии - на единицы.

Можно доказать, что любую булеву функцию можно представить в виде суммы минтермов или произведения макстермов.

Минтермы и макстермы, индексы которых находятся в соотношении, указанном в табл. М1, называются одноименными. Например, для функции трех переменных ( n=3) [image] является одноименным макстерму [image].

Отсюда следует важный вывод о дуальности логических операций:

Для перехода от операции логического сложения к операции логического умножения и наоборот следует заменить знаки соответствующих операций с одновременной заменой знаков инверсии.

Таблица М1

Деся-тич-ный экви-ва-лент чисел | Зна-че-ния пере-мен-ных | Минтермы | Одноимен-ные макстермы | Макстермы | Одноименные минтермы
0 | 000 |  |  |  |
1 | 001 |  |  |  |
2 | 010 |  |  |  |
3 | 011 |  |  |  |
4 | 100 |  |  |  |
5 | 101 |  |  |  |
6 | 110 |  |  |  |
7 | 111 |  |  |  |

Как следует из табл. М1, минтерм является инверсией одноименного макстерма и наоборот. Между индексами одноименных минтермов и макстермов существуют следующие соотношения:

Основные свойства минтермов

Булева сумма всех минтермов любого числа переменных равна единице, т.е.

.

Булево произведение минтермов, имеющих разные индексы, равно нулю, т.е. при

.

Мнемонические обозначения на функциональных схемах и таблицах состояний

Табл. М2

Обозначение | Название | Значение, расшифровка
A0 - A3 | Operand A | Слово, тетрада, операнд А для четырехразрядного арифметико-логического устройстав (АЛУ)
A=B | Parity | Выход равенства операндов А и В в АЛУ
A<B, A>B |  | Выходы неравенства операндов А и В в АЛУ
ALU | Arifhmetic logic unit | Арифметико-логическое устройство (АЛУ)
A/S | Asynchro/Synchro | Вход переключения синхронного и асинхронного режимов
B0 - B3 | Operand B | Слово, тетрада, операнд В для четырехразрядного АЛУ
 | Binfry/Decimal | Вход переключения счета двоичного (В) на десятичный (D)
C | Clock input | Вход тактовых импульсов
CD | Count down | Вход тактовых импульсов для уменьшения счета
CE | Clock enable | Вход разрешения тактовых импульсов
CEP | Count enable parallel | Вход параллельного наращивания числа разрядов счетчика
CET | Count enable trickle | “Трюковый” вход разрешения счета, необходимый при наращивании разрядности счетчика
CLR | Clear | Вход сброса, очистка счетчика
CВХ, Cin | Carry in | Вход для разряда переноса
Cn | Carry in | Вход переноса в сумматор
Cn+1 , Cn+y | Carry out | Выходы переноса: от сумматора (Cn+1), от четырехразрядного АЛУ (Cn+4)
Cn+z | Carry outputs | Выходы вспомогательных сигналов переноса от схемы ускоренного переноса для АЛУ
CPU | Central processor unit | ЦПУ - центральное процессорное устройство
Cвых, Cout | Carry out | Выход старшего разряда переноса
CS | Chip select | Выбор кристалла, доступ к одной из микросхем, входящих в устройство
CU | Count up | Вход тактовых импульсов для увеличения счета
CRU | Carry lock ahead unit | Схема ускоренного переноса (СУП)
D | D-flip-flop | D-триггер
D | Data input | Вход данных триггера, регистра, счетчика
D0 - D3 - Dn | Parralel inputs | Входы параллельной загрузки данных в счетчики, регистры
DEMUX | Demultiplexer | Демультиплексор
DSI | Data serial input | Вход последовательных данных
DS | Data select | Вход выбора данных
DL, DR | Data left, data right | Входы для последовательной загрузки данных слева и справа (в регистр)
DSL, DSR | Data shift left, data shift right | Входы для последовательного сдвига данных влево и вправо
DS0 - DS7 | Data serial inputs | Входы данных для последова-тельной загрузки
E | Enable | Вход сигнала разрешения
EC | Enable count | Вход разрешения счета
EE | Enable even | Вход разрешения четный
EI | Enable input | Вход стробирующего сигнала
EI0 | Enable input/output | Вход сигнала одновременного разрешения по входу и выходу
E0 | Enable output | Вход разрешения по выходу
F0 - F3 | Function output | Выходы функции (результаты работы АЛУ)
G | Carry generation | Вспомогательный сигнал переноса между АЛУ и СУП
GS | Group signal | То же, групповой сигнал
H | Histeresis input | Вход управления гистерезисом логического элемента
I/O | Input/Output | Один провод входа/выхода
I1 -I16 | Input 1-16 | Входы шестнадцатиразрядного слова
JK | JK-flip-flop | JK-триггер
JK | JK-inputs | Входы J и K управления триггером
LSB | Ltast Significant Bit | Младший значащий разряд (МЗР)
M | Mode control | Вход переключения режимов “Арифметика - логика” для АЛУ
MSB | Most Significant Bit | Старший значащий разряд (СЗР)
MUX | Multipltxer | Мультиплексор
OE | Odd Enable | Вход разрешения нечетный
PI | Polarity Input | Вход полярности
P | Carry propagation | Вспомогательный сигнал переноса между АЛУ и СУП
PE | Parralel Enable load | Вход разрешения параллельной загрузки
P/S | Parralel/Serial | Вход управления режимом загрузки: параллельный/последова-тельный
 | Outputs | Прямой и инверсный выходы
QCC | Q-output Conversion Complete | Выход завершения преобразования
Preset | Psevious set | Предварительная установка
R | Reset | Асинхронный сброс триггера, счетчика, регистра
RD | Read output | Выход чтения
RA, RB | Read Fdresses A and B | Адреса чтения А и В
RE | Read Enable | Вход разрешения чтения
RS | RS-flip-flop, RS-latch | RS- триггер, RS-защелка
 | Timing components | Наименование выводов для под-ключения времязадающих элемен-тов
S | Set | Установка триггера, счетчика, ре-гистра в единичное состояние
SE | Set Enable | Разрешение предварительной уста-новки счетчика
St | Start | Вход запуска регистра последова-тельного приближения
SAR | Succesive Approxi-mation Register | Регистр последовательного прибли-жения (РПП)
SI | Serial Input | Вход последовательный
SIR, SIL | Serial Input Right, SI left | Входы последовательные справа и слева
SR | Synchro Reseat | Вход синхронного сброса триггера, счетчика, регистра
SUB | Subtractor | Вычитатель
SUM | Summator | Сумматор
S0 - S3 - Sn | Select input | Входы выбора режима работы
 | Sum odd, Sum even | Выходы сумм четности и нечетности
 | Sum outputs | Выходы суммы
T | Toggle flip-flop | Счетный триггер
TC | Terminal Count | Выход окончания счета
T/C | True/Complement | Вход переключения кодов: прямой - дополнительный
TCD | Terminal Count down | То же, на уменьшение счета
TCU | Terminal Count up | То же на увеличение счета
Uи.п.К |  | Напряжение коллектор. питания
Uи.п.Э |  | Напряжение эмиттерного питания
 | Up/Down | Вход управления реверсивным счетчиком: больше/меньше
W | Wright Input | Вход записи
WA, WB | Wright Adress A, B | Адреса записи операндов А и В в память
WE | Wright Enable | Вход разрешения записи
Z | Z-state | Z-состояние для логического элемента с тремя состояниями
Y | Output | Выход логического элемента
B | Высокий | Высокий статический (входной или выходной) уровень
H | Низкий | Низкий статический (входной или выходной) уровень
в, н | Высокий, низкий | Логические уровни перед приходом тактового импульса
х | - | Схема безразлична к любым сигналам на данном входе (см. таблицы состояний)
/ | - | Запуск схемы перепадом о/1
\ | - | Запуск схемы перепадом 1/0
 | - | Запуск схемы полным импульсом
 | - | Состояние выходов (уровни в или н) перед приходом тактового импульса (перепада)
 | - | Окончательные выходные уровни после прихода тактового импульса (перепада)
Qn, Qn+1 | - | Состояние выхода в моменты времени tn, tn+1

Мультивибратор

Для получения колебаний, характеризующихся участками со скачкообразными изменениями напряжений и токов (так называемых “разрывных колебаний”), применяются релаксационные генераторы или релаксаторы. Релаксаторы, как и триггеры, относятся к классу спусковых устройств и основаны на применении усилителей с кольцом положительной обратной связи или приборов с отрицательным сопротивлением. В отличие от триггеров, имеющих два устойчивых состояния, генераторы релаксационного типа имеют максимум одно устойчивое состояние.

Мультивибратор - генератор прямоугольных импульсов релаксационного типа с резистивно - емкостными положитель-ными обратными связями, использующий замкнутый в кольцо положительной обратной связи двухкакасдный усилитель.

Мультивибратор может работать в одном из трех режимов: автоколебательном, характеризующимся отсутствием устойчивых состояний; существуют два чередующихся во времени состояния квазиравновесия;

ждущем, при котором существует одно устойчивое состояние и одно состояние квазиравновесия. Переход от устойчивого состояния в состояние квазиравновесия происходит под воздействием внешних запускающих импульсов, а момент возвращения в устойчивое состояние определяется параметрами времязадающей цепи (временем релаксации). Таким образом, на один импульс внешнего воздействия ждущий мультивибратор вырабатывает один импульс заданной длительности;

синхронизации. В этом режиме на мультивибратор воздействует внешнее синхронизирующее напряжение. При этом режиме существуют два чередующихся состояния квазиравновесия, но период колебаний равен или кратен периоду синхронизирующего воздействия.

Мультивибраторы применяются в качестве задающих генераторов, расширителей импульсов, делителей частоты.

Мультиплексор

Мультиплексор - цифровое устройство функционального назначения, предназначенное для распределения информации, представленной двоичными кодами от нескольких источников на общую линию передачи.

Задача мультиплексирования данных возникает довольно часто при проектировании устройств цифровой обработки данных.

Приведем пример обозначения и уравнение функционирования мультиплексора 4:1.

, (4)

где Di - информационные входы,

А1, А0 - старший и младший адресные входы,

F - выход мультплексора.

Таким образом, под воздействием сигналов адресных входов происходит подключение информационного входа, двоичный код которого выдан по адресной шине к выходу мультиплексора. Иными словами, происходит временное разделение сигналов от источников информации.

Обратившись к выражению (4), можно заметить, что оно представляет собой булево выражение в ДНФ. Отсюда следует вывод о том, что мультиплексор может быть применен как универсальное комбинационное устройство, реализующее булевы функциии многих переменных.

В качестве примера синтезируем на основе мультиплексора 4:1 сумматор по модулю два.

.

Если теперь на информационные входы подать уровни в соответствии с таблицей истинности, а на адресные входы - входные переменные Х1 и Х2, то на выходе мультиплесора будет генерироваться требуемая функция.

Обращение кода

Обращение кода - операция, связанная с заменой значений всех разрядов прямого кода на их инверсии.

Ограничение

Ограничение - нелинейная операция, связанная с ограничением амплитуды сигнала, подаваемого на ограничитель.

Различают одностороннее и двухстороннее ограничение. В качестве активных элементов ограничителей могут быть использованы диоды (диодные ограничители), транзисторы и другие элементы, имеющие нелинейную вольт-амперную характеристику.

Оперативное запоминающее устройство (ОЗУ)

Оперативное запоминающее устройство (ОЗУ) - часть внутренней памяти ЭВМ, предназначенное для хранения переменных данных и программ в процессе выполнения вычислений.

ОЗУ (RAM) представляет собой матрицу активных элементов памяти, объединенную со схемами управления, обеспечивающими режимы записи, хранения и считывания информации, представленной двоичными кодами. В обычных ОЗУ информация разрушается после отключения питания, однако существуют энергонезависимые ОЗУ (ЭН ОЗУ), в которых информация сохраняется при его отключени.

По способу хранения информации ОЗУ делят на статические и динамические.

В статических ОЗУ носителем информации служит массив элементов памяти (ЭП) с двумя устойчивыми состояниями (статических триггеров). Среди статических БИС ОЗУ различают синхронные, у которых хотя бы один входной управля.щий сигнал должен быть импульсным, и асинхронные, у которых управляющие сигналы могут быть потенциальными.

Динамические ОЗУ строятся на одностабильных элементах памяти, время хранения в которых ограничено, вследствие этого возникает необходимость в ее периодическом восстановлении - регенерации. В процессе регенерации происходит перезапись каждого хранимого в ОЗУ бита информации или в тот же самый ЭП, или в соседний; в последнем случае коды информации циклически сдвигаются вдоль массива ЭП на один разряд с каждым циклом регенерации. К последним относятся ЗУ на приборах с зарядовой связью (ПЗС). Обычно динамический ЭП содержит запоминающий МДП - конденсатор и обеспечивающий доступ к нему ключевой элемент.

По структурной организации БИС ОЗУ статического типа могут быть:

с линейной (словарной) выборкой ЭП или системы 2D;

с двухкоординатной выборкой ЭП или системы 3D;

с комбинированной выборкой ЭП или модифицированной системы 2D (2DM).

Подробно схемотехнические решения БИС ОЗУ и способы построения ОЗУ читатель может найти в [ 4 ].

Основные логические операции и логические схемы (см. рубрики “Инверсия”, “Конъюнкция”, “Дизъюнкция”).

Память ЦВМ

Под памятью цифровых вычислительных машин понимают совокупность технических средств, предназначенных для приема (записи), хранения и выдачи (считывания) информации, представленной двоичными кодами.

Системы памяти, состоящие из различных по техническим характеристикам модулей, с точки зрения пользователя должна функционировать как единый блок памяти с предельно высоким быстродействием и большой информационной емкостью. Для построения запоминающих устройств ЭВМ используют большой арсенал технических средств. Для детального ознакомления с системами памяти необходимо обратиться к весьма полезному изданию [ 4 ].

Приведем основные номенклатурные виды БИС ЗУ, применяемых при построении внутренней памяти ЭВМ, и их условные обозначения (табл. П1).

Таблица П1.

Услов-ное обозначение вида из-делия | Наименование вида изделия |  |  | Краткое описание вида изделия
 | Полное | Сокращенное |  |
 |  | Отече-ствен-ное | Междуна-родное |
РМ | Матрица оперативного запоминающе-го устройства | _ | _ | Массив активных элементов памяти, объединенных в прямоугольную матрич-ную схему, обеспечиваю-щую прямой электрический доступ к любому элементу памяти
РУ | Оперативное запоминающее устройство | ОЗУ | RAM | Матрица активных элемен-тов памяти, объединенная со схемами управления, обеспечивающими режимы записи, хранения и считы-вания информации
РВ | Матрица постоянного запоминающе-го устройства | _ | _ | Массив, как правило, пас-сивных элементов памяти в виде прямоугольной матри-цы, предназначенной для воспроизведения неизмен-ной информации, заноси-мой в матрицу при изготовлении; хранение информации энергонезави-симо
РЕ | Постоянное запоминающее устройство масочное | МПЗУ | ROM | Матрица пассивных эле-ментов памяти со схемами управления, предназначен-ная для воспроизведения неизменной информации, заносимой в матрицу при изготовлении; хранение информации энергонезави-симо
РТ | ПЗУ с возмож-ностью одно-кратного электрического программиро-вания | ППЗУ | PROM | Отличается от ПЗУ тем, что позволяет в процессе применения схемы одно-кратно изменить состояние запоминающей матрицы электрическим путем по заданной программе
РР | Постоянное запоминающее устройство с возможностью многократного электрического перепрограммирования | РПЗУ ЭС | EEPROM | ПЗУ, предназначенное для долговременного хранения при включенном и выклю-ченном напряжении пита-ния и воспроизведения записанной в процессе эксплуатации информации; допускает многократные электрические циклы стира-ние - запись информации, но число циклов ограни-чено (25 - 104); от ОЗУ отличается значитель-но меньшей скоростью записи
РФ | Постоянное запоминающее устройство с ультрафиолетовым стиранием информации | РПЗУ УФ | EPROM | От РПЗУ ЭС отличается только способом стирания информации - с помощью УФ освещения, для чего в крышке корпуса имеется окно со специальным стеклом
РА | Ассоциативное запоминающее устройство | АЗУ | CAM | “Безадресное” ЗУ; поиск и выборка информации осуществляется по содержа-нию произвольного числа разрядов, хранящихся в АЗУ слов, независимо от физических координат ячеек памяти
ИР | Регистровое запоминающее устройство | РЗУ | _ | ЗУ с произвольным или с последовательным доступом в виде сдвиговых регистров; ЗУ типа “очередь”, когда информа-ция считывается в том же порядке, в котором была записана (первый вошел - первый вышел), и типа “стек” или “магазин” (первый вошел - последний вышел)
РУ | Энергонезави-симое запоминающее устройство | ЭН ОЗУ | NV RAM | ЗУ, работающее в режиме ОЗУ с возможностью длительного, как в РПЗУ ЭС, хранения информации при отключении напряже-ния питания
РП | Прочие запоминающие устройства | _ | _ | _

Память стековая (см. рубрику “Регистровое запоминающее устройство”).

Память типа “очередь” (см. рубрику “Регистровое запоминающее устройство”).

Параметры импульсов и импульсной последовательности

Под параметрами импульсов и импульсной последовательности понимают их амплитудные и временные характеристики ( см. рубрики “Амплитуда импульса” и “Длительность импульса”). Если говорить о периодической импульсной последовательности, то она характеризуется частотой повторения Fп, периодом повторения Тп и скважностью импульсов, определяемой отношением периода повторения к длительности импульса:

Q=Tп/tи.

Параметры цифровых интегральных микросхем

Современная технология позволяет выпускать интегральные микросхемы, содержащие десятки и сотни тысяч логических элементов.

1. Сложность цифровой микросхемы оценивается степенью функциональной интеграции

,

где N - число элементов И-НЕ либо ИЛИ-НЕ на кристалле микросхемы.

У современных микросхем параметр К= 1- 4 и выше. При этом ИМС, содержащие один или несколько ЛЭ [image] , называют ИМС малой степени интеграции; ИМС, содержащие один или несколько функциональных узлов ( сумматоров, регистров, счетчиков и т.д. ) и имеющие обычно К=1 - 2, называют ИМС средней степени интеграции (СИС); ИМС, содержащие одно или несколько функциональных устройств (АУ или АЛУ, УУ, ЗУ) и имеющие К=2 - 4, называют ИМС большой степени интеграции (БИС). В последние годы появились микросхемы, имеющие K>4 и выполняющие функции целых цифровых систем (например, микроЭВМ) и получившие название сверхбольшие ИМС (СБИС).

2. Микросхемы, используемые в устройствах со статическим хранением информации, называются статическими, а используемые в устройствах с динамическим хранением - динамическими.

3. По способу представления двоичной информации ЦИМС делятся па потенциальные и импульсные, работающие либо в позитивной, либо в негативной логике (см. рубрики “Логика позитивная”, “Логика негативная”).

Большинство типов современных ЦИМС относятся к классу потенциальных. Для характеристики потенциальных ЦИМС используется следующая система параметров:

потенциалы, соответствующие 0 и 1 - U0 и U1;

порог переключения Vп;

число входов (коэффициент объединения по входу) М;

входные токи Ioвх при Uвх=U0 и I1вх при Uвх=U1;

коэффициент разветвления по выходу (нагрузочная способность) N;

помехоустойчивость по отношению к помехам положительной полярности U+п и отрицательной полярности U-п;

мощность Р и ток Iп, потребляемые от источника питания;

времена задержек переключения t0,1з из состояния 0 на выходе в состояние 1 и t1,0з из состояния 1 в 0.

4. Параметры ЦИМС определяются по их статическим и переходным характеристикам.

Основной статической характеристикой схем является передаточная характеристика Uвых=f(Uвх) - зависимость потенциала на выходе от потенциала на одном из входов при постоянных значениях потенциалов на остальных входах.

По типу передаточной характеристики ЦИМС делятся на инвертирующие и неинвертирующие.

Входная характеристика логических схем Iвх=f(Uвх) служит для определения значений входных токов: I0вх>0, вытекающего из схемы при Uвх=U0, Iвх<0, втекающего в схему при Uвх=U1.

Выходные характеристики логических схем U0вых=f(Iн0) и

U1вых=f (I1н). Втекающий I0н или вытекающий I1н выходные токи зависят от числа нагрузок n:

I0н=nI0вх, I1н=nI1вх .

5. Мощность Р и ток Iп, потребляемые ЦИМС от источника питания, зависят от ее логического состояния. Схема потребляет ток I0п при Uвых= U0 и ток I1п при Uвых=U1. Средняя мощность, потребляемая в статическом режиме, определяется выражением

P=0,5E(I0п+I1п).

Для уменьшения потребляемой мощности можно снижать напряжение питания Е, но при этом уменьшается и U1.

6. Среднее время задержки - один из важнейших параметров ЦИМС, определяющих быстродействие узлов обработки информации:

tз= (t0,1з+t1,0з).

Практически все параметры ЦИМС зависят от температуры, поэтому в ЧТУ на типы ИМС указывается диапазон температур, в пределах которого параметры имеют указанные значения.

К классу импульсных микросхем относятся некоторые типы ЦИМС на МДП-транзисторах.

Переключательные схемы (см. рубрику “Булева алгебра”)

Переходные процессы в транзисторном ключе

Переходные процессы в транзисторном ключе (ТК) связаны с наличием реактивных элементов в схеме и инерционностью транзистора.

При рассмотрении картины протекания переходных процессов разделяют следующие стадии [ 5 ]:

стадия задержки включения;

стадия включения;

стадия накопления избыточного заряда;

стадия рассасывания избыточного заряда;

стадия выключения.

Для интегральных ТК, работающих, как правило, в режиме глубокого насыщения, наибольший интервал времени занимает этап рассасывания избыточного заряда неосновных носителей, накопленных в базе. С целью уменьшения длительности этого этапа, а следовательно, для повышения быстродействия элементной базы применяют режим работы транзистора на границе режима насыщения или с небольшими коэффициентами насыщения. Для этого применяют ненасыщенный режим работы и ключи с форсирующей емкостью, нелинейной отрицательной обратной связью диоды и транзисторы с барьером Шоттки [ 5 ].

Полусумматор

Полусумматор - цифровое устройство функционального назначения, предназначенное для сложение двух одноразрядных двоичных чисел.

При сложении двух одноразрядных двоичных чисел кроме сигнала суммы может образовываться сигнал переноса, то полусумматор представляет собой устройство с двумя входами Х1 и Х2 и выходами: S - сигнала суммы и Р - сигнала переноса в старший разряд.

Таблица истинности и условное графическое обозначение полусумматора приведены ниже.

Функциональное уравнение полусумматора, полученное непосредственно из таблицы истинности, имеет вид:

От полученного уравнения можно перейти к схеме, реализующей устройство.

Последовательностные схемы

Последовательностные схемы - схемы, состояние выходов которых зависит не только от сотояния их входв в настоящий момент времени, но и определяется ее предществующим состоянием.

Отличительной особенностью последовательностных схем является наличие элементов памяти (триггеров) в ее составе.

Постоянное запоминающее устройство (ПЗУ)

Основным признаком классификации БИС ПЗУ является способ записи информации.

По этому призаку БИС ПЗУ делятся на три группы:

Обычные ПЗУ, в которых запись информации производится на заводе-изготовителе. Такие ПЗУ называются масочными (МПЗУ), поскольку для записи информации одна из масок для изготовления БИС делается нестандартной (такие МПЗУ называют еще заказными).

Программируемые ПЗУ (ППЗУ), в которых запись информации выполняется пользователем электрическим способом с помощью стенда-программатора. Изменение информации в таких БИС невозможно.

Репрограммируемые ПЗУ (РПЗУ), в которых запись информации производится электрическим способом и возможно ее изменение . В РПЗУ, как и в обычных ПЗУ, информация сохраняется при отключении напряжения питания, поэтому такие ЗУ называют энергонезависимыми.

Другими признаками классификации являются: тип элемента памяти (ЭП), вид элемента программирования, способ стирания информации ( для РПЗУ). Все эти данные сведены в табл. П2.

Таблица П2

Тип БИС ПЗУ | Тип ЭП | Элемент программирова-ния | Способ программирова-ния | Способ стирания
МПЗУ | Диод, биполярный транзистор, МДП- транзистор | Металлическое соединение, контактное окно | Фотошаблон | --
ППЗУ | Диоды, биполярные транзисторы | Плавкая пере-мычка p-n пе-реход, диод Шоттки | Электрическое пережигание Электрический пробой |
РПЗУ | МДП-транзистор с плавающим затвором _____________ МДП-транзистор с плавающим затвором и управляющим затвором _____________ МНОП- тран-зистор | МДП-транзистор _______________ МНОП- транзис-тор | Электрический | УФ-облу-чение ________ Электри-ческий

В дополнение можно остановиться на дополнительных функциях, которые могут быть реализованы с помощью ПЗУ:

ПЗУ в качестве преобразователей кодов;

ПЗУ для выполнения арифметических операций;

ПЗУ в генераторах символов;

ПЗУ в микропрограммных устройствах управления.

Потенциальные системы

Потенциальные системы - системы, основанные на применении элементов и устройств с потенциальным представлением информации.

Большинство систем обработки информации в настоящее время относятся к этому классу.

Приборы с зарядовой связью (ПЗС)

Развитие идей, положенных в основу построения динамических регистров сдвига и динамических ЗУ, привело к разработке нового типа интегральных полупроводниковых приборов с МДП-структурой, получивших название приборов с зарядовой связью (ПЗС). Известны две разновидности ПЗС: цепь МДП-транзистров и приборы с переносом поверхностного заряда на границе раздела полупроводник - диэлектрик

[ 4, 5 ].

Программируемая логическая матрица (ПЛМ)

Программируемая логическая матрица (ПЛМ или PLM), как и ПЗУ, представляет собой комбинационную схему.

ПЛМ (рис. П1) содержит m пар входных инверторов, k элементов И, каждый из которых имеет 2m входов. Эти элементы образуют матрицу А1, реализующую операцию И (И-НЕ). N элементов ИЛИ, каждый из которых имеет по k входов, образуют матрицу А2 и релизуют операцию ИЛИ. N сумматоров по модулю два (M2) и n элементов И с тремя состояниями расширяют функциональные возможности ПЛМ, поскольку М2 может выполнять , в зависимости от способа включения второго входа, либо функции инвертора, либо функции повторителя. Прерывистыми линиями обозначены разрушаемые перемычки, которые составляют три поля коммутации: на входах элементов И, на входах элементов ИЛИ и на входах сумматоров по модулю два. Программирование логической матрицы связано с устранением ненужных связей.

Рис. П1

Поскольку в ПЛМ может быть реализована булева функция многих переменных любой степени сложности, заданная либо в КНФ, либо в ДНФ, то области применения их весьма широки. По этой причине применение ПЛМ оправдано там, где устройства обработки информации работают по “жесткой” логике, не изменяемой в процессе эксплуатации, а ПЛМ являются хорошей альтернативой микропроцессорным комплектам (МПК), выигрывая у них по скорости обработки информации, поскольку обработка информации в МПК происходит по алгоритму машины Тьюринга, т.е. пошагово.

Условное графическое обозначение ПЛМ приведено ниже.

ПЛМ имеет m входов и n выходов по числу входных схем И и числу выходных схем И с тремя состояниями. Управление третьим состоянием производится входным управляющим сигналом CS “Выбор кристалла” (ВК). Для пояснения принципа построения ПЛМ, а также отличий между ПЗУ и ПЛМ рассмотрим задачу выработки некоторых управляющих (выходных) сигналов y1, y2,.......yn в зависимости от входных сигналов x1, x2,.......xm. Для простоты предположим, что входной код трезразрядный (m=3), а выходной код - двухразрядный (n=2).

Преобразователь кодов

Преобразователь кодов (ПК) - цифровое устройство функционального назначения, предназначенное для преобразования арифметических кодов.

Условное графическое обозначение преобразователей кодов показано ниже.

В цифровой технике ПК применяются для преобразования кодов прямого замещения (БК) в двоично-десятичный, код для управления устройствами индикации и др. В составе серий ИМС ПК выпускаются в качестве самостоятельных устройств, а также могут быть синтезированы и реализованы на различных устройствах другого функционального назначения (например, на ПЗУ).

Преобразователи уровня (ПУ)

ПУ - устройства, служащее для согласования уровней потенциалов логических уровней в случае, если в устройстве обработки информации по каким-либо причинам используются серии ТТЛ, КМОП, ЭСЛ, имеющие различающиеся по номиналам уровни U0 и U1. В составе серий ЭСЛ, КМОП имеются специальные микросхемы ПУ для согласования с уровнями ТТЛ.

Преобразователь цифроаналоговый (ЦАП) ( см. рубрику “Цифро-аналоговый преобразователь”)

Распределитель импульсов

Распределители импульсов - цифровые устройства с многими выходами, сигналы на которых появляются в определенной последовательности.

В качестве распределителей импульсов могут применяться сдвигающие регистры, замкнутые в кольцо. В кольце под воздействием синхроимпульса продвигается одна единица, предварительно записанная в первую ячейку. Под воздействием синхроимпульса СИ происходит сдвиг информации на один разряд вправо. Таким образом, на каждом из выходов импульс появляется в момент времени, когда в соответствующую триггерную ячейку будет подан сигнал уровня логической единицы U1.

Кроме функций распределителя импульсов это устройство может быть использовано как многоканальный делитель частоты, поскольку частота повторения импульсов на каждом из выходов Qi в четыре раза меньше, чем частота синхроимпульсов.

Расширитель логический

Логический расширитель - вспомогательное устройство, позволяю-щее, например, расширить число входов по какой - либо логической опе-рации (И, ИЛИ). В составе серий ИМС есть специальные схемы логи-ческих расширителей [ 8, 9 ].

Регистр памяти

Регистр памяти (накопительный регистр) - цифровое устройство функционального назначения, предназначенное для записи, хранения, преобразования и считывания информации, представленной двоичными кодами.

Регистры памяти предназначены для кратковременного хранения n-разрядного двоичного слова, представляющего собой результат выполнения арифметической или логической информации. Для хранения одного бита информации в накопительных регистрах отводится один разряд, выполненный на основе триггерной ячейки. В накопительных регистрах обмена информацией между отдельными триггерами не происходит. В сериях цифровых интегральных микросхем имеется большая номеклатура накопительных регистров различной разрядности, быстродействия и функциональной сложности.

Условное графическое изображение четырехразрядного регистра памяти приведено ниже.

На схеме: Di - информационные входы, Qi - выходы регистра.

Кроме показанных на рисунке входов возможно наличие дополнительных управляющих входов: выбор кристалла, переход в третье состояние и т.п.

Регистровое запоминающее устройство (РЗУ)

Регистровое запоминающее устройство (РЗУ) представляет собой ЗУ: адресные и безадресные. Безадресные РЗУ, применяемые в качестве буферных ЗУ, в свою очередь, можно разделить на ЗУ типа “очередь” (FIFO), когда информация считывается в том же порядке, в котором была записана (первый вошел - первый вышел); типа “стек” или “магазин” (FILO) (первый вошел - последний вышел) и ассоциативные.

В ассоциативных РЗУ поиск информации осуществляется по значению признака поиска, характеризующего информацию, т.е. по ее содержанию.

Большинство РЗУ являются адресными. Доступ к любому регистру определяется адресом, установленном на адресном входе РЗУ.

Регистр сдвигающий

Сдвигающий регистр - цифровое устройство функционального назначения, предназначенное для записи, хранения, преобразования и считывания двоичной информации.

Сдвигающие регистры подразделяются на однонаправленные и двунаправленные (реверсивные). В однонаправленном регистре под воздействием синхроимпульсов производится сдвиг информации на один разряд вправо (в сторону увеличения порядкового номера триггерной ячейки) или влево (в сторону уменьшения порядкового номера триггерной ячейки, предназначенной для хранения одного бита информации.

В реверсивных регистрах направление сдвига изменяется под воздействием управляющих сигналов.

Расширение функциональных возможностей достигается еще и применением выходных буферных элементов на три состояния ( режим Z)

Существуют и специализированные регистры, например, для построения АЦП используются регистры последовательных приближений. С целью уменьшения числа проводов шины данных (ШД) используются многорежимные буферные регистры (МБР). Их входные и выходные линии объединены и образуют так называемый порт данных. Это означает, что от ШД приходит один, а не два провода, который в зависимости от поданной команды служит или входным или выходным.

Номенклатура регистров в составе серий ИМС наиболее представительна. В этом можно убедиться, обратившись к [ 8, 9 ].

Области применения сдвигающих регистров:

узлы арифметических и логических устройств;

преобразователи параллельного кода в последовательный и наоборот;

кольцевые счетчики и делители частоты;

распределители импульсов;

генераторы псевдослучайной последовательности;

дискретные линии задержки;

генераторы дискретных фазовых сдвигов и т.п.

Условное графическое обозначение универсального реверсивного сдвигающего регистра приведено ниже.

В основном поле условного обозначения помещено название функционального устройства RG, направление сдвига указано стрелкой над обозначением. В левом дополнительном поле размещены обозначения входных и управляющих сигналов:

Di - информационные входы;

S0, S1 - входы управления режимом;

DL, DR - входы последовательного ввода со сдвигом влево (L) и вправо (R);

- вход синхроимпульса;

- вход установки нуля, имеющий наивысший приоритет.

В правом дополнительном поле условного обозначения помещены обозначения выходов Qi.

Приведенный в качестве примера регистр может реализовать следующие режимы работы в зависимости от комбинации управляющих сигналов на входах S0, S1:

  • параллельная загрузка данных по входам Qi;

    последовательный ввод данных со сдвигом влево по входу DL;

    последовательный ввод данных со сдвигом вправо по входу DR;

    •

    хранение.

    Более подробную информацию можно получить в [ 7 ].

    Резистивно-транзисторная логика

    Базовый элемент резистивно-транзисторной логики (РТЛ) реализует логическую функцию ИЛИ-НЕ, а следовательно, может явиться основой построения серий ИМС. Операция логического сложения (дизъюнкция) реализуется на резистивной сборке, а операция логического отрицания реализуется инвертором на транзисторном ключе с общим эмиттером.

    Схемотехническое решение базовых элементов РТЛ очень простое, но для нас знакомство с этим вопросом представляет чисто познавательный интерес, поскольку серийно РТЛ схемы не производятся ввиду их невысокого быстродействия, большой потребляемой мощностью в резистивной части схемы и небольшой степени интеграции.

    Релаксатор ( см. рубрику “Мультивибратор”)

    Репрограммируемое ЗУ (РПЗУ)

    РПЗУ представляют собой ПЗУ, допускающие в процессе экспплуатации производить многократные циклы перезаписи информации, записанной в матрицу элементов памяти. РПЗУ под-разделяются на:

    РПЗУ с электрическим стиранием информации (РПЗУ ЭС),

    РПЗУ со стиранием информации УФ облучением (РПЗУ УФ).

    РПЗУ ЭС предназначено для долговременного хранения при включенном и выключенном напряжении питания и воспроизведения записанной в процессе эксплуатации информации; допускает многократные электрические циклы стирание - запись информации, но число циклов ограничено (25 - 104); от ОЗУ отличается значительно меньшей скоростью записи по сравнению со скоростью считывания информации

    РПЗУ УФ от РПЗУ ЭС отличается только способом стирания информации - с помощью УФ излучения, для чего в крышке корпуса имеется окно с кварцевым стеклом.