В

  1. Разностные уравнения

В общем виде линейное разностное уравнение М -го порядка имеет вид

(1.1)

где [image] [image] коэффициенты, описывающие конкретную систему, причем [image].

Решение разностного уравнения можно произвести методом прямой подстановки, имея набор начальных условий и входную последовательность. Например, разностное уравнение

, [image] (1.2)

с начальным условием y(-1) = 0 и входной последовательностью

, (1.3)

по методу прямой подстановки имеет решение

и т.д.

Для получения решения в явном виде можно использовать аналитический метод, основанный на получении двух решений разностного уравнения: однородного и частного. Однородное решение получается путем подстановки нулей вместо всех членов, содержащих элементы входной последовательности и определения при этом отклика системы. Частное решение получают, подбирая вид выходной последовательности при заданной входной. Для определения произвольных постоянных однородного решения используются начальные условия. В качестве примера решим этим методом уравнение (1.2). Однородное уравнение имеет вид

(1.4)

Известно, что решение уравнения (1.4) с постоянными коэффициентами может быть записано следующим образом

, (1.5)

где A - коэффициент и [image] - переменная, подлежащая вычислению.

Подставляя (1.5) в (1.4), получаем

, (1.6)

или

откуда при [image] имеем

, [image],

Частное решение, соответствующее входной последовательности (1.3) попробуем найти в виде трехчлена

, (1.7)

Подставляя (1.7) в (1.2) с учетом (1.3) имеем

, (1.8)

Из выражений для коэффициентов при равных степенях n имеем значения

Таким образом полное решение разностного уравнения (1.2) приобретает вид

, (1.9)

Коэффициент А определяется из начального условия [image] тогда А = 9/32 и получаем

, (1.10)

Выборочная проверка (1.10) при [image] показывает полное её совпадение с приведенным выше прямым решением.

Задание 1. Вычислить решения следующих разностных уравнений прямым и аналитическим методом и сопоставить эти решения

при y(-1)=0

при Q – порядковом номере студента в списке группы.

Решение разностного уравнения может быть осуществлено с помощью Z – преобразования. Для последовательности x(n), заданной при всех n, оно определяется следующим образом

, (1.11)

где z – комплексная переменная.

Для действительной экспоненциальной последовательности x(n)=0 при n<0, [image] имеем

, (1.12)

X(z) сходиться при [image] и имеем только одну особую точку z = a. В случае комплексной экспоненциальной последовательности [image] при n<0, [image], [image] получаем

(1.13)

причем X(z) сходится при [image] с особой точкой [image].

Обратный переход от Z – преобразования к последовательности называется обратным преобразованием и формально определяется соотношением

(1.14)

В правой части этого равенства стоит контурный интеграл в Z – плоскости по любому замкнутому контуру в области сходимости, охватывающему начало координат. Например, контуром интегрирования может быть окружность радиуса [image] , где [image] радиус сходимости Z – преобразования в предположении, что последовательность физически реализуема. Обратное Z – преобразование можно вычислить либо прямым вычислением интеграла (1.14) с использованием теоремы о вычетах, либо разложением X(z) на простые дроби

(1.15)

Поскольку каждое слагаемое [image] имеет обратное преобразование вида [image] то получаем

Если последовательность x(n) имеет Z – преобразование X(z), то Z – преобразование последовательности с задержкой [image], составит [image] . Например разностное уравнение

(1.16)

можно представить Z – преобразованием

(1.17)

Если x(n), y(n) являются входной и выходной последовательностями дискретной линейной системы с импульсной функцией h(n), то

(1.18)

где X(z), Y(z), H(z) являются соответственно Z – преобразованиями последовательностей x(n), y(n), h(n). При этом

(1.19)

и для системы (1.16) имеем

(1.20)

При решении большинства практических задач можно принять x(n) = 0 при x<0 и поэтому вводиться ''одностороннее'' Z – преобразование

(1.21)

Рассмотрим разностное уравнение первого порядка

(1.22)

с начальным условием y(-1)=k при воздействии [image]. Чтобы найти одностороннее Z – преобразование y(n) умножим обе части равенства (1.22) на [image] и вычислим суммы

, (1.23)

с учетом свойства задержки имеем

, (1.24)

откуда

(1.25)

Для (1.13) и y(-1)=k получаем

(1.26)

Разложив второе слагаемое (1.26) имеем

(1.27)

и соответственно получаем обратное преобразование

(1.28).

Задание 2. Вычислить решение разностного уравнения

при y(-1)=k для

2. Нерекурсивные цифровые фильтры

В нерекурсивных цифровых фильтрах текущее значение отклика y(n) зависит только от текущего значения и конечного числа предшествующих значений входной последовательности x(n). При этом длина импульсной характеристики фильтра (отклика на единичный отсчет) является конечной и определяется количеством звеньев задержки.

Наибольшее распространение имеет прямая структурная форма фильтра, представленная на рис.1 с [image] звеньями задержки, масштабными множителями h и сумматаром

Рис.1

этой форме соответствует разностное уравнение

(2.1)

Характеристикой фильтра является передаточная функция

(2.2)

При построении таких фильтров удобна последовательная форма. В этом случае Z – преобразование импульсной характеристики представляется в виде произведения Z – преобразования, соответствующего системе первого порядка

(2.3)

или второго порядка

(2.4)

Тогда передаточная функция имеет вид

(2.5)

причем [image] равна целой части (N-1)/2

Пусть {h(n)} – физически реализуемая последовательность конечной длины, заданной на интервале [image] с Z – преобразованием (2.2).

Преобразование Фурье от {h(n)} составит

(2.6)

и оно является периодическим по частоте с периодом [image] , т.е. при [image] имеем

(2.7)

В случае только действительной последовательности

(2.8)

Знаки [image] необходимы так как

, (2.9)

где [image] - действительная функция, принимающая положительные и отрицательные значения.

При этом

, (2.10)

и [image] симметрично, а [image] антисимметрично.

Требование линейности фазовой характеристики

, (2.11)

где [image] постоянный коэффициент.

Значение [image] определяется из уравнения

, (2.12)

удовлетворяющее следующим условиям

(2.13)

Таким образом при заданном [image] импульсная характеристика должна обладать вполне определенной симметрией. Если N – нечетная, то [image] целое число и задержка в фильтре равна целому числу интервалов дискретизаций. Например для N = 11, [image] и центр симметрии для h(n) приходится на пятый отсчет. Для четного N, например, N = 10, [image] , а центр симметрии лежит между отсчетами.

Для нерекурсивного симметричного цифрового фильтра

(2.14)

при [image] имеем

(2.15)

Выбор коэффициентов a, b, c зависит от того какие частоты необходимо подавить, а какие пропустить. В случае низкочастотного фильтра необходимо пропускать низкие частоты, а подавлять высокие. Чтобы преобразовать низкочастотный фильтр в высокочастотный, необходимо просто вычислить [image] . Для низкочастотного фильтра потребуем, чтобы [image] (отсутствие искажений на постоянном токе), а на высокочастотном крае [image] (высшие частоты не проходят) эти два условия эквивалентны паре уравнений

решив которые получим b=1/4, c=(1/2)-2a и задача сводится к однопараметрическому семейству фильтров с передаточной функцией

(2.16)

В первом случае потребуем [image] тогда [image] a = 1/8, c = 3/4.

Низкочастотный фильтр будет иметь

y(n)=(-x(n-2)+2x(n-1)+6x(n)+2x(n+1)-x(n-2))/8,

Во втором случае примем [image] и поступая аналогично получим a = 0, c = 1/2, b = 1. Тогда

В третьем случае потребуем улучшения характеристики фильтра в области нулевой частоты: .

В результате при [image] имеем

Задание 3. Вычислить и построить частотные характеристики рассмотренных выше простейших нерекурсивных фильтров при следующих условиях:

Рассмотрим симметричный нерекурсивный фильтр

(2.17)

Переход от низкочастотного фильтра к высокочастотному может быть осуществлен путем замены f на 0,5 – f , т.е. заменой на обратный порядок следования значений в интервале [image] В результате имеем

Для расчета фильтров можно взять передаточную симметричную функцию заданной формы и найти коэффициенты соответствующего косинусного ряда, в общем случае, бесконечного. На практике отбрасываются коэффициенты с индексами после некоторого значения N и возникает необходимость в дополнительном сглаживании.

Рассчитаем симметричный относительно f = 0 фильтр низких частот для передаточной функции [image] вида

В результате прямого вычисления интегралов в выражениях коэффициентов ряда Фурье получаем, что [image] , а

(2.18)

Таким образом коэффициенты идеальной передаточной функции низкочастотного фильтра имеют вид

(2.19)

и соответствующий ряд Фурье

(2.20)

При N = 5 в сумме N – 1 = 4, получим

(2.21)

Для сглаживания умножим коэффициенты ряда Фурье на множитель [image] причем [image] Модифицированная передаточная функция приобретает вид

(2.22)

Задание 4. Вычислить и построить частотную характеристику рассмотренного выше фильтра при N = 5, удовлетворяющую условиям

3. Рекурсивные фильтры

В рекурсивном цифровом фильтре значение процесса на выходе определяется не только конечным числом значений входного процесса, но также и предшествующими величинами выходного процесса. На рис.2 представлена структурная схема рекурсивного цифрового фильтра с z-1 звеньями задержки, масштабными множителями h и сумматорами.

Рис.2

В этом случае

(3.1)

фильтр использует М значений выходного процесса и только одного входного. В рекурсивном цифровом фильтре более общего вида число значений выходного процесса не меняется, а число значений входного процесса с звеньями задержки, масштабными множителями и сумматарами возрастает.

Преобразование Фурье равенства (3.1) дает

(3.2)

причем сумма содержит многочлен по степеням комплексной экспоненты [image] . Обозначая последнее выражение символом z переходим к Z – преобразованию. Как следует из формулы (3.2), частотная характеристика рассматриваемого цифрового рекурсивного фильтра имеет вид

(3.3)

Таким образом, изучение свойств частотной характеристики [image] сводится к определению положения и характера полюсов в знаменателе выражения (3.3).

Простейший рекурсивный фильтр низких частот (ФНЧ) может быть задан следующим разностным уравнением

(3.4)

а высоких частот

(3.5)

Для расчета удобно использовать частотную характеристику, которая для рассматриваемого рекурсивного ФНЧ имеет вид

(3.6)

с модулем

(3.7)

и фазой

(3.8)

где [image] интервал между отсчетами.

Импульсная функция этого фильтра составит

(3.9)

По определению h(n) [image] 0 при n<0, а для устойчивого фильтра

Рекурсивный фильтр высоких частот второго порядка

(3.10)

имеет частотную характеристику

(3.11)

Переходя к обозначениям [image] знаменатель (3.11) представим в следующем виде [image] корни [image] которого соответствуют полюсам фильтра

(3.12)

При [image] корни действительные и [image] [image] и уравнение (3.10) можно записать следующим образом

(3.13)

и частотную характеристику

(3.14)

в виде произведения [image] фильтров первого порядка. При этом [image] и [image] иначе теряется устойчивость фильтра.

Для [image] корни комплексные

(3.15)

при [image] [image].

Для заданных [image] параметры [image] вычисляются по формулам при

Рекурсивный фильтр низких частот второго порядка с модулем частотной характеристики

(3.16)

где [image] при B – полосе пропускания, называется фильтром Баттерворта. Представим (3.16) в следующем виде

(3.17)

Рассмотрим последовательность расчета фильтра низких частот Баттерворта с частотной характеристикой

(3.18)

где [image] граница полосы пропускания.

Первоначально определим полосы фильтра путем решения уравнения

(3.19)

Из 2М корней этого уравнения М попадают в верхнюю, а другие М – в нижнюю полуплоскость, отвечающие неустойчивым состояниям. Далее определяем решения уравнения [image], m = 1,2,…,M и вычисляются коэффициенты.

где m = 1,2,…,(M – 1) для нечетного М. При F = 100Гц, [image] [image] положим М = 6. Тогда [image].

Для последовательности углов [image], [image],

имеем

Далее

m = 1,2,3.

Результаты вычислений сведены в таблицу

15 | 45 | 75
0,183 | 0,5 | 0,683
0,0598 | 0,25 | 0,433
1,274 | 1,618 | 1,855
- 0,188 | - 0,764 | - 0,672
0,379 | 0,146 | 0,085

при

частотная характеристика имеет вид

, (3.20)

Получен рекурсивный ФНЧ, составленный из трех рекурсивных фильтров второго порядка, каждый из которых устойчив. Для рекурсивного фильтра высоких частот М–го порядка необходимо реализовать передаточную функцию

(3.21)

обеспечивающий пропускание в полосе от [image] до F Гц. Кроме дополнительного угла в [image] эта передаточная функция совпадает с (3.16).

Задание 5. Рассчитать параметры рекурсивного ФНЧ и построить его частотную характеристику с шагом 0,05 F. Принять F = 100 Гц,

, [image], [image].

Использованная литература

  1. Рабинер Л., Гоулд Б. Теория и применение цифровой обработки сигналов. Пер. с англ. – М.: 1978 – 848c.

  2. Отнес Р., Эноксон Л. Прикладной анализ временных рядов. Пер. с англ. – М.:''Мир'', 1982 – 428с.

  3. Хемминг Р.В. Цифровые фильтры. Пер. с англ. – М.:''Недра'', 1987 – 221с.

  4. Гольденберг Л.М., Матюшкин Б.Д., Поляк М.И. Цифровая обработка сигналов. – М.: Радио и связь, 1990 – 256с.