z-преобразование :: Форум Radioscanner.Ru

На главную страницу сайта
· Музей · Lab / Mods · LPD-форум new! · Погода [AD]
На сайте: гостей - 18,
участников - 1 [ Rulez Reloaded ]
· Начало · События · Статистика · Регистрация · Поиск · Правила · FAQ · Галерея ·

Форум —› Разработка, схемы, модификации —› z-преобразование
Автор Сообщение
griton
Опытный участник
 Дата: 29 Май 2005 11:23:25

Всем привет. Подскажите, пожалуйста, в общих словах что такое z-преобразование в цифровых фильтрах и для чего оно нужно.

Заранее огромное спасибо!
dimss
Опытный участник
 Дата: 29 Май 2005 12:44:08

Принцип работы цифрового фильтра: задерживаем сигнал (входной или выходной) на некоторое количество тактов, затем смешиваем сигналы с разной задержкой в некоторой пропорции со входным сигналом. Если в смешении используется только задержанный входной сигнал, то это фильтр FIR (с конечной импульсной характеристикой). Если задерживается и подмешивается и выходной сигнал, получается фильтр IIR (с бесконечной импульсной характеристикой).

Представить это дело можно так. Пусть x(t) -- сигнал на входе в момент t, y(t) -- сигнал на выходе в момент t.

y(t) = x(t) + a1*x(t-1) + a2*x(t-2) + ... Это фильтр FIR
y(t) = x(t) + a1*x(t-1) + a2*x(t-2) + ... + b1*y(t-1) + b2*y(t-2) -- Фильтр IIR

Можно представить это в виде z-преобразования. z в минус первой степени ознчает задержку на один такт. z в минус второй -- на два такта.

Y(z) = a2*z**-2*X(z) + a1*z**-1*X(z) + X(z) -- Это FIR
Y(z) = a2*z**-2*X(z) + a1*z**-1*X(z) + X(z) + b2*z**-2*Y(z) + b1*z**-1*Y(z) -- это IIR

Теперь можем получить передаточную функцию:

H(z) = Y(z) / X(z).

А из неё -- ФЧХ и АЧХ фильтра.
griton
Опытный участник
 Дата: 29 Май 2005 12:58:49

спасибо огромное! Всё стало предельно ясно!
:: Ваш ответ

» Логин » Пароль
[AD]
 Время загрузки страницы (сек.): 0.028
Поддержка: miniBB / radioscanner © 2004