ОСНОВНЫЕ РАЗДЕЛЫ СОВРЕМЕННОЙ ТЕОРИИ АВТОМАТИЧЕСКОГО УПРАВЛЕНИЯ

Лекция № 1.

Тема:«Векторно-матричные модели систем управления в непрерывном времени»

Понятие пространства состояний

Современная теория автоматического управления оперирует с векторно-матричными моделями динамических систем. При этом рассматриваются в общем случае многомерные системы, т.е. системы произвольного порядка со многими входами и многими выходами, в связи, с чем широко используются векторно-матричные уравнения и аппарат векторной алгебры. Для получения векторно-матричной модели (ВММ) исследуемая динамическая система представляется в виде “черного ящика” с некоторым числом входных и выходных каналов (рис. 1.1, а).

Рис.1.1. Скалярное (а) и векторное (б) представления динамической системы в виде "черного ящика"

Все переменные, характеризующие систему, можно разделить на три группы.

1. Входные переменные или входные воздействия, генерируемые системами, внешними по отношению к исследуемой системе. Они характеризуются вектором входа.

r - число входов

2. Выходные переменные, характеризующие реакцию системы на указанные входные воздействия. Представляются вектором выхода

m - число выходов.

3. Промежуточные переменные, характеризующие внутреннее состояние системы, - переменные состояния, представляются вектором

n - число переменных состояния.

Таким образом, совокупность входов можно рассматривать как один обобщенный вход, на который воздействует вектор входа u, совокупность выходов как вектор y, а совокупность промежуточных координат, характеризующих состояние системы, - в виде вектора состояния x (см. рис. 1.1, б).

Состояние системы - это та минимальная информация о прошлом, которая необходима для полного описания будущего поведения (т.е. выходов) системы, если поведение ее входов известно.

Собственно система, ее входы и выходы - это три взаимосвязанных объекта, которые в каждой конкретной ситуации определяются соответственно математической моделью системы, заданием множеств входных и выходных переменных.

Решение задач анализа и синтеза связано с исследованием состояний системы, множество которых образует пространство состояний, [image].

Векторно-матричные модели в непрерывном времени

В общем случае динамическая система в непрерывном может быть описана парой матричных уравнений:

(1.1)

(1.2)

где F - n-мерная вектор-функция системы; Q - m-мерная вектор-функция выхода.

Матричное уравнение (1.1) называют уравнением состояния системы. Его решение, удовлетворяющее начальному условию [image], дает вектор состояния системы

(1.3)

Матричное уравнение (1.2), определяющее выходные переменные в зависимости от x(t) и u(t), называют уравнением выхода.

В частном случае зависимости [image] могут быть линейными комбинациями переменных состояния xi и входных переменных uq. При этом динамическая система описывается в векторно-матричной форме:

(1.4)

(1.5)

Переход к стационарным моделям позволяет оперировать с коэффициентными матрицами, т.е. со стационарными уравнениями

(1.6)

(1.7)

где:

А - функциональная матрица размером n x n, называемая матрицей состояния системы (объекта);

В - функциональная матрица размером n x r, называемая матрицей управления (входа);

С - функциональная матрица размером m x n, называемая матрицей выхода по состоянию;

D - функциональная матрица размером m x r, называемая матрицей выхода по управлению.

Очень часто D=0, т.е. выход непосредственно не зависит от входа.

В дальнейшем под векторно-матричной моделью объекта (системы) будем понимать описание ее динамического поведения в классе стационарных непрерывных линейных систем, представленное в виде уравнений (1.6), (1.7).

Таким образом, ВММ имеет единую форму представления, что значительно облегчает алгоритмизацию и компьютерную реализацию проектных процедур и проектных операций структурно-параметрического синтеза и анализа систем управления. Однако с использованием ВММ может быть получено лишь приближенное проектное решение, которое потребует дальнейшего уточнения, так как такие модели отображают динамическое поведение реального объекта лишь в классе стационарных линейных систем.

Построение ВММ реального объекта сопряжено с проблемами линеаризации исходного математического описания и приведения его к структурированному виду - форме Коши.

Если мы знаем физическое описание системы и можем записать уравнения, описывающие поведения ее отдельных частей, то получить уравнения состояния системы обычно сравнительно не трудно. Покажем эту процедуру на нескольких примерах.

Пример 1.1. Получим уравнения состояния для простейшей RLC-цепи, показанной на рис 1.2.

Динамическое поведение этой системы при [image] полностью определяется, если известны начальные значения [image] и входное напряжение U(t) при [image]. Следовательно, [image] можно выбрать в качестве переменных состояния, то есть

Для указанных переменных состояния можно записать дифференциальные уравнения

или в векторно-матричной форме

(1.8)

Таким образом для рассматриваемой системы матрицы А, В, С векторно-матричной модели будут иметь следующий вид:

Пример 1.2. На рис. 1.3. показан электродвигатель постоянного тока независимого возбуждения, работающий при постоянном магнитном потоке (Ф=const).

Дифференциальные уравнения для такого объекта могут быть записаны относительно следующих переменных состояния: - скорости вращения ротора, тока якоря i(t), углового перемещения ротора [image]. При использовании знакомых зависимостей для электродвижущей силы [image] и вращающего момента двигателя [image] получим уравнение электрической цепи

и уравнения вращающейся части

где J – приведенный момент инерции электродвигателя.

Представляя векторы состояния, входа и выхода как [image] получим следующую векторно-матричную модель электродвигателя постоянного тока

1.9

То есть для рассматриваемой системы матрицы А, В, С векторно-матричной модели будут иметь следующий вид:

Пример 1.3. Построим векторно-матричную модель электромеханического объекта - электропривода постоянного тока, приводящего в движение через механический редуктор тяжелую платформу. Функциональная схема такого объекта приведена на рис. 1.4.

Здесь легко выделить три функциональных элемента, соответствующие трем видам преобразования энергии:

преобразователь, осуществляющий управляемое преобразование электрической энергии;

двигатель, выполняющий преобразование электрической энергии в механическую, - электромеханический преобразователь;

механизм, осуществляющий передачу механической энергии от вала двигателя через редуктор к рабочему органу - платформе.

При использовании общеизвестных допущений [5] и обозначений координат и параметров такого объекта его динамическое поведение при МС=0 описывается следующей системой линейных дифференциальных уравнений:

1.10

Если компонентами вектора состояния выбрать [image], где Uп – напряжение преобразователя, iя - ток электродвигателя, [image] - скорость вращения электродвигателя, МУ - момент упругости механизма, [image] - скорость вращения механизма, то элементы векторно-матричной модели

1.11

принимают следующий вид:

1.12

После подстановки реальных значений параметров объекта, которые приведены в табл. 1.1, компоненты матриц состояния А и управления В принимают вид (1.13).

1.13

На рис. 1.5. приведено окно редактирования векторно-матричной модели (1.13) в среде Компьютерного комплекса функционального проектирования динамических систем.

Контрольные вопросы к лекции № 1.

1. Какие переменные при построении математического описания системы принято называть

a) входными переменными;

b) выходными переменными;

c) переменными состояния?

2. Математическое описание объекта с одним входом и одним выходом представлено структурной схемой, содержащей q элементов, представленных передаточной функцией общего вида

Как в этом случае можно определить размерность пространства состояния [image] для описания этого объекта?

3. Математическое описание объекта с двумя входами [image] и одним выходом y(t) представлено следующим уравнением в операторной форме

Какова в этом случае будет размерность пространства состояния n для описания этого объекта?

4. Выберите из приведенных ниже записей возможные формы представления уравнения состояния для непрерывных систем.

5. Объект управления имеет r – входов, m - выходов, его математическое описание в непрерывном времени содержит n дифференциальных уравнений первого порядка. Какова в этом случае будет размерность матрицы состояния?

6. Сформируйте векторно-матричную модель фильтра, электрическая схема которого представлена на рис. 1.6.

Здесь следует учесть, что

  • объект имеет один вход - U1 один выход - iH ;все параметры электрической схемы R1, R2, L, C1, C2, RH известны и являются постоянными;
  • могут быть использованы следующие обозначения

7.При составлении математического описания динамических процессов в упругом электромеханическом объекте, влючающем в себя электродвигатель постоянного тока независимого возбуждения (Ф=const) и механизм, модель которого представляется двухмассовой системой (см. пример 1.3), могут быть использованы следующие переменные:

  • iя - ток электродвигателя,
  • - скорость вращения электродвигателя,
  • Му – упругий момент механизма,
  • - скорость вращения механизма,
  • - угол поворота ротора электродвигателя,
  • l – линейное перемещение механизма.

Какие из этих переменных, и в какой последовательности включены в состав вектора состояния [image] приведенной ниже векторно-матричной модели?

ОТВЕТЫ

№ задания | Ответ
1. | a) переменные, характеризующие реакцию системы на входные воздействия; b) переменные, генерируемые системами, внешними по отношению к исследуемой системе; c) промежуточные переменные, характеризующие внутреннее состояние системы.
2. |
3. | n=2
4. | a, e, f, g
5. | (n x n): n – строк и n – столбцов
6. |
7. |