Форум «Всё о Паскале» > Метод Холецкого, метод Краута-Дулитла, LU

Полная версия: Метод Холецкого, метод Краута-Дулитла, LU
Форум «Всё о Паскале» > Образование и наука > Математика
Altair
10.12.2005 1:28
есть ряд вопросов (пока по треминологии)

1. LU разложение.
Предположим коэффициенты матриц L и U мы нашли, что нам это дало ? я не пойму никак.
Чем наша LUx=f лучше чем Ax=f ?

2. чем оличается метод Краута - Дулитла от метода Холецкого ? как я понимаю оба метода используют LU рзложение.
Atos
13.12.2005 6:45
1. Ну просто из одного уравнения получаем два более простых... В принципе, ничего особенного, действительно, это не даёт (почти те же преобразования, как в Гауссе). А в учебнике Вержбицкого по этому поводу говорится, что LU-разложение матрицы А играет роль обратной матрицы, может помещаться в память компьютера на место А и использоваться, например, при решениии нескольких систем, имеющих одну и ту же матрицу коэффициентов и разные правые части.
Краута - Дулитла посмотрю.. по-моему мы его не проходили...
Altair
13.12.2005 18:40
Цитата
Ну просто из одного уравнения получаем два более простых.

да я уже понял
ТОлько имеет ли это смысл для алгоритмирования? неужели этот метод быстрее того же Гаусса ?
Atos
14.12.2005 6:58
Скорее всего, нет...
Слушай, а что это за метод Краута-Дулитла? Яндекс выдал единственную ссылку - на эту тему
Altair
14.02.2006 19:29
Вобщем-то вопрос уже давно решен.
Что бы это не было черной дырой, напомню о теме, и напишу ответ.
Метод Краута Дулитла.
1. теорема о существовании LU разложения.
Всякая квадратная матрица A, удовлетворяющая критерию Адомара,
может быть единственным образом факторизованна (разложенна) на LU, причем
L - нижнетреугольная матрица, U - верхнетр. матрица.
A=L*U.

Критерий адомара - если для квадратной матрицы, все элементы диагонального
преобладания строго положительны, то все ее главные миноры отличны от нуля.

Элемент диагонального преобладания вычисляется по формуле:
Нажмите для просмотра прикрепленного файла

Удобен метод LU факторизации тем, что путем простых вычислений, мы получаем матрицы L и U
и далее, получаем простые системы уравнений, легко решаемые, в отличии от ихсодной.

Фактически, метод LU разложения есть другая схема реализации метода Гаусса.
В некоторой литературе, LU разложение называют методом Холецкого, а в некоторой методом Краута Дулитла.
Это текстовая версия — только основной контент. Для просмотра полной версии этой страницы, пожалуйста, нажмите сюда.